Job-System Hilfe

Übersicht

Informationen

Job-Verwaltung
 Programmelemente
 Menüs der Job Verwaltung
 Ansichtenleiste
 Ordneransicht
 Joblisten
 Gesteuerte Jobs
 Gestartete Jobs
 Protokoll-Archiv
 Computer
 Extras
 Benutzerverwaltung
 Optionen

Jobs
 Eigenschaften
 Start
 Ausführung
 Befehls-Editor
 Tabellen-Editor
 Prüfprotokoll
 Dokumentation

Batchlauf-Modul

PC-Befehle

FTP-Befehle

TelNet-Befehle

Parameter
 Parameterfunktionen

Steuerbefehle

Sonstiges


Allgemeines
Weiter

Das Job-System dient zur Verwaltung und Durchführung von Arbeitsabläufen, die bisher manuell ausgeführt wurden und meist nur umständlich dokumentiert werden können.

Das Job-System besteht aus folgenden Hauptprogrammeinheiten:

Die Job-Verwaltung, die Jobs und das Batchlauf-Modul.

Durch die Implementation von in PC-Produktionsumgebungen notwendigen Befehlen zur Dateibehandlung und direkte Anbindung zu Verarbeitungen auf einem Fernrechner, lassen sich komplette Produktionsabläufe als Job durchführen und abspeichern.

Durch die Ablaufprotokollierung lassen sich für alle ausgeführten Jobs die einzelnen Produktionsschritte nachvollziehen.


Wie arbeitet das Job-System
Zurück Weiter

Die zur Datenverarbeitung benutzten Jobs sind in Textform auf einem Speichermedium abgelegte Befehlsdateien. Sie werden nur vom Namen her in der Job-System Datenbank verwaltet.

Diese Befehlsdateien enthalten Befehlszeilen, die vom Job-System ausgeführt werden.

In den Befehlszeilen können Parameterdefinitionen, Steuerbefehle, Verbindungsbefehle, Dateibefehle und Programmaufrufe stehen.

Enthält eine Befehlsdatei Parameter (eingeschlossen in Begrenzungszeichen; z.B. %), so ist diese Datei nur über das Job-System ausführbar.

Dies geschieht normalerweise, indem man die notwendigen Parameter in den Jobeigenschaften eingibt und den Job startet.

Das Job-System erstellt dann eine ausführbare Befehlsdatei, in der alle Parameter mit den vom Benutzer eingegeben Werten ersetzt werden. Die Befehlsdatei enthält auch keine Programmlogiken mehr, wie z.B. Bedingungen, Schleifen usw.

Mit dieser ausführbaren Befehlsdatei arbeitet dann das Batch-Modul.

Man kann eine ausführbare Befehlsdatei auch gesondert abspeichern, um diese eventuell ohne das Job-System abarbeiten zu können (zum Beispiel um sich einen Job auf dem Desktop abzulegen oder einen Job mit einem Schedule-Programm periodisch ausführen zu lassen).


Notation der Syntax
Zurück

Befehlswörter sind in groß und in FETTSCHRIFT angegeben.

Kursivschrift kennzeichnet Parametertext, der frei gewählt werden kann.

Wörter in GROßSCHRIFT sind optionale Schlüsselwörter.

Eckige Klammern [ ] geben an, dass der folgende Begriff optional angegeben werden kann.

Das Pipezeichen | gibt an, dass nachfolgende Begriffe anstelle des vorherigen Begriffs angegeben werden können

Beispiel:
 Beschreibung=%parameter%=FORMAT([UCASE] | [LCASE] | [0] [,INIT:inhalt | EMPTY] [,LINES:zeilenanzahl ] [,LENGTH:zeichenanzahl ])


Die Job-Verwaltung
Weiter Siehe auch die Job-Verwaltungs Menüs

Mit der Job-Verwaltung können Jobs angelegt, gestartet und Job-Informationen bzw. Job-Protokolle abgerufen werden.

Die Job-Verwaltung hat zwei Elemente zur Bedienung der Programmeinheiten:

Die Ansichtenleiste ermöglicht schnelles Aufrufen und Starten von Jobs.
Die Ordneransicht dient zur strukturierten Anzeige aller vorhandenen Informationen.

Die Taskleiste unterhalb der Fenster zeigt alle geöffneten Fenster. Durch Anklicken der entsprechenden Schalter wird das dazugehörende Fenster in den Vordergrund gebracht.


Job-Verwaltung Menüs
 Zurück

Datei

Neue Jobliste | erzeugt eine leere Jobliste, in die Jobs aus der Liste der vorhandenen Jobs oder aus anderen Jobs kopiert werden können.
Jobliste öffnen... | öffnet ein Dialogfenster zum Auswählen von vorhanden Joblisten. Dort muss aus der Auflistung der vorhanden Benutzergruppen ('Aus Gruppe') eine Gruppe ausgewählt werden. In den darunter erscheinenden Listen dieser Gruppe muss die Gewünschte ausgewählt und geladen werden.
Jobliste speichern | speichert eine neue oder geänderte Jobliste.
Jobliste speichern unter... | speichert die aktuelle Jobliste unter einem anderen Namen oder für eine andere Benutzergruppe ab.
Jobliste importieren... | importiert Joblisten, die mit der letzten Version des Job-Systems benutzt wurden. Es muss unter Umständen der Pfad der Programmdatei des alten Job-System angegeben werden, bevor die Joblistendatei angegeben werden kann.
Datenbank öffnen... | öffnet ein Dialogfenster zum Auswählen einer anderen Job-System Datenbank.
Neuer Job | bringt ein Fenster zum Anlegen eines neuen Jobs.
Job öffnen | öffnet einen in einer Jobliste markierten Job. Ob ein gleicher schon geöffneter Job aufgerufen werden soll kann in den Optionen eingestellt werden.
Job öffnen in neuem Fenster | öffnet einen Job immer in einem neuen Fenster, auch wenn dieser schon geöffnet ist.
Anmelden... | bringt ein Fenster, in dem sich entweder ein anderer Benutzer anmelden kann oder in dem der Benutzer sein Kennwort ändern kann.
Beenden | beendet das Job-System-Programm. Aktuell laufende Jobs werden nicht beendet.

Bearbeiten

Ausschneiden | kopiert einen markierten Job in einer Jobliste in die Zwischenablage und entfernt ihn, sobald er in einer anderen Jobliste eingefügt wird.
Kopieren | kopiert einen markierten Job in einer Jobliste in die Zwischenablage.
Einfügen | fügt einen kopiert Job in eine Jobliste ein.
Löschen | entfernt einen markierten Job aus einer Jobliste.
Suchen | sucht nach einem vorgegebenen Text in den Zeilen einer Jobliste. Alternativ kann auch in den Befehlsdateien der Jobs einer Jobliste gesucht werden.

Ansicht

Symbolleiste | schaltet die Symbolleiste (Werkzeugleiste) ein oder aus.
Ansichtenleiste | schaltet die Ansichtenleiste ein oder aus.
Ordner | schaltet die Ordneransicht ein oder aus.
Taskleiste | schaltet die Taskleiste zur Anzeige der geöffneten Fenster ein oder aus. Über das Kontextmenü der Taskleiste kann das Aussehen und die Position verändert werden.
Statusleiste | schaltet die Statusleiste ein oder aus.

Extras

Gitternetzlinien in Listen | schaltet in allen Auflistungen vertikale und horizontale Trennlinien ein oder aus.
Benutzerverwaltung... | ruft das Fenster zur Verwaltung von Benutzern, Gruppen und Abteilungen auf.
Optionen... | ruft das Fenster mit den Programmoptionen auf.

Fenster

Untereinander | ordnet Fenster innerhalb des Job-System untereinander an.
Nebeneinander | ordnet Fenster innerhalb des Job-System nebeneinander an.
Überlappend | ordnet Fenster innerhalb des Job-System überlappend an.
Alle minimieren | minimiert alle geöffneten Fenster.
Alle wiederherstellen | vergrößert alle minimierten Fenster.
Alle schließen außer | schließt alle Fenster außer den auswählbaren Joblisten oder Jobs.

?

Inhalt... | zeigt die Themenauswahl dieser Hilfe an.
Index... | zeigt den Index der Themen dieser Hilfe an.
Hilfe benutzen | zeigt eine allgemeine Hilfe zur Benutzung von Windows Hilfeseiten an.
Info | zeigt Information über das Job-System an.


Ansichtenleiste

Die Ansichtenleiste ermöglicht schnelles Aufrufen und Starten von Jobs.

Der Schalter 'Jobliste' zeigt im rechten Fenster die Jobliste des Benutzers an.
Der Schalter 'Job' ruft einen aus der Jobliste gewählten Job aus oder zeigt den letzten aufgerufenen Job an.
Der Schalter 'Gestartete' zeigt die Statusliste der gestarteten Jobs an.


Ordneransicht
Weiter

Die Ordneransicht dient zur strukturierten Anzeige aller vorhandenen Informationen.

Dazu gehören folgende Ordner:

'Vorhandene Jobs' enthält Jobs und Joblisten der Benutzer.
'Gesteuerte Jobs' enthält Jobs, die automatisch durch definierte Termine oder Ereignisse ausgeführt werden.
'Gestartete Jobs' zeigt eine Statusliste für gestartete, laufende und beendete Jobs.
'Protokoll-Archiv' enthält alle Protokolle, die von bisher gelaufenen Jobs erzeugt wurden.
'Computer' zeigt die Computer, auf denen das Job-System installiert ist.


Ordner 'Vorhandene Jobs'
Zurück Weiter

Der Ordner 'Vorhandene Jobs' enthält Jobs und Joblisten der Benutzer.

Unterhalb des Ordners wird als Unterordner der Name der Jobliste des Benutzers angezeigt (hier im Beispiel die Jobliste 'Dataview').

Bei dem Benutzertyp 'Support' werden durch Anklicken des Ordners 'Vorhandene Jobs' im rechten Fenster die Jobs angezeigt, die zu der Abteilung des Benutzers gehören und die Jobs, die für alle Abteilungen gelten.

Bei dem Benutzertyp 'Administrator' werden durch Anklicken des Ordners 'Vorhandene Jobs' im rechten Fenster alle Jobs angezeigt, die im Job-System aufgenommen wurden.

Beim Anklicken des Ordners 'Vorhandene Jobs' enthält das rechte Fenster den Titel 'Vorhandene Jobs - Alle'.

Die Jobs werden nach Typ und Beschreibung sortiert aufgelistet.


Joblisten
Zurück Weiter

Joblisten enthalten die Jobs, die für eine bestimmte Gruppe von Benutzern zusammen gestellt wurden.

In der Ordneransicht wird der Name der Jobliste als Unterordner angezeigt (hier im Beispiel die Jobliste 'Dataview').

Durch Anklicken des +- Symbols wird der Ordner der Jobliste auf- bzw. zugeklappt.

Unterhalb des Namens der Jobliste erscheinen bei aufgeklapptem Ordner die Typen der Jobs, die in der Jobliste enthalten sind.

Im Kontextmenü des Joblistnamens gibt es folgende Menüeinträge:

Jobliste entfernen | die Jobliste wird aus der Anzeige der Ordner entfernt. Diese Möglichkeit besteht nur für Administrator- und Support- Anwender.
Joblistnamen filtern | bei Jobtypen, die den Namen der Jobliste enthalten (z.B. 'Dataview-EDD'), kann der Name der Jobliste aus der Anzeige entfernt werden, um die Übersichtlichkeit zu erhöhen. Diese Möglichkeit besteht nur für Administrator- und Support- Anwender.

Durch Anklicken des Namens der Jobliste erscheinen im rechten Fenster alle Jobs, die in der Jobliste enthalten sind. Die Jobs werden nach Typ und Beschreibung sortiert aufgelistet.

Wird in der linken Ordneransicht der Typ eines Jobs angeklickt, erscheinen im rechten Fenster alle Jobs diese Jobtyps.

Durch Doppelklicken auf die Zeile eines Jobs wird der Job geöffnet.

Joblisten erstellen

Über das Menü 'Datei/Neue Jobliste' wird eine leere Jobliste erstellt. Aus der Liste 'Vorhandene Jobs' oder anderen Joblisten können dann Jobs kopiert und in die neue Liste eingefügt werden.

Nach dem Schließen der neuen Jobliste muss bestätigt werden, ob die Änderungen gespeichert werden sollen. Nach der Bestätigung erscheint ein Dialogfenster, in dem die Gruppe ausgewählt werden muss, der die neue Liste zugeordnet werden soll. Außerdem muss ein Name für die Liste angegeben werden.

Joblisten bearbeiten

Jobs können aus Listen gelöscht, verschoben und kopiert werden. Dabei kann das Kopieren auch per Drag&Drop erfolgen. Mit dieser Methode ist es auch möglich Jobs über die Ordneransicht in eine andere Jobliste zu kopieren.


Gesteuerte Jobs
siehe auch Job Planung

Gesteuerte Jobs sind Jobs, die automatisch durch definierte Termine oder Ereignisse gestartet werden können.

In der Ordneransicht können alle Rechner aufgelistet werden, für die Jobs definiert sind.

Die Liste der gesteuerten Jobs kann entweder als Gesamtliste oder selektiert für einen Rechner aufgerufen werden.

Die Liste der gesteuerten Jobs zeigt folgende Informationen:

Computer | ist der Computer, auf dem der geplante Job laufen soll.
Geplanter Job | ist die Beschreibung des geplanten Jobs.
Geplante Ausführungszeit | zeigt, welcher Termin oder welches Ereignis zur Ausführung führt.
Letzter Start | ist die letzte Startzeit des Jobs.
Zuletzt beendet | zeigt, wann der Job zuletzt beendet wurde.
Letzter Status | zeigt den letzten Status des Jobs.
Nächster Termin | zeigt die Zeit der nächsten Ausführung (nur bei zeitgesteuerten Jobs).

Die Menüs der gesteuerten Jobs

Planung von Jobs siehe Job Planung


Gesteuerte Jobs Menüs

Datei

Neuen Job planen... | ruft das Eigenschaftenfenster für einen neu zu planenden Job auf.
Plan ändern... | ruft das Startplanfenster für einen bereits definierten Job auf.
Eigenschaften | ruft das Eigenschaftenfenster für einen bereits definierten Job auf.
Importieren von Lokale Schedule Datei | importiert eine einzelne Definitionsdatei des Job-Schedulers der Version 1.32 des Job-Systems.
Jetzt starten | startet sofort einen in der Liste markierten Job.

Bearbeiten

Deaktivieren | schaltet den Plan eines in der Liste markierten Jobs ein oder aus.
Löschen | löscht einen Job aus der Liste der gesteuerten Jobs.
Nach unten | verschiebt einen markierten Job in der Liste nach unten. Hat keinerlei Auswirkung auf den Plan.
Nach oben | verschiebt einen markierten Job in der Liste nach oben. Hat keinerlei Auswirkung auf den Plan.

Ansicht

Aktualisieren aktualisiert die Liste der gesteuerten Jobs.

Extras

Scheduler anhalten | hält bzw. unterbricht die Überprüfung aller Pläne von gesteuerten Jobs des Rechners an, auf dem das aktuelle Job-System läuft. Der Scheduler wird nicht beendet.
Scheduler deaktivieren | beendet den Scheduler.
Ohne Jobs deaktivieren | bestimmt, ob der Scheduler automatisch beendet wird, wenn alle Jobs gelöscht wurden.
Dauerhaft aktivieren | bestimmt, ob der Scheduler bei Neustart des Rechners automatisch gestartet werden soll. Dies sollte der Normalfall sein, sobald gesteuerte Jobs definiert wurden.
Alle Jobs anzeigen | bestimmt, ob die Liste der gesteuerten Jobs auch Jobs anderer Rechner anzeigen soll.
Protokoll ansehen | ruft das Protokoll des Schedulers auf, in dem Start und Ende des Schedulers selbst und eventuell ausgeführter Jobs enthalten sind.


Job Planung Eigenschaften

Mittels der Job Planung können existierende Jobs gesteuert aufgerufen werden.

Die Steuerung kann aufgrund von zeitlichen Terminen oder Ereignissen erfolgen.

Über das Dateimenü 'Neuen Job planen...' oder 'Eigenschaften' wird das Eigenschaftenfenster aufgerufen.

Folgende Elemente beschreiben die Eigenschaften des zu steuerndes Jobs:

Befehlszeile | muss den vollständigen Dateipfad eines Programms und alle zu übergebenden Parameter enthalten. Enthält der Pfadname Leerzeichen, so muss dieser in Gänsefüßchen eingeschlossen sein. In der aufklappbaren Liste sind alle Befehlszeilen aufgeführt, die bisher für Jobs angegeben wurden. Über den Schalter 'Durchsuchen...' kann das aufzurufende Programm ausgewählt werden.
Status protokollieren | jeder Aufruf der Befehlszeile wird in der Protokolldatei des Schedulers festgehalten (siehe Menü 'Extras/Protokoll ansehen').
Beschreibung | hier kann ein Beschreibungstext eingegeben werden, der in der Liste der gesteuerten Jobs erscheint.
Starten in | definiert das Arbeitsverzeichnis, das zur Ausführung benutzt wird.
Computer von | zeigt den Computer, auf dem der geplante Job laufen soll. Kann nur auf der Ordneransicht 'Gesteuerte Jobs' verändert werden.
Anzeige | bezieht sich auf das Fenster eines aufzurufenden Programms (falls vorhanden). 'Versteckt' unterdrückt eine Fensterausgabe vollständig. 'Normales Fenster' lässt das Fenster in normaler Größe öffnen. 'Minimiert' verkleiner das Fenster. 'Maximiert' vergrößert das Fenster auf volle Bildschirmgröße.
Deaktiviert | kann den Aufruf des Programms durch den Scheduler an- oder ausschalten.
Plan ändern | ruft das Startplanfenster zur Definition von Terminen oder Ereignissen auf.


Gestartete Jobs
Zurück Weiter

'Gestartete Jobs' zeigt eine Statusliste für gestartete, laufende und beendete Jobs.

Die Statusliste kann über die Ordneransicht aufgerufen werden.

Durch Anklicken des Ordners 'Gestartete Jobs' in der Ordneransicht wird die Statusliste der Jobs aufgerufen, die gerade laufen, bisher beendet wurden oder abgebrochen sind.

Durch Anklicken des untergeordneten Ordner 'Laufend' werden nur laufende Jobs angezeigt.

Der Ordner 'Beendet' kann fehlerfrei beendete, abgebrochene und Jobs mit Warnungen anzeigen.

Das Protokoll eines in der Statusliste markierten Jobs kann durch Doppelklick, über den Schalter [image] oder das Datei/Kontext-Menü 'Job öffnen' geöffnet werden.

Bei noch laufenden Jobs kann der tatsächliche Stand vom gezeigten Protokoll abweichen, wenn noch nicht alle Informationen in der Protokolldatei gespeichert sind. Mit dem Untermenüpunkt 'Automatisch aktualisieren' des Menüs 'Extras' kann das automatische Neueinlesen des Protokolls an- oder abgeschaltet werden.

Wurde eine Speicherung des Protokolls im Archiv unterdrückt (NoArchive/NoHistory), so wird bei bereits beendeten Jobs nur das letzte Protokoll geöffnet.

Ein laufender Job kann über das Kontextmenü 'Job abbrechen' in der Liste in den Status 'Abgebrochen' versetzt werden. Der Job selbst wird nicht beeinträchtigt. Ein bereits beendeter Job kann über das Kontextmenü 'Job löschen' aus der Liste gelöscht werden.

Standardmäßig wird die Statusliste alle 20 Sekunden aktualisiert. Dies kann über das Kontextmenü 'automatisch aktualisieren' deaktiviert werden. Über den Schalter [image] kann die Anzeige manuell aktualisiert werden.

Über das Menü 'Nur Jobs der eigenen Gruppe' können Jobs anderer Benutzergruppen ausgeblendet werden.

Die Anzeige der beendeten Jobs kann auf einen bestimmten Zeitraum eingeschränkt werden. Über das Register 'Listen' der Programmoptionen kann eingestellt werden, wie viel Tage lang beendete Jobs in der Statusliste angezeigt werden sollen.

Die Statusliste zeigt folgende Informationen:

Status | kann den Jobzustand 'Laufend', 'Beendet', Warnung' und 'Abbruch' enthalten. Der Zustand 'Warnung' beschreibt einen Job, der beendet ist und bei dem nicht alle Befehle fehlerfrei ausgeführt werden konnten.
Fortschritt | zeigt den prozentualen Bearbeitungsfortschritt der gesamten Befehlszeilen eines Jobs.
Jobname | gibt einen Bezeichner wieder, wenn dieser innerhalb des Jobs mit dem Befehl '/Set Jobname' definiert wurde.
Step/Label | zeigt das 'Label' , mit dem die aktuelle Verarbeitung im Job beschrieben ist.
Typ - Beschreibung | zeigt den Verarbeitungstyp und die Beschreibung, die für einen Job gelten.
Startzeit | zeigt den Zeitpunkt des Start eines Joblaufs.
Endzeit | zeigt den Zeitpunkt des Ende eines Joblaufs.
Gestartet von | zeigt den Benutzername von dem der den Job gestartet hat.
Computer | ist der Name des Computers, auf dem der Job gestartet wurde.
Prozess | ist eine interne Nummer des Betriebssystems des Computers auf dem der Job gestartet wurde.
Priorität | unbenutzt.
Performance | unbenutzt.


Protokoll-Archiv
Weiter siehe auch Protokoll-Archiv Menüs

Das Protokoll-Archiv dient zur Archivierung der Protokolle, die von den Jobs des Job-Systems erstellt werden.
Es kann entweder über die Ordneransicht oder über die Eigenschaften eines Jobs aufgerufen werden.

Bei der Ordneransicht werden alle Protokolle in Ordnern nach Erstellungsjahr und -monat gegliedert. Wenn die Option 'Protokoll-Archiv erst bei Gebrauch laden' aktiviert wurde, wird diese Gliederung nach dem erstmaligen Anklicken sichtbar.
Erst, wenn ein Monatsordner angeklickt wird, erscheint die Liste der Protokolle, die in diesem Monat erstellt wurden.

Das Fenster enthält die Liste mit den in dem Archiv vorhandenen Protokollen und den spezifischen Angaben.
Die Angaben in einer Spalte können durch Anklicken der Spaltenüberschrift sortiert werden.

Folgende Spalten sind vorhanden:

Job | ist der Dateiname des zur Verarbeitung benutzen Jobs ohne Pfad und Dateiendung.
Jobname | gibt einen Bezeichner wieder, wenn dieser innerhalb des Jobs mit dem Befehl '/Set Jobname' definiert wurde.
Status | gibt an, ob der Joblauf abgebrochen ist ('Abbruch'), normal beendet wurde ('Normal') oder eine Warnung enthalten hatte ('Warnung').
Modus | gibt an, ob der Joblauf im normal Modus ('Normal') oder im Einzelschritt Modus ('E-Schritt') gestartet wurde.
Startzeit | zeigt den Zeitpunkt, zu dem der Job gestartet wurde.
Endzeit | zeigt den Zeitpunkt, zu dem der Job beended wurde.
Zeilen | gibt die Anzahl Zeilen des Protokolls aus.
Gestartet von | zeigt den Benutzernamen, mit dem der Benutzer sich angemeldet hatte.

Über den Spalten der Protokoll-Liste befinden sich sieben Eingabefelder , die für Auswahl-Kriterien benutzt werden können.

Dabei entspricht jedes Feld der jeweils darunter liegenden Spalte, außer bei dem Erstellungsdatum. Hier kann mit zwei Eingabefeldern ein Zeitraum definiert werden.

Ein einzelnes Protokoll kann entweder mit einem Doppelklick oder über den Schalter [image] aufgerufen werden.

Sind die Auswahl-Kriterien eingegeben worden, kann mit dem Schalter [image] die Auswahl bestätigt werden und es werden in der Protokoll-Liste nur noch die Protokolle aufgelistet, deren Angaben mit den Kriterien übereinstimmen.

Mit dem Schalter [image] können wieder sämtliche, innerhalb des aktuell gewählten Monats vorhandenen Protokolle aufgelistet werden.

Mit dem Schalter [image] kann eine Aktualisierung der Protokoll-Liste erreicht werden, um eventuell neu aufgenommene Protokolle zu sehen.

Vergleichszeichen:
 Folgende Zeichen innerhalb der Auswahlkriterien haben eine besondere Bedeutung.
* kein, ein oder mehrere beliebige Zeichen
? genau ein beliebiges Zeichen
# genau eine Ziffer


Protokoll-Archiv Menüs
Zurück Weiter

Datei

Protokoll öffnen... | öffnet ein in der Protokoll-Liste selektiertes Protokoll.
Protokoll importieren... | nimmt ein Joblauf Protokoll zusätzlich in das Archiv auf.
Protokoll exportieren... | speichert ein selektiertes Protokoll als Datei ab.
Protokoll-Liste exportieren... | speichert die aktuell zu sehende Protokoll-Liste als Datei ab.

Bearbeiten

Als Auswahl nehmen kann benutzt werden, um Einträge in der Protokollliste in die Eingabefelder für die Auswahlkriterien zu übernehmen. Dazu muss der entsprechende Eintrag in der Protokollliste vorher mit der Maus angeklickt werden.

Extras

Filtern | zeigt die Protokolle der aktuellen Protokollliste, die den eingegebenen Auswahlkriterien entsprechen.
Alle Protokolle anzeigen | zeigt alle Protokolle der aktuellen Protokollliste an.


Protokoll
Zurück Weiter siehe auch Protokoll Menüs

Ein Protokoll enthält alle Befehle und deren Protokollausgaben, die ein Job zur Laufzeit erzeugt hat. Außerdem werden Laufzeitinformationen und Parameter gezeigt, die der Benutzer eingegeben hat.

Prokolle können über das Protokoll-Archiv oder über die Eigenschaften eines Jobs aufgerufen werden.

Bei einem Protokoll eines laufenden Jobs kann die Ansicht mit dem Schalter [image] aktualisiert werden.

Der Schalter [image] zeigt die normale Ansicht, mit der Zeilen über den Rand des Fenster hinausgehen und mit den Rollbalken verschoben werden können.

Mit dem Schalter [image] kann die Ansicht auf Zeilenumbruch geschaltet werden, sodass immer die komplette Zeile im Fenster sichtbar ist.

Mit dem Schalter [image] kann auf hexadezimale Ansicht geschaltet werden. Dabei wird unterhalb jeder Zeile jedes Zeichen der Zeile nochmals mit seiner hexadezimalen Kodierung dargestellt. Hierbei ist zu beachten, dass nicht der komplette Inhalt zu sehen ist, wenn die maximal sichtbare Anzahl Bytes überschritten ist. Will man Zeilen sehen, die darunter liegen, so muss man das Menü 'Ansicht/Hex/Ab Cursorzeile' wobei die Anzeige ab der Zeile beginnt, auf der der Textcursor gesetzt wurde.

Der Schalter [image] ist aktiviert, wenn im Protokoll eine Fehlermeldung des Job-Systems vorhanden ist. Dann kann man mit dem Schalter auf die nächste Zeile springen, in der ein Fehler angezeigt wurde. Eine Fehlermeldung kann folgendermaßen aussehen:

Folgende Laufzeitinformationen werden im Protokoll ausgegeben:

Vollständiger Dateiname der Befehlsdatei mit Zeitpunkt von Start und Ende.

OS | Version des Betriebssystems.
LanguageNumber | ID der Sprache mit der der Job gestartet wurde.
Processor | Anzahl und Typ der Prozessoren des Computers.
ComputerName | Name des Computers im Netzwerk.
Username | Benutzername, mit dem das Job-System auf dem Computer angemeldet wurde.
Jobname | Name des Jobs, falls dieser mit dem Befehl '/Set Jobname' definiert wurde.
JobOwner | Name des Benutzers, der den Job gestartet hat.
JobOwnerGroup | ID der Gruppe des JobOwners. Ist in der Benutzerverwaltung mit dem Namen verknüpft.
JobOwnerDepartment | ID der Abteilung des JobOwners. Ist in der Benutzerverwaltung mit dem Namen verknüpft.
JobID | interne ID des Jobs im Job-System.
SJobID | Jobnummer des gestarteten Jobs. Erscheint in der Statusliste der gestarteten Jobs.

Parameterinhalte werden dunkelrot angezeigt.
Labeltext werden grün angezeigt.
Zeilenkennzeichner werden blau gezeigt.
Fehlerkennzeichner werden hellrot angezeigt.

Hat eine Protokolldatei mehr als 50000 Zeichen, so muss über das Menü 'Gehe zu' oder mit dem Seitenschalter [image] auf den nächsten Seitenblock oder mit [image] an das Ende der Protokolldatei geblättert werden.


Protokoll Menüs
Zurück

Datei

Speichern als... speichert das Protokoll als Datei ab.

Bearbeiten

Nächsten Fehler suchen...

ist aktiviert, wenn im Protokoll eine Fehlermeldung vorhanden ist. Dann kann man damit auf die nächste Zeile springen, in der ein Fehler angezeigt wurde. Eine Fehlermeldung kann folgendermaßen aussehen:

Ansicht

Normal | zeigt die normale Ansicht, mit der Zeilen über den Rand des Fenster hinausgehen und mit den Rollbalken verschoben werden können.
Zeilenumbruch | schaltet die Ansicht auf Zeilenumbruch um, sodass immer die komplette Zeile im Fenster sichtbar ist.
Hex | schaltet auf hexadezimale Ansicht. Dabei wird unterhalb jeder Zeile jedes Zeichen der Zeile nochmals mit seiner hexadezimalen Kodierung dargestellt. Hierbei ist zu beachten, dass nicht der komplette Inhalt zu sehen ist. Bei der Option 'Ab Textbeginn' beginnt die Anzeige mit der ersten Zeile. Mit der Option 'Ab Cursorzeile' beginnt die Anzeige ab der Zeile, auf der der Cursor steht.
Aktualisieren aktualisiert die Ansicht bei einem Protokoll eines laufenden Jobs.

Extras

Automatisch aktualisieren Bei einem Protokoll eines laufenden Jobs kann das automatische Aktualisieren an- oder abgeschaltet werden.


Computer
Zurück

Das Fenster 'Computer' zeigt die Computer, auf denen das Job-System installiert ist.

Es kann über die Ordneransicht aufgerufen werden.

Folgende Spalten sind vorhanden:

Markierungskästchen | zeigt an, ob der Computer für die Gruppe des Benutzers freigegeben wurde.
Computer | zeigt den Namen des Computer, wie er in der Netzwerkumgebung bzw. im Betriebssystem definiert ist.
Bezeichnung | enthält den Namen des Benutzers. Kann über das Kontextmenü beliebig geändert werden.
Adresse | zeigt die IP-Adresse des Computer.
Job-System Status | zeigt, ob das Job-System auf diesem Computer läuft oder nicht.
Job-System gestartet | zeigt die Zeit, wann das Job-System auf diesem Computer gestartet wurde.
Job-System beendet | zeigt die Zeit, wann das Job-System auf diesem Computer beendet wurde.
Benutzergruppe | enthält die Gruppe, zu der der Benutzer gehört.
Benutzer | enthält den Benutzernamen, mit dem das Job-System gestartet wurde (ändert sich nicht, wenn über das Job-System der Benutzer gewechselt wurde).

Über das Kontextmenü kann ein Benutzer mit Administratorrechten einen Computer aus der Liste löschen.

Über das Kontextmenü 'automatisch aktualisieren' kann eine Aktualisierung alle 20 Sekunden eingeschaltet werden. Über den Schalter [image] kann die Anzeige manuell aktualisiert werden.


Benutzer und Gruppen
Weiter

Über dieses Register der Benutzerverwaltung werden Benutzer definiert, die das Job-System benutzen. Die Benutzerverwaltung wird über das Menü 'Extras' aufgerufen.

Folgende Felder stehen für die Benutzerdaten zur Verfügung

Vorname, Nachname, Rolle und Benutzername müssen angegeben werden. Das Kennwort kann optional vergeben werden.

Neuanlage eines Benutzers

Für eine Neuanlage müssen die Felder des Benutzers ausgefüllt und mit dem Schalter 'Aufnehmen' bestätigt werden.

Für die Zugriffsberechtigung gibt es folgende Rollen:

Administrator | Alle Zugriffrechte stehen zur Verfügung.
Support | Innerhalb der zugeordneten Abteilung können Gruppen und Benutzer angelegt, Joblisten erweitert und Jobs bearbeitet, sowie gestartet werden.
Anwender | Jobs der zugeordneten Joblisten können gestartet werden.

Nach der Neuaufnahme erscheint der Benutzername in der Liste 'Benutzer' des Bereichs 'Benutzergruppen'.

Das leere Kästchen links neben dem Namen bedeutet, dass der Benutzer noch keiner Gruppe zugeordnet ist.

Zurordnen eines Benutzers zu einer Gruppe

Falls schon Gruppen definiert wurden, sind diese in der rechten Liste 'Gruppen' zu sehen. Die Gruppe 'Administratoren' ist nur verfügbar für Benutzer mit der Rolle 'Administrator'.

Durch Selektieren einer vorhandenen Gruppe werden alle zu dieser Gruppe gehörenden Benutzer in der Liste 'Benutzer' angezeigt. Auch ein nicht zugeordneter Benutzer wird in der Liste angezeigt. Wenn man diesen selektiert, wird der Schalter 'Zuordnen' aktiviert. Mit diesem Schalter kann dann der Benutzer der Gruppe zugeordnet werden. Das Kästchen neben dem Namen enthält dann ein Häkchen und der Benutzer wird dann nur noch bei dieser Gruppe mit aufgelistet.

Entfernen eines Benutzers aus einer Gruppe

Durch Selektieren einer Gruppe der Liste 'Gruppen' werden alle zu dieser Gruppe gehörenden Benutzer in der Liste 'Benutzer' angezeigt. Ein Kästchen mit einem Häkchen links neben dem Benutzernamen bedeutet, dass der Benutzer der selektierten Gruppe zugeordnet ist. Wird dieser selektiert, wird der Schalter 'Entfernen' aktiviert. Mit diesem kann dann der Benutzer aus der Gruppe entfernt werden.

Ändern oder Löschen eines Benutzers

Durch Selektieren einer Gruppe in der Liste 'Gruppen' werden alle zu dieser Gruppe gehörenden Benutzer in der Liste 'Benutzer' angezeigt. Erst wenn ein Benutzer in der Liste angeklickt wird, erscheinen seine Daten in den Feldern des Bereichs 'Benutzer'.

Dann werden auch die Schalter 'Ändern' und 'Löschen' aktiv, mit denen Änderungen übernommen werden oder der Benutzer gelöscht werden kann.


Optionen Allgemein
Weiter

Über die Optionen des Menüs 'Extras' können Einstellungen gemacht werden, die das Verhalten des gesamten Job-Systems steuern.

Folgende Optionen sind möglich:

Sprache nach Ländereinstellung | Es wird automatische die Sprache übernommen, die in der Ländereinstellung der Systemsteuerung eingestellt ist. Dies ist nur für Sprachen möglich, für die eine Sprachdatei existiert.
Direkte Auswahl | Ermöglicht die Wahl der Sprache aus der Liste der Sprachen, für die eine Sprachdatei existiert. Achtung! die Ausführung eines Jobs und die Ausgabe des Protokolls wird immer mit der Ländereinstellung der Systemsteuerung durchgeführt.
Hintergrundbild anzeigen | Schaltet die Anzeige eines Bildmusters an oder aus, dass als Hintergrund für das Fenster des Job-Systems benutzt wird.
XP Schema für Steuerelemente | Unter Windows XP können so genannte Schemen bzw. Themes für das Layout der Standardelemente des Betriebssystems gewählt werden. Mit dieser Option wird das Layout eines gewählten Schemas auch für die Standardelemente des Job-Systems übernommen.
Animationen anzeigen | Mit einem zusätzlichen Modul, das auf der Microsoft Agent Technologie basiert, können animierte Figuren in die Programmumgebung des Job-System eingebunden werden. Für einige Funktionen des Job-System wurden Animationensbewegungen und Beschreibungen integriert.
SMTP für EMail benutzen | Für E-Mail Sendungen ist die Angabe einer SMTP Gateway Adresse notwendig. Zu Beachten ist, dass eine Änderung dieser Adresse für die gesamte Installation gültig ist. Deswegen können nur Benutzer mit Administratorrechten Änderungen vornehmen.
Modus für langsame Verbindung | Zeigt an, ob die Verbindung zu den Datenbank Tabellen mehr als 3 Sekunden benötigt. In diesem Fall werden keine Status Informationen an die Datenbank zurückgeliefert um Laufzeitprobleme zu vermeiden..
Support Verbindung aktiviert | Bei Aktivierung wird geprüft, ob die Internetseite "www.Job-System.info/Notify" existiert. Wenn ja, werden Statusmails an die Adresse "JMarkart@online.de" gesendet. Kann nur von Benutzern mit Administratorrechten geändert werden.
Diesen Rechner für die Gruppe freigeben | Mit dieser Option wird es möglich, von einem anderen Rechner aus, einen Job auf dem aktuellen Rechner zu starten. Dies ist natürlich nur für Benutzer möglich, die zur gleichen Gruppe des aktuellen Benutzers gehören.


Jobs
Weiter

Jobs sind Beschreibungen von Prozessen, die von bestimmten Gruppen bzw. Abteilungen ausgeführt werden müssen. Die Beschreibung eines Jobs ist auf verschiedene Seiten aufgeteilt, um die einzelnen Details besser darstellen zu können.

Folgende Seiten werden angezeigt:

'Eigenschaften' zeigen organisatorische Daten, Laufzeitdaten und notwendige Parameter.
'Start' zeigt die zum Joblauf notwendigen Parameter und dient zum Starten des Jobs.
'Ausführung' zeigt den Job während des Laufes.
'Befehle' zeigt den Befehlseditor mit den Befehlen, die für den Job ausgeführt werden müssen.
'Vorschau' zeigt die Befehlszeilen, die tatsächlich ausgeführt werden.
'Dokumentation' zeigt die Beschreibungen und Kommentare, die in den Befehlen stehen.

Passen die Schalter zum Anwählen der Seiten nicht in das Fenster, so werden am rechten Rand Schalter eingeblendet, mit denen die Seitenschalter verschoben werden können. Über die Programmoptionen können die Symbole der Seitenschalter unterdrückt werden.

Die Job Menüs


Seite Eigenschaften
Zurück Weiter

Die Seite der Jobeigenschaften zeigt organisatorische Daten, Laufzeitdaten und notwendige Parameter.

Allgemeine Informationen

Verarbeitungstyp : | beschreibt das Produkt, für was der Job laufen muss. Erscheint in der Ordneransicht der Joblisten und in der Jobliste
Abteilung : | zeigt die Abteilung der Gruppe, die den Job starten muss. Erscheint in der Jobliste
Beschreibung : | Kurzbeschreibung, was der Job macht. Erscheint in der Jobliste
Befehlsdatei : | der Dateiname der Befehlsdatei, die die Befehle des Jobs enthält
Bearbeitet : | Datum der letzten Änderung der Befehlsdatei. Erscheint in der Jobliste
von : | der Benutzername des Bearbeiters, der mit dem Job-System die Befehlsdatei zuletzt bearbeitet hat. Erscheint in der Jobliste

Der Schalter 'Starttermin festlegen' übergibt den Job und die Parameterinhalte an den Job-System Scheduler, der unter 'Gesteuerte Jobs' der Ordneransicht zu finden ist.

Beschreibung aus Befehlsdatei :

Dieser Schalter ist nur für Benutzer mit Administrations- oder Support- Rechten benutzbar. Er zeigt, ob der Verarbeitungstyp und die Beschreibung aus der Befehlsdatei entnommen sind. Dabei wird die erste gefundene Kommentarzeile untersucht. Der Aufbau des Kommentars sollte sein 'Verarbeitungstyp - Beschreibung'. Der Verarbeitungstyp wird linksbündig aus dem Text, der mit einem Leerzeichen und einem Bindestrich ' - ' begrenzt ist extrahiert. Die Beschreibung wird ab dem Bindestrich übernommen.

Informationen zum Lauf

Im mittleren Block der Jobeigenschaften werden Informationen zum aktuellen oder zum letzten Joblauf gezeigt.

'UserID ' zeigt den letzten Benutzer, der den Job gestartet hat.

Folgende Statusinhalte können vorkommen:

Neu | Der Job wurde neu in das System aufgenommen und ist noch nie gestartet worden
Läuft | Der Job wurde gestartet und ist noch nicht beendet
Abbruch | Der Job wurde entweder vom Benutzer oder vom Batchlauf-Modul abgebrochen
Warnung | Der Job wurde beendet, aber es konnten nicht alle Befehle fehlerfrei ausgeführt werden
Beendet | Der Job wurde fehlerfrei beendet

Mit dem Schalter 'Protokoll' kann das Protokoll des letzten Laufes dieses Jobs angezeigt werden. Gezeigt wird nur das Protokoll von dem Lauf, der auf dem Rechner gestartet wurde, auf dem das Job-System läuft (siehe Speicherung der Protokolle).

Mit dem Schalter 'Archiv' können die Protokolle aller bisherigen Läufe dieses Jobs über das Protokoll-Archiv angezeigt werden.

Job-Parameter

Im unteren Block der Jobeigenschaften erscheinen alle Parameter, die für den Job ausgefüllt werden müssen, bevor er gestartet werden kann. Diese Parameter werden auch auf der Seite 'Start' angezeigt. Die Inhalte sind nur auf der Seite 'Start' vollständig bearbeitbar.

Die Beschreibung aller möglichen Parameterarten ist bei der Beschreibung von Parametern und Parameterfunktionen zu finden.

Beim Aufruf der Jobeigenschaften werden immer die Parameterinhalte angezeigt, die entweder vom Job vorgegeben werden, oder die der Benutzer zuletzt eingegeben hat.

Besteht ein Job-Parameter aus einer Tabelle wie z.B. in obigem Bild der Parameter 'DB', so kann durch Rechtsklick über ein Kontextmenü 'Tabelle bearbeiten...' diese Tabelle mit dem Tabellen-Editor bearbeitet werden.

Wenn man mit der rechten Maustaste auf eine freie Fläche des Jobeigenschaften-Fensters klickt, erscheint der Menüpunkt 'Hilfe', der diese Hilfe-Seite aufruft.


Seite Start
Zurück Weiter

Mit der Seite 'Start' kann ein Job gestartet werden.

Das Feld 'Typ - Beschreibung' enthält den Verarbeitungstyp und die Beschreibung des Jobs.

Im Block 'Job-Parameter' erscheinen alle Parameter, die für den Job ausgefüllt werden müssen, bevor er gestartet werden kann. Wenn man mit der Maus darüber steht, erscheint bei Parameterfeldern, die entsprechend definiert wurden, ein Tooltip mit Formatangaben.

Die Beschreibung aller möglichen Parameterarten ist bei der Beschreibung von Parametern und Parameterfunktionen zu finden.

Beim Aufruf der Seiten 'Start' oder 'Eigenschaften' werden immer die Parameterinhalte angezeigt, die entweder vom Job vorgegeben werden, oder die der Benutzer zuletzt eingegeben hat.

Der Hinweistext 'Einzelschrittmodus !' erscheint, wenn über das Menü 'Extras' der Modus 'Job schrittweise ausführen' gewählt wurde (siehe Batchlauf-Modul im Einzelschritt-Modus ).

Die Checkbox 'Jobmeldungen mit Klang' erscheint nur, wenn der Job den Befehl 'MSG' mit Zusatzbefehlen für Klangausgabe enthält. Damit kann der Benutzer vor dem Start entscheiden, ob diese Klangzusatzbefehle ausgeführt werden sollen.

Die 2 Ampelsignale zeigen an, ob alle Parameter gefüllt sind und der Job gestartet werden kann.

Der Schalter 'Job Starten' startet einen Job, indem er das Batchlauf-Modul aufruft. Sind noch nicht alle Parameter eingegeben, erscheint eine Fehlermeldung und das Feld mit fehlendem Inhalt wird aktiviert.

Nach dem Start des Batchlauf-Moduls wird die Seite 'Ausführung' angezeigt.

Die Auswahlliste 'auf Computer' ist sichtbar, wenn ein anderer Rechner für die eigene Gruppe freigegeben wurde. Er kann dann zum Ausführen des Jobs ausgewählt werden. Für Benutzer mit der Rolle 'Administrator' werden alle verfügbaren Rechner aufgelistet. Vorhandene und verfügbare Rechner sind in der Ordneransicht in 'Computer' aufgelistet.

Wird das Fenster des Jobs mit dem Schalter 'Schließen' geschlossen, werden alle eingegebenen Parameter mit den in der Befehlsdatei definierten Parameternamen gespeichert..

Wird das Fenster des Jobs über das Fenstermenü oder mit dem Schalter zum Schließen von Fenstern geschlossen, werden eingegebene Parameter nicht gespeichert..

Wird der Menüpunkt 'Job schrittweise ausführen' aktiviert, kann die Ausführung für jede Zeile des Jobs einzeln vorgenommen werden. Das Batch-Modul wird dann im Einzelschritt-Modus gestartet. Die Aktivierung dieses Menüpunktes wird nach dem Verlassen des Job-Systems nicht gespeichert.


Seite Ausführung
Zurück Weiter

Diese Seite wird während der Ausführung eines Jobs angezeigt.
Solange kein Job gestartet wurde, kann nur die Seite 'Start' angezeigt werden.

Auf dieser Seite ist die Ausführung des Batchlauf-Moduls zu sehen.

Ausführliche Erklärung unter 'Batchlauf-Modul im Normal-Modus' und 'Batchlauf-Modul im Einzelschritt-Modus'.

Ist der Batchlauf mit einem Fehler abgebrochen, wird automatisch das Protokoll des Batchlaufs angezeigt.


Seite Befehle
Zurück Weiter siehe auch Job Menüs

Die Seite 'Befehle' dient zum Erstellen von Jobs mit Parameterdefinitionen und Befehlszeilen.

Das Fenster enthält den Job mit den Kommandos.

Folgende spezielle Elemente bietet die Werkzeugleiste für den Befehlseditor.
Suchen und Weitersuchen von Text innerhalb der Befehlszeilen.
Rückgängig machen oder Wiederholen einer Textänderung.
ruft den Tabelleneditor auf, wenn innerhalb des Textes ein Datei mit Datensätzen einer Tabelle markiert wurde. Ruft Microsoft® Access® auf, wenn der Befehl 'TABLE' markiert wurde und dieser sich auf Datenbanktabelle bezieht. Siehe Job Menü 'Tabellensätze bearbeiten...'.
versetzt das Programm in den Tastenaufzeichnungsmodus. Der Schalter verändert sich zu [image] , das Programmfenster wird minimiert und Tastendrücke werden aufgezeichnet. Der Modus wird beendet, durch Vergrößern des Programmfensters und erneutem Anklicken des Schalters. In der Statusleiste erscheinen die aufgezeichneten Tastensymbole.
zeigt den Inhalt von Parametern, die zuvor markiert wurden, in der Statusleiste an.
zeigt eine Befehlsreferenz. Es erscheint eine Liste mit allen zur Verfügung stehenden Befehlen. Die Syntax der Befehle wird in der Statusleiste ausgegeben. Nach Anwahl eines Befehles kann mit der Taste 'F1' die entsprechende Hilfe aufgerufen werden.
verschiebt markierte Zeilen nach rechts oder links um eine bestimmte Anzahl Stellen. Die Stellenanzahl kann in den Optionen angegeben werden.
markierte Zeilen werden auskommentiert oder wieder aktiviert.

Innerhalb des Textes des Jobs kann man für jeden definierten Befehl oder Zeichen die Hilfe aufrufen, indem man den Cursor darauf platziert und die Taste 'F1' drückt oder das Kontextmenü aufruft.

Ist die Code-Färbung aktiviert, so werden Labels, also Zeilen, die mit einem Doppelpunkt beginnen, in grüner Fettschrift dargestellt (siehe Optionen).


Seite Vorschau
Zurück Weiter

Mit dieser Seite werden die Befehlszeilen geprüft und ausgegeben, so wie sie für einen Joblauf ausgeführt werden.

Alle Parameter werden mit ihren Inhalten gefüllt und in den Befehlszeilen ersetzt.

Jede Zeile, die einen ausführbaren Befehl enthält, wird mit einer Zeilennummer ausgegeben.

Durch Anklicken einer Zeile und anschließendem Aufruf der Seite 'Befehle', wird der Befehlsbereich angezeigt, in dem der Befehl definiert wurde.

Die Vorschau wird jedes Mal neu aufgebaut, sobald entweder der Befehlstext geändert oder ein anderer Parameterinhalt eingegeben wurde.

Treten Fehler bei der Generierung der Befehlszeilen auf, so wird die Generierung abgebrochen und eine Fehlermeldung im Protokoll ausgegeben.


Seite Dokumentation
Zurück Weiter

Mit dieser Seite können Label, Kommentare, Parameter und Programme aufgelistet werden.

In der ersten Zeile wird der Dateiname der Befehlsdatei ausgegeben.
Darunter folgt die erste Kommentarzeile, die den Job beschreiben sollte.
Durch Aktivieren oder Deaktivieren der entsprechenden Wahlschalter können Kommentare, Parameter und Programme ein- oder ausgeblendet werden.

Alle Zeilen, die mit einem Semikolon und einer Leerstelle beginnen, sowie einen nachfolgenden Text enthalten, werden als Kommentarzeilen ausgegeben. Zeilen, die mit Kommentarzeichen ohne nachfolgender Leerstelle beginnen, werden als deaktivierte Befehlszeilen angenommen und nicht angezeigt. Innerhalb von 'INLINE' Abschnitten muss ein Hochkomma vor das Semikolon gesetzt werden.

Werden Programme ausgewählt, so werden alle Programme gezeigt, die vom Job-System nicht intern ausgeführt werden, sowie Befehle, die externe Programmmodule benutzen.


Job Menüs
Zurück

Datei

Neue Befehlsdatei | leert den aktiven Befehls-Editor für eine vollständig neue Eingabe.
Befehlsdatei öffnen... | öffnet eine zu wählende Befehlsdatei und lädt sie in den Befehls-Editor.
Befehlsdatei speichern | speichert Änderungen der aktuellen Befehlsdatei. Eine bereits vorhandene Befehlsdatei gleichen Namens wird mit der zusätzlichen Endung '.Backup' umbenannt.
Befehlsdatei speichern unter... | speichert Änderungen der aktuellen Befehlsdatei unter einen zu wählenden Namen.
Ausführbare Batchdatei speichern... | erstellt und speichert eine Batchdatei, die mit dem Batchlauf-Modul unabhängig vom Job-System aufgerufen werden kann (siehe auch 'JSBATCH'). Dazu müssen alle Parameter des Jobs gefüllt sein. Ist nur für Administrator- und Support- Anwender verfügbar.
Job speichern | speichert Änderungen, die sich bei den Definitionen des Jobs ergeben haben. Dies kann auch eine Änderung der ersten Kommentarzeile der Befehlsdatei sein, die zur Beschreibung des Jobs benutzt wird.
Drucken... | bezieht sich immer auf den Inhalt der angezeigte Seite.

Bearbeiten

Suchen... | sucht einen angegebene Text innerhalb der Befehlszeilen.
Weitersuchen | führt die zuvor gewählte Suche fort.
Ersetzen... | ruft ein Eingabefenster auf, mit dem ein Text durch einen anderen Text im Befehls-Editor ersetzt werden kann. Dabei kann die Ersetzung für jeden einzelnen gefundenen Text erfolgen oder für alle auftretenden Texte in einem Schritt.
Blockeinzug vergrößern | verschiebt markierte Zeilen um jeweils die Anzahl Stellen nach rechts, die in den Programm-Optionen definiert wurde.
Blockeinzug verkleinern | verschiebt markierte Zeilen um jeweils die Anzahl Stellen nach links, die in den Programm-Optionen definiert wurde.
Block auskommentieren | deaktiviert markierte Zeilen, indem das Kommentarzeichen Semikolon ';' davor gestellt wird.
Block aktivieren | entfernt die Kommentarzeichen Semikolon, die vor markierten Zeilen stehen.
Datei bearbeiten... | wird aktiviert, sobald der Benutzer in dem Befehlstext eine existierende Datei markiert hat. Ist die Dateigröße kleiner als 65000 Bytes, wird diese dann mit dem Systemprogramm 'Notepad' aufgerufen. Andernfalls ändert sich der Menüpunkt in 'Markierte Datei ansehen... ' und die Datei wird mit dem Job-System eigenen Programm 'View' angezeigt.
Tabellensätze bearbeiten... | wird aktiviert, sobald der Benutzer in dem Befehlstext einen Text markiert hat. Handelt es sich um eine zu der Parameterfunktion TABLE gehörende externe Tabellendatei, so können deren Datensätze mit dem Tabellen-Editor bearbeitet werden. Handelt es sich um einen Text innerhalb einer TABLE Funktion, die sich auf eine Datenbanktabelle bezieht, so wird dazu Microsoft® Access® aufgerufen. Enthält die Microsoft® Access® Datenbank ein Makro mit dem Namen 'OPENtabellenname' wobei tabellenname der in der TABLE Funktion definierten Tabelle entspricht, so wird dieses Makro gestartet. Dies kann dazu benutzt werden, um z.B. dem Benutzer eine Tabelle im maximierten Fenster zu öffnen.
Tabellendefinition bearbeiten... | wird aktiviert, sobald der Benutzer in dem Befehlstext einen Text markiert hat. Handelt es sich um einen Text innerhalb der Parameterfunktion TABLE, so wird der Tabellen-Editor für Definitionen mit den Definitionszeilen der Tabelle aufgerufen.
Tastendrucke aufzeichnen | zeichnet Tastendrucke auf, die man nach dem Anwählen dieser Funktion eingibt. Nach dem Aktivieren des Menüpunktes wird das Batchprogramm minimiert und danach werden alle Tastendrucke solange aufgezeichnet, bis dieser Menüpunkt wieder deaktiviert wird. Dann erscheinen die aufgezeichneten Tastendrucke zusammen mit dem Befehl 'SENDKEYS' in der Statuszeile. Beim ersten Aufruf dieser Funktion werden wahrscheinlich noch Tastendrucke aus dem Tastaturpuffer mit übernommen, so dass es besser ist, erst beim zweiten Aufruf mit der eigentlichen Aufzeichnung zu beginnen.
Tastendrucke einfügen | fügt zuvor aufgezeichnete Tastendrucke zusammen mit dem Befehl 'SENDKEYS' in den Text der Befehlsdatei ein.
Fenstertitel kopieren | kann den Fenstertitel eines fremden Programms in die Zwischenablage kopieren. Dies kann für die Option '{TOWINDOW ' fenstertitel '} ' des Befehls 'SENDKEYS' benutzt werden. Nach der Anwahl dieses Menüpunktes ist es möglich mit der Maus über ein Fenster eines Fremdprogramms zu fahren und sich in der Statuszeile des Batch-Editors dessen Titel anzusehen. Wenn man dann mit der Maus auf dieses Fenster klickt, wird der Titel in die Zwischenablage kopiert und kann dann in obengenannter Option eingefügt werden. Am besten ist es den Mauszeiger aus dem Job-System Fenster hinaus direkt in das Fremdprogrammfenster zu bewegen.

Ansicht

Parameterinhalt | zeigt den Inhalt eines Parameters (in %-Zeichen eingeschlossener Name), wenn im Befehls-Editor ein entsprechender Parameter markiert wurde.
Definition | sucht das erste Vorkommen eines Parameters, wenn im Befehls-Editor ein entsprechender Parameter markiert wurde.
Letzte Position | zeigt nach dem Aufruf des Menüs 'Definition' die zuvor gesehene Stelle im Text.

Extras

Batch-Job schrittweise ausführen | aktiviert die Einzelschrittausführung, bei der jede Zeile des Batch-Jobs einzeln ausgeführt werden kann. Das Batch-Modul wird dann im Einzelschritt-Modus gestartet. Die Aktivierung dieses Menüpunktes wird nach dem Verlassen des Jobs nicht gespeichert.
Markiertes Programm ausführen... | kann ein im Befehls-Editor markiertes Programm direkt ausführen.

Hilfe

Hilfedatei für Scriptsprache

zeigt eine Hilfedatei, die über die Optionen bestimmt werden kann.


Tabellen-Editor
siehe auch Tabellen-Editor-Menüs und Tabellen-Editor für Definitionen

Mit dem Tabellen-Editor können Datensätze von Tabellen bearbeitet werden, die für einen Job als Parameter definiert wurden. Diese Tabellen werden in den Befehlen des Jobs mit den Funktionen 'TABLE' und 'TABLESELECT' benutzt. Die eventuell bei diesen Funktionen benötigten Spalten- und Zeilentrennzeichen sowie Tabellenabschlusszeichen werden automatisch erzeugt.

Der Tabellen Editor wird im Befehlseditor (Seite 'Befehle') eines Jobs über den Menüpunkt 'Bearbeiten/Tabellensätze bearbeiten...' aufgerufen, wenn es sich um eine Tabelle in einer externen Datei handelt. Bei Tabellenzeilen, die in einer externen Datei oder Datenbank enthalten sind, kann der Tabellen-Editor auch über das Kontextmenü der erzeugten Tabelle im Parameterteil der Job-Eigenschaften aufgerufen werden.

Es gibt zwei Ansichten zum Bearbeiten von Tabellensätzen.

Die Tabellen Ansicht und die Datensatz Ansicht

Die Bedienung des Editors in der Tabellen Ansicht gleicht der Bedienung von Microsoft® Access®.

Das Tabellen-Fenster

Mit den Schaltern [image] und [image] in der Toolbar kann eine markierte Spalte entweder auf- oder absteigend sortiert werden.

Mit dem Schalter [image] kann in die Datensatz Ansicht umgeschaltet werden. Dabei wird der in der Tabelle aktuell markierte Datensatz angezeigt.

In der obersten Zeile werden die Feldnamen ausgegeben.
Die Inhalte der einzelnen Zellen können direkt in der Tabelle eingegeben werden.
Der Datensatzzeiger [image] zeigt den aktuellen Datensatz an. Die schwarze Markierung zeigt, dass der komplette Satz kopiert werden kann.

Wenn der Tabellen Editor im Bearbeitungsmodus aufgerufen wurde, enthält die letzte Zeile immer das Kennzeichen für einen neuen Datensatz [image] . Nur dort kann ein neuer Satz eingefügt werden.

Links unten, neben dem Schalter zum Scrollen nach links, befindet sich ein Element [image] zum vertikalen Aufteilen der Tabellenanzeige. Damit ist es möglich zwei und mehr verschiedene Bereiche der gleichen Tabelle nebeneinander zu zeigen.


Tabellen-Editor für Definitionen
siehe auch Tabellen-Editor-Menüs

Mit dem Tabellen-Editor können Definitionen von Tabellen bearbeitet werden, die für einen Job als Parameter definiert sind. Diese Tabellen werden in den Befehlen des Jobs mit den Funktionen 'TABLE' und 'TABLESELECT' benutzt.

Der Tabellen Editor wird im Befehlseditor (Seite 'Befehle') eines Jobs über den Menüpunkt 'Bearbeiten/Tabellendefinitionen bearbeiten...' aufgerufen.

Die Bedienung des Editors in der Tabellen Ansicht gleicht der Bedienung von Microsoft® Access®.

Das Tabellen-Fenster

Mit den Schaltern [image] und [image] in der Toolbar kann eine markierte Spalte entweder auf- oder absteigend sortiert werden.

Mit dem Schalter [image] kann in die Datensatz Ansicht umgeschaltet werden. Dabei wird der in der Tabelle aktuell markierte Datensatz angezeigt. Allerdings werden dann keine vordefinierten Anzeige- und Operator- Werte angezeigt.

In der obersten Zeile werden die Bezeichnung der Definitionsparameter ausgegeben.
Die Inhalte der einzelnen Zellen können direkt in der Tabelle eingegeben werden.
Der Datensatzzeiger [image] zeigt den aktuellen Datensatz an. Die schwarze Markierung zeigt, dass der komplette Satz kopiert werden kann.

Wenn der Tabellen Editor im Bearbeitungsmodus aufgerufen wurde, enthält die letzte Zeile immer das Kennzeichen für einen neuen Datensatz [image] . Nur dort kann ein neuer Satz eingefügt werden.

Die Anzeige kann aus einer Popup Liste ausgewählt worden. Siehe Tabellenzeilenauswahl.
Der Auswahloperator kann aus einer Popup Liste ausgewählt worden. Siehe Tabellenzeilenauswahl.

Wenn der Tabelleneditor geschlossen wird und Definitionen geändert wurden, dann wird die komplette Tabellendefinition in die Zwischenablage kopiert.


Tabellen-Editor Menüs
Zurück

Datei

Neu, Öffnen..., Speichern und Speichern als... ' beziehen sich nur auf Tabellen, die im Textformat abgespeichert sind und enthalten die üblichen Funktionen zur Einrichtung von Dateien.

Bearbeiten

Kopieren | kopiert einen ganzen Datensatz, wenn mit Maus vorher auf das linke Feld neben dem Datensatz geklickt wurde. Dann erscheint der Datensatzzeiger [image] und die ganze Zeile ist markiert. Eine ganze Spalte kann man kopieren wenn man zuvor eine komplette Spalte markiert, indem man auf die Zelle mit dem Feldnamen klickt.
Kopierten Datensatz einfügen | fügt einen zuvor kopierten Datensatz in einen anderen Datensatz, wenn dort die ganze Zeile markiert ist (Datensatzzeiger siehe oben) oder in die Zeile für neue Datensätze [image] .
Datensatz löschen | löscht eine Zeile, wenn sie ganz markiert ist.
Spalte löschen | löscht eine Spalte, wenn sie ganz markiert ist.
Spalte umbenennen... | ermöglicht das Umbenennen einer markierten Spalte.
Suchen... | sucht einen eingegeben Text innerhalb einer aktiven Spalte.

Ansicht

Datensatz | schaltet zwischen Datensatzansicht und Tabellenansicht um
Aufsteigend sortieren | sortiert ein oder mehrere markierte Spalten aufsteigend.
Absteigend sortieren | sortiert ein oder mehrere markierte Spalten absteigend.

Einfügen

Neuer Datensatz | setzt den Datensatzzeiger auf die letzten Zeile [image] der Tabelle. Dort können dann neue Feldinhalte eingegeben werden.
Spalte | fügt eine neue Spalte ein, wenn zuvor eine Spalte markiert wurde. Spalten markieren kann man durch Anklicken der Feldnamen. Eine neue Spalte wird links vor einer markierten Spalte eingfügt. Ein Spaltenname läßt sich über den Menüpunkt 'Spalte umbenennen... ' des Kontextmenüs umbenennen.

Extras

%Spaltenparameter% erstellen | Benutzer mit Supportrechten können hiermit aus den Namen der Spalten eine Zeile erzeugen, die die Parameter für den Befehl 'TABLE' enthält. Die erzeugte Zeile wird in der Statuszeile des Jobs-Systems ausgegeben.
Optimale Breite | setzt die Breite einer oder mehrer Spalten auf die Breite des jeweils längsten Eintrags. Ist nach dem Anklicken von Spaltenköpfen aktiviert. Hinweis: wird die linke obere Ecke der Tabelle mit der rechten Maustaste angeklickt, erscheint ein Kontextmenü. Über den gleichnamigen Menüpunkt können alle Spalten der Tabelle optimiert werden.


Das Batchlauf-Modul im Normal-Modus
Weiter

Das Batchlauf-Modul führt gestartete Jobs aus.

Nachdem der Benutzer über den Schalter 'Job starten' der Job-Seite Start eines Jobs den Job gestartet hat, wird vom System ein eigenständiges Batchlauf-Programmmodul aufgerufen, das die Befehlszeilen des Jobs abarbeitet.

Sobald das Batchlauf-Modul gestartet ist, wird das Programmfenster des Batchlauf-Moduls in der Job-Seite Ausführung des Jobs angezeigt.

In dem oberen Ausgabeteil werden alle auszuführenden Befehlzeilen angezeigt. Dabei wird jeweils die aktuell ausgeführte Befehlszeile markiert.

Im unteren Ausgabeteil erscheinen die Protokollzeilen, die von den ausgeführten Befehlszeilen erzeugt werden.

In der oberen Fortschrittsanzeige wird der Bearbeitungsfortschritt der aller Befehlszeilen angezeigt.

In der unteren Fortschrittsanzeige können bestimmte Fortschritte von Befehlen erscheinen. Z.B. beim Transferieren, Kopieren und Komprimieren von Dateien oder durch Verarbeitungen innerhalb einer Scriptsprache.

Wenn ein externes Programm vom Job aufgerufen wurde, wird es vom Batchlauf Modul in bestimmten Intervallen auf Beendigung geprüft. Mit dem Schalter [image] kann man eine sofortige Prüfung durchführen.

Mit dem Schalter 'Pause' kann der Joblauf angehalten werden. Der Schalter wechselt dann zu 'Weiter', womit der Joblauf wieder weitergeführt werden kann.
Mit dem Schalter 'Abbrechen' kann der Joblauf abgebrochen werden. Dies muss dann vom Benutzer bestätigt werden.

Hinweis:

Während eines Joblaufs können andere Jobs geöffnet, bearbeitet und gestartet werden. Das Job-System kann sogar ganz geendet werden. ohne noch laufende Jobs zu beenden.

Wird das Windows-Betriebssystem beendet, so gibt das Batchlauf-Modul einen Hinweis auf die noch laufende Verarbeitung aus.

Für jede ausgeführte Batchdatei wird eine Protokolldatei geschrieben. Die Protokolldatei hat den Namen der Batchdatei mit der Endung '.LOG'.


Das Batchlauf-Modul im Einzelschritt-Modus
Zurück

Das Batchlauf-Modul im Einzelschritt-Modus bietet die Möglichkeit die Befehlszeilen eines Jobs benutzergesteuert auszuführen. Dadurch sind alle Jobs 'Restart'-fähig.

Dazu muss vorher der Menüpunkt 'Job schrittweise ausführen ' im Job-Menü 'Extras' aktiviert werden.

Das Starten des Jobs erfolgt wie im Normal-Modus über den Schalter 'Job starten ' der Job-Seite Start. Im Einzelschritt-Modus werden die Befehlszeilen des Jobs vom Batchlauf-Programmmodul nicht automatisch abgearbeitet..

Sobald das Batchlauf-Modul gestartet ist, wird das Programmfenster des Batchlauf-Moduls in der Job-Seite Ausführung des Jobs angezeigt.

Alle Elemente aus dem Normal-Modus haben die gleiche Funktion.

Mit den vier zusätzlichen Schaltern lässt sich der Ablauf der Befehlzeilen steuern.

Im oberen Ausgabeteil mit den auszuführenden Befehlzeilen kann die jeweils gewünschte Befehlszeile vom Benutzer markiert werden. Wenn innerhalb der Befehlszeilen Label verwendet wurden, können diese mit Hilfe der erscheinenden Listbox markiert werden.

Mit dem Schalter [image] werden alle Befehlszeilen wie im Normal-Modus hintereinander ausgeführt. Ist vom Benutzer eine Befehlszeile markiert worden, so beginnt der Job ab dieser Zeile. Soll der Job bei einer bestimmten Zeile enden, so muss auch diese Zeile markiert werden. Das heißt, dass bei einer gewünschten Endzeile immer auch eine Anfangszeile markiert werden muss.

Während des Ablaufs der Befehlszeilen, kann mit dem Schalter [image] die Ausführung unterbrochen werden.

Mit dem Schalter [image] wird der komplette Job abgebrochen und das Batch-Programmmodul beendet.

Mit dem Schalter [image] wird jeweils nur eine Befehlszeile ausgeführt. Wenn der Benutzer eine Befehlszeile markiert hat, wird diese Zeile ausgeführt. Wird dieser Schalter wiederholt gedrückt, ohne eine neue Befehlszeile zu markieren, so wird mit der jeweils nächsten Befehlszeile fortgefahren.

Bemerkung:

Normalerweise kann jede Zeile einzeln ausgeführt werden. Ausnahme sind Zeilen, die innerhalb einer FTP-Session oder einer TelNet-Session liegen. In diesen Fällen kann keine Einzelschrittverarbeitung durchgeführt werden. Es ist nur möglich innerhalb einer Session eine Endzeile zu markieren, bis zu der der Ablauf durchgeführt wird. Ist eine FTPLogin- oder TelNetLogin- Sessionzeile mit dem Einzelschrittschalter bearbeitet worden, so wird die Bearbeitung bis zur nächsten markierten Endzeile oder bis zum Ende der Session durchgeführt.

Hinweis:

Die vom Batch-Modul angezeigten Befehlszeilen mit '/Parameter' und '/Set' müssen nicht ausgeführt werden. Sie werden nur zur Kontrolle ausgegeben. Ausnahme sind 'Set'-Zeilen, die die Parameterfunktion 'DRIVE' enthalten, da diese Funktion erst zur Laufzeit ausgeführt wird.


PC-Befehlstypen

Ablaufsteuerung
CONTINUE
 END
 WAIT
 WAIT UNTIL EXISTS
 WAIT UNTIL HH:MM

Ausgaben
ECHO
 PRINTFILE
 WRITETO

Beschreibung
:Label
 ; / ' / REM

Dateien
CHCHAR
 COPY
 DELete
 MOVE
 PACK
 REName
 SETATTRIB
 SORT
 UNPACK

Informationen
ADDTOLOGFILE
 BEEP
 CHECKLOGFILE
 DIR
 ERROR
 MSG

Netzwerk
LOGOUT
 MAP
 NET (extern)

Pfade
ChDir
 CHDRIVE
 MkDir
 RmDir

Programmausführung
INLINE
 JSBATCH
 JSSTART
 NOWAIT
 Programm
 SENDKEYS
 START

Befehle, die ausschließlich externe Programmteile nutzen, sind mit (extern) gekennzeichnet.


:Label

Mit Labelnamen können Befehlszeilenblöcke hervorgehoben werden.

Syntax:
: labelname

Bemerkung:
 Labelnamen können als Beschreibung, aber vor allem als Markierung benutzt werden. Sind Labelnamen benutzt worden, so können diese im Einzelschrittmodus zur Auswahl von Befehlszeilen verwendet werden. Es erscheint dann eine Listbox, die alle Labelnamen zur Auswahl enthält. Außerdem werden Label in der Statusliste, dem Ausführungsprotokoll und auf der Dokumentationsseite ausgegeben.

Beispiel:
 :Dies ist ein Label
:Download
:Build
:Dispatch


ADDTOLOG
siehe auch 'FTP addtolog'

Hinzufügen eines Dateinhaltes in die Batch-Protokolldatei.

Syntax:
AddToLog dateiname [ /ErrorIfNotExists [( n) ] suchtext ] [/ErrorIfExists suchtext ] [/Exclude suchtext ] [/Unix ] [/Text ]

Bemerkungen:
 Der Inhalt der mit Dateiname angegebenen Datei wird in das Job-Protokoll eingefügt.

Dies ist dann sinnvoll, wenn ein vorher aufgerufenes Programm eigene Protokollausgaben in eine Datei geschrieben hat und diese Ausgaben dem Benutzer im aktuellen Job-Protokoll sichtbar gemacht werden sollen.

Mit der Angabe '/Exclude' werden alle Zeilen, die den suchtext enthalten, nicht in das Job-Protokoll übernommen. Enthält der suchtext Jokerzeichen wie * oder ?, wird er linksbündig mit den Zeilen verglichen. Leerzeilen können ausgefiltert werden, indem Hochkommata ohne suchtext angegeben werden ( '' bzw. "" ). Diese Option kann mehrmals angegeben werden.

Mit den Angaben '/ErrorIfNotExists' und '/ErrorIfExists' kann man an Hand von Informationen aus der eingelesenen Datei, den Job abbrechen lassen. '/ErrorIfExists' kann mehrmals angegeben werden.

Bei '/ErrorIfNotExists' kann mit einem in Klammern eingeschlossenen Zahlenausdruck bestimmt werden, wie oft der nachfolgend angegebene suchtext mindestens vorkommen muss. Tritt suchtext pro Zeile mehrfach auf, dann wird er nur einmal gezählt. Diese Option kann nur einmal angegeben werden.

Enthält der suchtext Leerzeichen, so muss er in Hochkomma eingeschlossen werden.

Der Parameter '/Unix' erlaubt auch das Einlesen von Dateien, die auf der Unix erstellt wurden und nicht das Zeilenendekennzeichen besitzen, das auf dem PC verwendet wird.

Mit der Option '/Text' wird der Bezeichner dateiname selbst als Text ausgegeben. Dies ist vor allem sinnvoll, wenn innerhalb eines Scriptes (siehe Befehl 'INLINE') Texte oder Variableninhalte ausgegeben werden sollen.

Beispiel:
 AddToLog c:\imsview\iws\imsview.log /ErrorIfNotExists(2*5): 'Transfer complete'

AddToLog cv%DBName%.log /ErrorIfNotExists: 'Job Complete.' /Exclude: 'Pass '


BEEP
siehe auch MSG

Ausgeben eines Pieptones.

Syntax:
BEEP [dauer ]

Bemerkungen:
 Der einfache Piepton bewirkt nur ein kurzes Knacken im PC-Lautsprecher. Eine Angabe von mindestens 100 als Dauer ist sinnvoll.

Unter Windows NT hat dieser Befehl keine Wirkung.

Beispiel:
 Beep 200


CHCHAR

Umwandeln von Zeichen in einer Datei.

Syntax 1:
CHCHAR dateiname ASCII-ANSI | ANSI-ASCII

Syntax 2:
CHCHAR dateiname zeichen , ersatzzeichen [, ...]

Syntax 3:
CHCHAR dateiname TABLE tabellendateiname

Mit der Syntax 1 können Umlaute von ASCII (DOS) nach ANSI (Windows) oder umgekehrt umgewandelt werden.

Mit der Syntax 2 können beliebige Zeichen in andere Zeichen umgewandelt werden. Jede Zeichenangabe muss sich immer auf ein einzelnes Zeichen beziehen. Es können also nicht ganze Zeichenfolgen umgewandelt oder Zeichen gelöscht werden.

Es muss jeweils zuerst das Zeichen angeben werden, das geändert werden soll (zeichen) und dann, durch Komma getrennt, das einzusetzenden Zeichen (ersatzzeichen ) angegeben werden.

Jedes zeichen und ersatzzeichen kann folgendermaßen eingegeben werden:

1. direkt z.B. {, [, }, ]
2. als dezimaler 3-stelliger Zeichencode z.B. 009, 032, 013, 032
3. als hexadezimaler Zeichencode in der Form [he]x'##' z.B. hex'7B', x'BA'

Alle 3 Formate können gemischt angegeben werden (z. B.: {, [, }, ], hex'7B', ä, x'BA', ö, 009, x'20'... ).

Achtung , ein Komma muss als Zeichencode angegeben werden !.

Mit der Syntax 3 kann ein kompletter Zeichensatz anhand einer Zeichentabelle umgewandelt werden. In der tabellendatei müssen alle 256 Zeichen eines Zeichensatzes definiert sein. Die Definition der zeichen und ersatzzeichen erfolgt dabei wie bei der Syntax 2 beschrieben. Dabei können die Zeichenpaare, die sich aus zeichen , ersatzzeichen ergeben, jeweils in eine einzelne Zeile geschrieben werden.

Beispiel:
{, [
}, ]
hex'7B', ä
x'BA', ö
009, x'20'
. . .


ChDir

Wechseln von Verzeichnissen.

Syntax:
ChDir Verzeichnisname

CD Verzeichnisname

Hinweis:
 Enthält der Verzeichnisname eine Laufwerksangabe, so wird dabei auch das Laufwerk gewechselt.


CHDRIVE

Wechseln des aktuellen Laufwerkes.

Syntax:
CHDRIVE Laufwerksbuchstabe:

Bemerkung:
 Alternativ kann auch nur der Laufwerksbuchstabe mit Doppelpunkt angegeben werden.


CHECKLOG
siehe auch 'Telnet checklog'

Überprüfen von Ausgaben in die Job-Protokolldatei und steuern des Ablaufes.

Syntax:
CHECKLOG /IfExists | /IfNotExists [(n) ] suchtext [And suchtext ] Error fehlertext | Skip Next n Lines | Continue With | After labelname

Bemerkungen:
 Überprüft werden können Ausgaben, die durch Befehle des Job-Systems in das Job-Protokoll gestellt wurden. Dabei beginnt die Prüfung immer ab der Protokollzeile des letzten Befehls.

Mit den Angaben '/IfNotExists' und '/IfExists' können die Protokollzeilen nach einem suchtext überprüft werden. '/ErrorIfExists' kann mehrmals angegeben werden.

Bei '/IfNotExists' kann mit einem in Klammern eingeschlossenen Zahlenausdruck bestimmt werden, wie oft der nachfolgend angegebene suchtext mindestens vorkommen muss. Wenn der suchtext
nicht so oft auftritt, wie mit der in Klammern eingeschlossenen Anzahl definiert, dann wird ein Fehler erzeugt.

Mit dem Befehl 'Error' kann man den Job in den Fehlerzustand mit der Meldung fehlertext versetzen. Der weitere Ablauf ist dann abhängig von den benutzten Befehlen zur Fehlerbehandlung.

Mit dem Befehl 'Skip Next n Lines' kann man die angegebene Anzahl Befehlszeilen des Jobs überspringen. Damit lassen sich bedingte Befehlszeilen einrichten um z.B. Aktionen für fehlerhafte Ausführungen zu starten.

Mit dem Befehl 'Continue With labelname' kann der Name eines Labels angegeben werden, bei dem der Job im Ablauf fortfahren soll.

Mit dem Befehl 'Continue After labelname' kann der Name eines Labels angegeben werden, hinter dem der Job im Ablauf fortfahren soll. Dies ist dann sinnvoll, wenn noch nicht bekannt ist welches der nächste labelname sein wird, weil dieser durch Parameter verändert werden kann. Dann muss nach Zeilen, die übersprungen werden sollen ein Abschlusslabel definiert werden.

Hinweis:
 Tritt suchtext pro Zeile mehrfach auf, dann wird er nur einmal gezählt. Wird der Operator 'And' benutzt, so bezieht sich die gesamte Bedingung auf die gleiche Zeile.

Enthält der suchtext Leerzeichen, so muss er in Hochkomma eingeschlossen werden.

Wird bei der Option '/IfExists' als suchtext ein Text der Länge 0 angegeben (zwei Hochkomma direkt nebeneinander '' ), so werden die Aktionsbefehle immer ausgeführt.

Beispiel:
 unpack c:\daten\test\database.zip /List
checklog /IfNotExists(3): 'dbfile.' Error
checklog /IfNotExists: 'parmfile.dat' Skip next 2 Lines
checklog /IfNotExists(4): %Filename% And %SYSDD%.%SYSMM%.%SYSYYYY% Error

OnErrorWarning
checklog /IfNotExists(4): '.exe' Error Continue with 'Build without Exefiles'


CONTINUE

Lässt den Ablauf eines Batchjobs an einer anderen Stelle fortfahren.

Syntax:
Continue With labelname

labelname bezeichnet den Namen eines Labels , das an nachfolgender Stelle definiert ist.

Beispiel:
 /Set %EXE%=ON(%ZipExe%:Ja)

%EXE% Continue with 'Build with Exefiles'
:Build without Exefiles

:Build with Exefiles


COPY
siehe auch 'FTP copy'

Kopieren von Dateien.

Syntax:
COPY QuellName ZielName
COPY QuellName [+ QuellName ] ZielName [/CRLF]
COPY QuellName + ZielName [/CRLF]
COPY QuellTeilname ZielTeilname [/SubDirs] [/Ignore:dateiname] [/ShortLog]

Bemerkungen:
 Mit einem Plus-Zeichen vor dem ZielNamen wird die Quelldatei mit der Zieldatei zusammen kopiert, falls die Zieldatei schon vorhanden ist. Dadurch lassen sich besser tabellengesteuerte Kopierbefehle zusammenstellen (siehe %Tabellen-Parameter% ).

Beim Zusammenkopieren von Dateien werden mit der Option '/CRLF ' Zeilenvorschubsteuerzeichen (CarriageReturn-Linefeed) an die Datei angehängt. Das kann notwendig sein, wenn die zu kopierenden Dateien nicht mit diesen Zeichen abgeschlossen sind.

Beim Kopieren von mehreren Dateien (QuellTeilname) durch Angabe von Jokerzeichen ('* ' oder '? ') können mit der Option /SubDirs auch Dateien von Unterverzeichnissen berücksichtigt werden. Verzeichnisse, die im Ziel nicht existieren, werden angelegt. Mit der Option /Ignore: werden Dateien ignoriert, die wegen Zugriffproblemen nicht kopiert werden können. Mit der Option '/ShortLog' kann die Ausgabe aller Dateinamen unterdrückt werden. Anstelle dessen wird die Anzahl der kopierten Dateien und die Anzahl Bytes ausgegeben.

Enthält der Dateiname Leerzeichen, so muss er in Gänsefüßchen eingeschlossen sein.

Hinweise:
Im Ziel existierende Dateien gleichen Namens werden ohne Warnung überschrieben. Die Anzahl kopierter Bytes wird zwischen Zieldatei und Quelldatei verglichen, um mögliche System- bzw. Netzwerkfehler auszuschließen. Bei Dateien, die größer als 10 MB sind, wird eine Fortschrittsanzeige ausgegeben.

Beispiel:
 copy c:\temp\datei1.txt + c:\test\datei1.txt + c:\temp\datei2.txt c:\daten\datei.dat

Ist ein QuellTeilname (Dateiname, der Jokerzeichen wie '* ' oder '? ' enthält) angegeben worden, und die gefundenen Namen nach dem Quellpfad sollen genauso übernommen werden, so muss als ZielTeilname nur der entsprechenden Zielpfad angegeben werden.

Beispiel:
 copy c:\temp*.txt c:\temp\daten

Ist ein QuellTeilname (Dateiname, der Jokerzeichen wie '* ' oder '? ' enthält) angegeben worden, und die gefundenen Namen nach dem Quellpfad sollen nur zum Teil übernommen werden, so wird der ZielTeilname gemäß den Regeln des PC-Befehls 'RENAME' umbenannt.

Beispiel:
 copy c:\temp*.txt c:\temp\daten*.dat


DELete

Löschen von Dateien.

Syntax:
DEL dateiename

DEL dateiteilname* [/SubDirs] [/Exclude:dateiname*] [/ShortLog ]

Bemerkungen:
 Wenn dateiename nicht vorhanden ist, wird kein Fehler erzeugt.

Beim Löschen von mehreren Dateien (dateiteilname) durch Angabe von Jokerzeichen ('* ' oder '? ') können mit der Option /SubDirs auch Dateien von Unterverzeichnissen berücksichtigt werden. Unterverzeichnisse werden nicht gelöscht. Mit der Option /Exclude: werden Dateien vom Löschen ausgeschlossen. Mit der Option '/ShortLog' kann die Ausgabe aller Dateinamen unterdrückt werden. Anstelle dessen wird die Anzahl der gelöschten Dateien und die Anzahl Bytes ausgegeben.

Beispiel:
 del c:\daten\test.dat
del c:\daten\*.dat /SubDirs /Exclude:sal*.dat /ShortLog


DIR

Ausgeben von Dateiinformationen eines Dateipfades.

Syntax:
DIR Dateiteilname [Ausgabedateiname ]

Bemerkungen:
 Ausgegeben werden der Dateiname, die Dateigröße, das Datum und die Zeit der letzten Dateiänderung.
Es werden keine Pfadangaben und keine Verzeichnisnamen mit ausgegeben.
Ohne Angabe von Ausgabedateiname werden die Informationen ins Jobprotokoll übernommen.

Existiert der angegebene Dateiname oder Pfadname nicht, wird der komplette Dateiname mit der Meldung 'existiert nicht. <!!>' angezeigt. Die Zeichen '<!!>' werden unabhängig von der verwendeten Sprache ausgegeben, sodass diese mit dem Befehl CheckLogfile überprüft werden können.

Beispiel:
 dir c:\temp\*.*

Bookfiles.ini | 381 | 09.09.2000 | A
GREEN.bmp | 870 | 06.01.2000 | A
HEADING.TMP | 1.548 | 09.07.2000 | A
isism11.log | 26 | 09.09.2000 | A
Isism11.rec | 158 | 07.09.2000 | A


ECHO

Ausgabe von Protokollmeldungen in eine separate Protokolldatei.

Syntax:
ECHO Nachricht

Bemerkungen:
 Die mit diesem Befehl angegebenen Texte werden in dem normalen Job-Protokoll und in einem eigenen ECHO-Protokoll ausgegeben.

Die ECHO-Protokolldatei wird fortlaufend von jedem Joblauf ergänzt. Damit ist es möglich Protokolltexte zu erstellen, die dann zur Informationsweitergabe benutzt werden können.

Die ECHO-Protokolldatei hat den Namen der Batchdatei mit der Endung '.EKO' und kann in dem Bereich Informationen zum Lauf der Jobeigenschaften aufgerufen werden.

Beispiel:
 ECHO cd /xtre_ger/server/data/input/%FirmKZ%
ECHO copy IBM:arz.arz.pfc.fd80.M%MM%%JJ%.C%FirmNr% SP2:%FirmDKZ%%MM%%JJ%.dat
ECHO copy IBM:arz.arz.pfc.desc.M%MM%%JJ%.C%FirmNr% SP2:%FirmKZ%.dat

Mögliche Ausgabe:

Job-Echo-Protokoll

Batch-Job c:jobsysbatchechotst.bat gestartet am 11.06.1998 um 21:07:48
cd /xtre_ger/server/data/input/scherax
copy IBM:arz.arz.pfc.fd80.M0198.C47000 SP2:sch0198.dat
copy IBM:arz.arz.pfc.desc.M0198.C47000 SP2:scherax.dat

Dieser Text kann nun zum Beispiel per E-Mail als Batchlauf-Information weitergegeben werden.


END

Beenden des Joblaufs. Mit diesem Befehl ist es möglich nachfolgende Teile der Jobbefehle von der Ausführung auszuschließen.

Syntax:
END


ERROR

Setzen eines Fehlers.

Syntax:
ERROR Fehlermeldung

Bemerkungen:
 Das Setzen eines Fehlers kann im Zusammenhang mit dem Befehl 'CheckLogfile' benutzt werden. Der weitere Ablauf ist abhängig von den benutzten Befehlen zur Fehlerbehandlung.

Beispiel:
 Während einer Verarbeitung muss die Datei 'parmfile.dat' mit einem externen Programm bearbeitet werden. Das externe Programm erwartet die Endung .OLD und schreibt die bearbeitete Datei mit der Endung .DAT zurück. Danach soll vom Job geprüft werden, ob die neue Datei mit der Endung .DAT vorhanden ist. Ist sie nicht vorhanden, soll der Joblauf abgebrochen werden und die Datei wieder so umbenannt werden, dass sich der Job später wieder an dem Label ':Parameteränderung' aufsetzen lässt.

:Parameteränderung
ren parmfile.dat parmfile.old
; Dateiänderung mit externem Program
changefile.exe parmfile
dir parmfile.dat
checklogfile /IfExists: 'parmfile.dat' Skip next 2 Lines
ren parmfile.old parmfile.dat
Error 'Parameterdatei wurde nicht erzeugt'


INLINE

Einbinden von Script Programmcode in den Job.

Syntax:
INLINE [WSHOST] scriptsprache [/Timeout sekunden] [/LogOnError]
Scriptbefehle
" "
ENDINLINE [/KeepStatus]

Bemerkungen:
 Scriptbefehle der scriptsprache werden nicht direkt vom Batch-Modul verarbeitet. Trotzdem kann die Ausführung überprüft werden, wenn es sich um normales VBScript oder JScript von Microsoft handelt. Beim Testen eines Jobs über die Vorschauseite werden die Scriptbefehle auf Wunsch ausgeführt. Dabei werden vom Script-Interpreter eventuelle Syntaxfehler erkannt und ausgegeben. Zu Beachten ist allerdings, dass es sich nicht um eine reine Syntaxprüfung handelt, sondern um eine echte Ausführung der Befehle der Scriptsprache. Im Vorschau-Protokoll erscheinen alle Scriptzeilen innerhalb 'Inline' und 'EndInline' mit einem vorangestellten Markierungszeichen.

Sind in den Scriptbefehlen Texte in '%' Zeichen eingeschlossen, dann werden sie vom Job-System als %Parameter% angesehen und wie in den Befehlen des Job-Systems entsprechend ersetzt. Somit lassen sich Parameterinhalte an die Befehle der Scriptsprache übergeben. Außerdem wird die Verwendung von Bezeichnern für temporären Dateien unterstützt.

Mit der Option /LogOnError kann die Ausgabe der Scriptzeilen unterdrückt werden solange kein Fehler bei der Ausführung auftritt.

Hinweis:
 Der Zusatz 'WSHost' (Windows Scripting Host) bewirkt, dass die Scriptsprache nicht direkt unterstützt wird. Auch werden die Methoden des JSBatch Obekts nicht unterstützt. Dies liegt daran, dass für die WSHost-Engine Sprachelemente hinzugefügt wurden, die nur von dieser verarbeitet werden können. Das Batch-Modul gibt die Scriptbefehle in diesem Fall zur Laufzeit nur an die WSHost-Engine weiter und wartet auf die Beendigung.

Als scriptsprache werden 'VBScript' und 'JScript' von Microsoft direkt unterstützt. Dadurch lassen sich, wie oben beschrieben, Syntaxfehler erkennen. Außerdem können von diesen Sprachen Jobbefehle des Job-Systems genutzt werden.

Mit der Option '/Timeout sekunden' kann eine Systemmeldung erzwungen werden, die nach der abgelaufenen Anzahl Sekunden erscheint und den Benutzer entscheiden lässt, ob die Ausführung des Scripts abgebrochen oder fortgesetzt werden soll.
Die Option '/KeepStatus' bewirkt, dass nach Ausführung des Scripts der Scriptcode sowie alle Variablen im Speicher gehalten werden. Somit können Scriptbefehle, die an einer anderen Stelle im Job per 'Inline' Befehl definiert werden, den schon vorhandenen Scriptcode und die Variablen weiter benutzen.

Befehle des JSBatch Objekts:
 Der Befehls-Editor bietet zum Testen von Variablen und Ergebnissen die Befehle 'JSBatch.DebugMsgBox' und 'JSBatch.DebugPrint'. Diese Befehle können innerhalb eines Scriptes zur Ausgabe von Werten in das Vorschau-Protokoll benutzt werden. Mit 'JSBatch.DebugMsgBox' werden Ausgaben zusätzlich in ein Nachrichtenfenster ausgegeben, das auch den Abbruch eines Scriptes ermöglicht. Zur Laufzeit werden diese Befehle nicht ausgeführt. Siehe Beispiel.

Folgende Befehle des Job-Systems können von diesen Scriptsprachen zur Laufzeit im Batch-Modul benutzt werden:

JSBatch.AddToLog | JSBatch.ChChar
JSBatch.Copy | JSBatch.Del
JSBatch.Dir | JSBatch.Echo
JSBatch.Error | JSBatch.FTPSession
JSBatch.MkDir | JSBatch.Pack
JSBatch.PrintFile | JSBatch.RmDir
JSBatch.Sort | JSBatch.Start
JSBatch.TelnetSession | JSBatch.Unpack
JSBatch.Wait | JSBatch.WriteToSession

Die Syntax dieser Befehle entspricht der Beschreibung. Allerdings müssen alle Parameter in Gänsefüßchen eingeschlossen sein. Außerdem ist es auch möglich alle Parameter mit einem Komma getrennt an zugeben.

Syntax:
 JSBatch.befehl "parameter1 parameter2 parameterN "
oder
JSBatch.befehl "parameter1 ", "parameter2 ", "parameterN "

Syntax von Sessions:
 Alle Sessionbefehle müssen zeilenweise zusammen gefaßt und als ein Parameter übergeben werden.
[variable =] JSBatch.FTPSession "FTPLogin ..." + vbCrLF + "ftpbefehl1 " + vbCrLF + "ftpbefehlN " + vbCrLF + "FTPLogout"
[variable =] JSBatch.TelnetSession "TelnetLogin ..." + vbCrLF + "telnetbefehl1 " + vbCrLF + "telnetbefehlN " + vbCrLF + "TelnetLogout"
[variable =] JSBatch.WriteToSession "WriteTo ..." + vbCrLF + "writetobefehl1 " + vbCrLF + "writetobefehlN " + vbCrLF + "EndWriteTo"

Außerdem kann mit variable das Ergebnis einer Session abgefragt werden. Ein Wert 0 bedeutet, dass die Session mit einem Fehler abgebrochen wurde. Der Wert -1 bedeutet, dass die Session erfolgreich beendet wurde (siehe Beispiel).

Die Protokollausgaben aller Befehle werden wie üblich in die Protokolldatei des Jobs geschrieben. Dies hat besonderen Wert bei dem Befehl 'AddToLogfile', da man dadurch auch Ausgaben der originalen Scriptbefehle protokollieren kann.

Sonstige Befehle:
 Temporären Dateien können durch Benutzen von &&bezeichnername verwendet werden (siehe temporäre Dateien). Diese können auch außerhalb des Scriptes in den Befehlen des Jobs weiter benutzt werden. Siehe Beispiel.

Mit dem Befehl 'JSBatch.EndAfterInline' kann der Joblauf nach dem Ablauf des Scriptes beendet werden. Siehe Beispiel.

Mit der Funktion 'JSBatch.FileRecords(Dateiname)' kann die Anzahl Sätze einer Datei ausgegeben werden. Die Satzanzahl wird anhand der in der Datei vorhandenen Zeichen Chr(10) ermittelt (siehe Beispiel).

Mit der Funktion 'JSBatch.FormatVariant(Ausdruck, Format[, ersterWochentag[, ersteJahreswoche, Eingabe-, Ausgabedezimalzeichen]]]]) ' kann ein Ausdruck formatiert werden. Sie dient als Ergänzung zu den in VBScript vorhandenen Format Funktionen. Wenn Eingabe-, bzw. Ausgabedezimalzeichen nicht angegeben sind, entspricht diese Funktion in Syntax und Ergebnis der Format Funktion von Visual Basic.
Mit dem Eingabe-, bzw. Ausgabedezimalzeichen kann genau bestimmt werden, ob als Dezimalzeichen Komma oder Punkt im Ausdruck enthalten sind bzw. im Ergebnis ausgegeben werden sollen. Bei gemischten Installationen und Verarbeitung von Daten anderer Länder kann dies notwendig sein.
Zu Beachten ist, dass in Format als Dezimalzeichen immer ein Punkt und als Tausendertrennzeichen ein Komma angegeben werden muss (siehe Beispiel).

Mit der Funktion 'JSBatch.GetLocalInfo(infotyp)' können Informationen über die Ländereinstellungen des Rechners abgerufen werden. Als mögliche Werte für infotyp siehe GetLocalInfo Konstanten .

Mit dem Befehl 'JSBatch.MidStr(Text, Start, Länge, ErsatzText) kann ein Teil eines Textes durch einen anderen text ersetzt werden. Siehe Beispiel.

Mit dem Befehl 'JSBatch.Progressbar(Beschreibung, AktWert, MaxWert) können obere und untere Fortschrittsanzeige des Batchlauf Moduls angesprochen werden. Dabei können Initialisierung und Ausschalten durch die Parameterinhalte bestimmt werden. Die obere Fortschrittsanzeige wird durch die Beschreibung "(MAIN)" angesprochen. Dies ist allerdings nur sinnvoll, wenn der Job überwiegend mit einem Script ausgeführt wird, da die obere Hauptfortschrittsanzeige vor und nach einem Script über die Anzahl der ausgeführten Befehlszeilen gesteuert wird. Siehe Beispiel.

Die Funktion 'JSBatch.SplitRecord(Zeichenfolge, Tennzeichen) trennt einen Text anhand eines Tennzeichens auf und gibt die Teilstücke in einem Variablenarray zurück. Der Unterschied zu der VBScript Funktion 'Split' besteht darin, dass auch Textbegrenzungszeichen wie Gänsefüßchen und Hochkomma berücksichtigt werden. Außerdem erzeugt ein abschließendes Trennzeichen ein weiteres (leeres) Teilstück. Somit lassen sich z.B. einfach die Felder von Datensätze im CSV Format bearbeiten (siehe Beispiel).

Die Funktion 'JSBatch.StrLike(Zeichenfolge, Muster) prüft, ob Zeichenfolge einem angegebenen Muster entspricht. Dabei kann Muster Jokerzeichen wie * , ? und # enthalten. Es sind auch komplexere Vergleiche möglich (siehe Beispiel).

Beispiel:
Schreiben von VBScript-Befehlen innerhalb eines Jobs und Übernehmen eines Parameters in eine Script-Variable. Der Inhalt der Variable soll mit dem Job-System Befehl 'DebugPrint' ausgegeben werden.

/Parameter %JobParameter%

Inline VBScript

Testvariable = %JobParameter%

If Testvariable > "" Then
JSBatch.DebugPrint Testvariable
End If

EndInline

Beispiel:
 Ausgeben von Variablen und Ausdrücken eines Scriptes.

Inline VBScript

JSBatch.DebugPrint "2 * 3 = " & (2 * 3) ' aus Text und Zahlen mit '&' zusammen gesetzter Wert

Testvariable = %JobParameter%

JSBatch.DebugMsgBox Testvariable

EndInline

Beispiel:
 In einem Dateiverzeichnis sollen alle darin enthaltenen Dateien separat gepackt werden (also nicht alle Dateien zusammen in einer Zipdatei).

Inline VBScript

Dim fso, folder, file

Set fso = CreateObject("Scripting.FileSystemObject")

Set folder = fso.GetFolder("c:datentest")

For Each file In folder.Files
JSBatch.AddToLog file.Name + "wird gepackt", "/Text"
JSBatch.Pack file.Name
Next

EndInline

Beispiel:
 Es soll ein Job mit dem Programm JSStart gestartet werden. Wenn das Programm nicht erfolgreich gestartet werden kann soll eine Fehlermeldung erzeugt werden.

Inline VBScript

hProcess = JSBatch.Start ("/NoWait", "JSStart /B batchsendlettermail.bat " + destpath + "" + filetitle)
If hProcess = 0 Then
JSBatch.Error "Batchjob kann nicht gestartet werden."
End If

EndInline

Beispiel:
 Innerhalb eines Jobs soll ein Microsoft Excel Macro gestartet und darin eine Funktion ausgeführt werden, die Parameterinhalte aus dem Job übernehmen soll.

Inline VBScript

Dim objXL

Set objXL = CreateObject("Excel.Application")

objXl.Visible = True ' nur wenn Microsoft Excel sichtbar sein soll
objXL.Workbooks.Open("c:\makros\parmedit.xls")

objXL.Run "Sheet_Erstellung", "%DBName%", %MM%, %YYYY%

EndInline

Beispiel:
Innerhalb eines Scriptes soll eine temporäre Datei benutzt werden, die auch im Job verwendet wird.

Inline VBScript

msgbox &&tempfile

EndInline
WriteTo &&tempfile
test
EndWriteTo

Beispiel:
Mit einer Bedingung innerhalb eines Scriptes soll der Job beendet werden.

Inline VBScript

If testvariable = "Quit" Then
JSBatch.EndAfterInline
 End If

EndInline

Beispiel:
Innerhalb eines Scriptes soll eine Datenübertragung per FTP erfolgen. Jede FTP Befehlszeile muss mit der vorhergehenden durch die Steuerzeichen 13+10 (CarriageReturn Linefeed; VB Konstante vbCrLf) zusammen gesetzt werden.

Inline VBScript
Dim FTPCmd

FTPCmd = "FTPLogin ME 127.0.0.1 guest anonymous" + vbCrLf
FTPCmd = FTPCmd + "pwd" + vbCrLf
FTPCmd = FTPCmd + "copy c:\daten\logo.bmp ME:logo.bmp" + vbCrLf
FTPCmd = FTPCmd + "FTPLogout"

JSBatch.FTPSession FTPCmd
EndInline

Beispiel:
 Verschiedene Formatierungsangaben.

Inline VBScript
Dim Zeit1, Datum1, ZF1
Zeit1 = #17:04:23#
Datum1 = #January 27, 2004#

' Aktuelle Systemzeit im langen Zeitformat des Systems bestimmen.
ZF1 = JSBatch.FormatVariant(Time, "Long Time")
' Aktuelles Systemdatum im langen Datumsformat des Systems bestimmen.
ZF1 = JSBatch.FormatVariant(Date, "Long Date")

ZF1 = JSBatch.FormatVariant(Zeit1, "h:m:s") ' Liefert "17:4:23".
ZF1 = JSBatch.FormatVariant(Zeit1, "hh:mm:ss AMPM") ' Liefert "17:04:23".
ZF1 = JSBatch.FormatVariant(Datum1, "dddd, mmm d yyyy") ' Liefert "Mittwoch, 27. Januar 2004".
ZF1 = JSBatch.FormatVariant(Datum1, "yyyymmdd") ' Liefert "20040127".

' Benutzerdefinierte Formate.
ZF1 = JSBatch.FormatVariant(5459.4, "##,##0.00") ' Liefert "5.459,40".
ZF1 = JSBatch.FormatVariant(334.9, "###0.00") ' Liefert "334,90".
ZF1 = JSBatch.FormatVariant(334. 9, "0000.00") ' Liefert "0334,90".
' Achtung! Jetzt folgt die gleiche Zahl als Text.
ZF1 = JSBatch.FormatVariant("334. 9", "0000.00") ' Liefert "3349,00".
' Das Kommazeichen Punkt wird nicht mehr erkannt.
' deswegen muss es heißen:
ZF1 = JSBatch.FormatVariant("334. 9", "0000.00", , , ". ") ' Liefert "0334,90".

ZF1 = JSBatch.FormatVariant(5, "0.00%") ' Liefert "500,00%".
ZF1 = JSBatch.FormatVariant("BANANE", "<") ' Liefert "banane".
ZF1 = JSBatch.FormatVariant("birne", ">") ' Liefert "BIRNE".
EndInline

Beispiel:
Erstellen eines Datensatzes mit festen Feldlängen.

Inline VBScript
Dim Record

Record = String(50, " ") ' Erstellt einen 50 Stellen langen Satz.

JSBatch.MidStr Record, 1, 10, "1. Inhalt"
JSBatch.MidStr Record, 11, 15, "2. Inhalt"
JSBatch.MidStr Record, 20, 12, "3. Inhalt"

EndInline

Beispiel:
Ansteuern der Fortschrittsanzeigen des Batchlauf Moduls.

Inline VBScript
Dim MaxSaetze, file, record, fso, folder, reccounter, filecounter

Set fso = CreateObject("Scripting.FileSystemObject")

Set folder = fso.GetFolder("c:\daten")

For Each file In folder.Files

MaxSaetze = JSBatch.FileRecords (file.Path)

' Durch die Angabe von 0 für den aktuellen Wert wird die untere Fortschrittsanzeige initialisiert
' und der Beschreibungstext übergeben.
JSBatch.Progressbar "Datei lesen...", 0, MaxSaetze

reccounter = 0

Do While counter <= MaxSaetze
record = file.ReadLine
reccounter = reccounter + 1
JSBatch.Progressbar "", reccounter, MaxSaetze
Loop

filecounter = filecounter + 1

' Durch die Angabe "(MAIN)" als Bezeichnung wird die obere Fortschrittsanzeige angesprochen
 JSBatch.Progressbar "(MAIN)", filecounter, folder.Files.Count

Next

' Durch die Angabe von 0 für den maximalen Wert wird die untere Fortschrittsanzeige ausgeschaltet.
 JSBatch.Progressbar "", 0, 0
EndInline

Beispiel:
Aufteilen eines Datensatzes mit dem Inhalt 'hallo;"test; ""M""";ha ha ;' in ein Feldarray.

Inline VBScript

record = "hallo;" + Chr(34) + "test; " + Chr(34) + Chr(34) + "M" + Chr(34) + Chr(34) + Chr(34) + ";ha ha ;"
Fields = JSBatch.SplitRecord(record, ";")

For i = 0 To UBound(Fields)
JSBatch.DebugPrint i & ": " & Fields(i)
Next
EndInline

JSBatch.DebugPrint Output:
0: hallo
1: test; "M"
2: ha ha
3:

Beispiel:
Im folgenden Beispiel werden Daten zurückgegeben, die mit dem Buchstaben P beginnen und anschließend einen Buchstaben von A bis F und drei Ziffern enthalten:

If JSBatch.StrLike(Zeichenfolge, "P[A-F]###") Then
MsgBox "Übereinstimmung gefunden"
End If

In der folgenden Tabelle wird gezeigt, wie StrLike verwendet werden kann, um Zeichenfolgen auf verschiedene Muster zu überprüfen.

Art der Entsprechung | Muster | Entsprechung (gibt True zurück) | Keine Entsprechung (gibt False zurück)
Mehrere Zeichen | a*a | aa, aBa, aBBBa | aBC
 | *ab* | abc, AABB, Xab | aZb, bac
Sonderzeichen | a[*]a | a*a | aaa
Mehrere Zeichen | ab* | abcdefg, abc | cab, aab
Einzelne Zeichen | a?a | aaa, a3a, aBa | aBBBa
Einzelne Ziffern | a#a | a0a, a1a, a2a | aaa, a10a
Zeichenbereich | [a-z] | f, p, j | 2, &
Außerhalb des Bereichs | [!a-z] | 9, &, % | b, a
Keine Ziffern | [!0-9] | A, a, &, ~ | 0, 1, 9
Kombination | a[!b-m]# | An9, az0, a99 | abc, aj0


JSBATCH
siehe auch '/Include', 'Programm ', 'START' und 'INLINE'

Ausführen einer ausführbaren Batchdatei.

Syntax:
JSBATCH batchdatei

Bemerkungen:
 'JSBATCH.exe' ist der Programmname des Batch-Moduls. Das Batch-Modul kann innerhalb eines Jobs separat, sowie auch außerhalb des Job-Systems als eigenständiges Programm aufgerufen werden.

Da das Batch-Modul keine eigene Umsetzung von %Parametern% durchführt, können nur so genannte 'ausführbare Befehlsdateien' ausgeführt werden.

'ausführbare Batchdateien' sind Batchdateien , die keine %Parameter% enthalten. Die Erstellung einer ausführbaren Batchdatei erfolgt über das Job Startfenster und das Menü 'Datei/Ausführbare Batchdatei speichern'.

Nach dem Aufruf wartet der aktuelle Job auf die Beendigung des gestarteten Jobs und fährt erst danach mit dem Joblauf fort. Die Prüfung der Programmbeendigung erfolgt alle 5 Sekunden.


JSSTART
siehe auch 'Programm ' und 'START'

Ausführen eines externen Jobs mit Parameterübergabe.

Syntax:
JSSTART [[/B | /W ] [/S | /N]] befehlsdatei [parameter1 ] [parameterN ]

Bemerkungen:
 'JSSTART.exe' ist der Programmname des externen Job Startmoduls. Das Startmodul kann innerhalb eines Jobs, sowie auch außerhalb des Job-Systems als eigenständiges Programm aufgerufen werden.

Das Startmodul zeigt nach dem Aufruf ein Jobeigenschaftenfenster zur Eingabe von Parametern, ähnlich wie es im Job-System erscheint. Dabei werden, in der Kommandozeile angegebene Parameter, in die angezeigten Eingabefelder übernommen.

Die Reihenfolge der Parameter muss mit der Reihenfolge der Eingabefelder übereinstimmen. Das Starten des Jobs erfolgt dann manuell wie üblich (siehe unten).

Mit der Option '/B ' wird die Anzeige des Jobeigenschaftenfensters unterdrückt, wenn alle für den Job erforderlichen Parameter in der Kommandozeile übergeben wurden. In diesem Fall wird der Job sofort ausgeführt.

Bei der Option '/W ' verhält sich das Programm wie mit '/B', wartet aber auf die Beendigung des von ihm aufgerufenen Jobs. Diese Option muss benutzt werden, wenn der aufrufende Job auch auf die Beendigung des mittels JSStart aufgerufenen Jobs warten soll.

Mit der Option '/S' als Zusatz zu '/B' oder '/W' wird das Laufzeitfenster des Jobs angezeigt.

Mit der Option '/N' als Zusatz zu '/B' oder '/W' kann das Weiterleiten von Protokollnachrichten an aufrufende Systeme eingeschaltet werden.

Beim Start ohne Startmaske gilt:

Es müssen so viele parameter angegeben werden, wie in der Startmaske vorhanden sind.

Enthält der Job Tabellen oder Listen bei denen eine Auswahl von Zeilen erfolgen muss, so muss ein übergebener Parameter eindeutig eine Zeile der Tabelle identifizieren.

Enthält also eine Tabelle mehrere Zeilen, die in der ersten Spalte gleiche Inhalte haben, so müssen als Parameter soviel Spalteninhalte übergeben werden, wie notwendig sind um die gewünschte Zeile der Tabelle eindeutig zu bestimmen.

In diesem Fall müssen die Spalteninhalte jeweils mit dem Zeichen | getrennt angegeben werden (z.B. sparm1| sparm2).

Sollen mehrere Zeilen einer Tabelle bestimmt werden, können die Parameter für diese Zeilen mit Komma getrennt werden (z.B. z1sparm1| z1sparm2, z2sparm1| z2sparm2).

Flexibler ist die Definition von variablen Feldkriterien mit Joker Zeichen. Z.B *|*|Yes um alle Zeilen auszuwählen, die in der dritten Spalte 'Yes' enthalten (für eine negative Bedingung kann '<>Yes' angegeben werden).


LOGOUT
siehe auch 'MAP'

Abmelden von einem Server.

Syntax:
LOGOUT server

Beispiel:
 LOGOUT s49if02


MAP
siehe auch 'NET', 'LOGOUT'

Verbinden eines Servers mit einem Laufwerk.

Syntax:
MAP laufwerksbuchstabe:= server\volume: [userid passwort ]

Bemerkungen:
 Das passwort wird während des Joblaufs und im Job-Protokoll verschlüsselt sichtbar gemacht.
Das Abmelden von einem Server kann mit dem Befehl 'LOGOUT' erfolgen.

Hinweis:
 Ab Windows 9x und ab Windows NT 4.0 kann auch der Befehl 'NET' benutzt werden.

Beispiel:
 MAP h:=s49if02\two: t49imjm geheim


MkDir

Erstellen von neuen Verzeichnissen.

Syntax:
MakeDir Verzeichnisname
 MkDir Verzeichnisname
 MD Verzeichnisname

Bemerkungen:
 Die Anweisung wird nur durchgeführt, wenn der angegebene Verzeichnisname noch nicht vorhanden ist. Es werden alle Teilverzeichnisse, die in dem Verzeichnisnamen enthalten sind mit angelegt.

Beispiel:
md c:\verz1\verz2\ver3


MOVE

Verschieben von Dateien und Verzeichnissen.

Syntax:
MOVE QuellName ZielName
MOVE QuellTeilname ZielTeilname

Hinweis:
 Es können nur Dateien verschoben werden, die auf dem gleich Datenträger liegen.

Beispiel:
 move h:\eisims\NDB\DATA\I\ALFA.exe h:\eisims\old\I

move h:\eisims\NDB\DATA\I\ALFA.* h:\eisims\old\I


MSG

Ausgeben von Nachrichten, die vom Benutzer bestätigt werden müssen.

Syntax:
MSG [BEEP [dauer ] | [PLAY klangdatei , ] | [CALL( dateiname [,parameter ]), ] nachricht

Bemerkungen:
 Achtung! Der Joblauf wird unterbrochen, bis der Benutzer diese Meldung bestätigt hat.

Ist 'BEEP ' angegeben worden, so wird während der Meldungsausgabe ein Piepton in Intervallen ausgegeben. Außerdem erscheint in dem Nachrichtenfenster ein Schalter 'Klang aus', mit dem der Ton ab- und angeschaltet werden kann.

Der einfache Piepton bewirkt nur ein kurzes Knacken im PC-Lautsprecher. Eine Angabe von mindestens 100 als Dauer ist sinnvoll. Unter Umständen hat der Befehl 'BEEP ' keine Wirkung, wenn der System-Lautsprecher nicht ansprechbar ist.

Ist 'PLAY ' angegeben worden, so wird während der Meldungsausgabe die angegebene Klangdatei (WAV-Format) in Intervallen ausgegeben. Ist keine Ausgabe eines Klanges möglich, wird statt dessen ein Piepton ausgegeben.

Ist 'CALL( ' angegeben worden, so kann ein Schalter erzeugt werden, mit dem der Benutzer ein Programm oder eine Datei aufrufen kann. Die Funktionsweise entspricht der Parameterfunktion 'CALL'.

Wird dieser Befehl nicht als letzter Befehl des Jobs definiert, erscheint in dem Nachrichtenfenster ein Schalter 'Abbrechen', mit dem die Ausführung des Jobs an dieser Stelle abgebrochen werden kann.

Beispiel:
MSG Job fertig!

MSG Beep 200, Job fertig!
MSG PLAY g:\jobsys\fertig.wav, Job fertig!
MSG CALL( wopcheck.hlp,DataView) , Datenbank-Check


NET (extern)

Ausführen von Aktionen, die sich auf Netzwerkresourcen beziehen. Im Folgenden wird nur die Funktion 'NET USE' beschrieben, die das Verbinden eines Servers mit einem Laufwerk und das Trennen ermöglicht.

Syntax:
NET USE [laufwerksbuchstabe: | * ] \\server\volume /user: userid passwort [/delete ]

Bemerkungen:
 Wird anstelle des Laufwerkbuchstabens ein Sternchen * angegeben, so wird der nächste freie Laufwerksbuchstabe zugewiesen.

Hinweis:
 Der Befehl 'NET' ist ein Befehl der Betriebssysteme Windows 9x und ab Windows NT 4.0 und bietet je nach Zugriffsrechten des Benutzers weitere Funktionen, die in der DOS-Oberfläche mit dem Befehl 'NET HELP' abgerufen werden können.

Beispiel:
 NET USE h: \\s49if02\two /user:t49imjm geheim
NET USE h: /delete


NOWAIT

Ausführen der nachfolgenden Befehle, ohne auf die Beendigung des vorheriges Programms zu warten.

Syntax:
NOWAIT

Beispiel:
 jsbatch /R c:\jobs\sonder.bat
NOWAIT
MSG 2. Job gestartet

Sollen an das aufgerufene Programm per Befehl 'SENDKEYS' Tastendrücke übergeben werden, so darf der Befehl 'NOWAIT' erst danach angegeben werden.


PACK

Dateien im Zip Format packen.

Generelle Syntax:
PACK [ZIP | ZIPEXE | EXEZIP ] QuellName [Ausgabename ] [Optionen ]

Dateien im ZIP-Format packen:
Syntax1:
PACK ZIP | ZIPEXE QuellName [ZipAusgabename ] [/Subdirs ] [/Pathnames ] [/SubPathnames ] [/Update ] [/Delete ] [/Move ] [/Compression n ]

Syntax2:
PACK ZIP | ZIPEXE @QuellnamenDatei [ZipAusgabename ] [/Pathnames ] [/Update ] [/Delete ] [/Move ] [/Compression n ]

Syntax3:
PACK ZIPEXE ZipDateiname

Syntax4:
PACK EXEZIP ExeZipDateiname

Bemerkungen zu Zip-Formaten:
 Wird kein ZipAusgabename angegeben, so wird der QuellName mit der Endung '.ZIP' bzw. '.EXE' als ZipName erstellt.
Mit dem Zusatz '/Subdirs' werden auch Dateien gepackt, die sich in Verzeichnissen unterhalb des angegebenen Pfades von QuellName befinden.
Mit dem Zusatz '/Pathnames' wird der Pfadname (ohne Laufwerksbuchstabe) mit übernommen.
Mit dem Zusatz '/SubPathnames' werden nur Pfadnamen übernommen, die sich unterhalb des angegebenen Pfades von QuellName befinden.
Soll keine neue Zipdatei erstellt werden, sondern eine vorhandene Zipdatei mit neuen Dateien ergänzt oder aktualisiert werden, so muss der Zusatz '/Update' angegeben werden.
Zum Löschen von Dateien innerhalb einer vorhandenen Zipdatei muss der Zusatz '/Delete' angegeben werden.
Sollen die Dateien nach dem Packen gelöscht werden, muss der Zusatz '/Move' angegeben werden.
Mit dem Zusatz '/Compression n' kann die Komprimierungsstärke eingestellt werden. Die wählbaren Werte sind 0 - 9. Dabei bedeutet 0 gar keine Komprimierung. Die Werte 1, 3, 5, 7 und 9 entsprechen in etwa den Optionen -es, -ef, -en, -ex und -exx des Programms PKZip.

Die 2. Syntax dient zum Packen von mehreren Dateien in eine Zipdatei. Es muss nach dem Klammeraffenzeichen @ eine Datei angegeben werden, die die Namen der zu packenden Dateien enthält. Hier ist der Zusatz '/Pathnames' nur wirksam, wenn die Dateinamen in der angegebenen Datei auch Pfadangaben enthalten.

Der Zusatz 'ZIP' ist der Standardwert und bewirkt eine Komprimierung im PKZip-Format.

Zusatz 'ZIPEXE' bewirkt die Erstellung einer selbstextrahierenden Zip-Programmdatei (Dateiendung '.EXE') zusätzlich zur normalen Zip-Datei. Die selbstextrahierende Programmdatei kann unter DOS ausgeführt werden (siehe auch Hinweis).

Mit der 3. Syntaxform kann eine schon vorhandene Zipdatei (...'.ZIP') in eine selbstextrahierenden Zip-Programmdatei (...'.EXE') umgewandelt werden.
Mit der 4. Syntaxform kann eine schon vorhandene selbstextrahierenden Zip-Programmdatei (...'.EXE') in eine Zipdatei (...'.ZIP') umgewandelt werden.

Hinweis:
 Wird der Befehl 'DOSPack/Unpack' definiert, so wird nur die Anzahl der gesamten Bytes während des Packvorganges in der Statuszeile des Batchlauf-Moduls angezeigt.

Wird der Zusatz 'EXEZIP' benutzt, so muss zu dieser Funktion das Programm 'ZIP2EXE.EXE' im Verzeichnis des Job-System-Programms vorhanden sein.

Soll eine selbstextrahierende Programmdatei unter Verwendung von PKWare Software erstellt werden (mit entsprechenden Meldungen beim Entpacken), so muss der Zusatz 'ZIPPKEXE' angegeben werden. Außerdem muss dazu das Programm 'ZIP2EXE.EXE' im Verzeichnis des Job-System-Programms vorhanden sein.

Ist als Befehl 'DOSPack' angegeben worden, so müssen zur Funktion des gesamten Pack-Befehls die Programme 'PKZIP.EXE' und 'ZIP2EXE.EXE' im Verzeichnis des Job-System-Programms vorhanden sein.

Nach dem Start der DOS-PKZIP Programme wartet der Job auf die Beendigung und fährt erst danach mit dem Joblauf fort. Bei Dateien, die größer als 10 MB sind, wird ein Hinweis mit der zu packenden Dateigröße ausgegeben.

Achtung:
 Wird kein Ausgabedateipfad angegeben, so entspricht das Verzeichnis der gepackten Ausgabedatei immer dem Verzeichnis der zu packenden Dateien, unabhängig vom aktuellen Arbeitsverzeichnis.


PRINTFILE

Drucken einer Datei.

Syntax 1:
PRINTFILE dateiname [/Application programmdatei ] [/ParmFile parameterdatei ] [Option1 wert1 OptionN wertN ... ] [/Element tabelle | /ALL]

Syntax 2:
PRINTFILE /ListDevices | /ListFonts

Bemerkungen:
Syntax 1 führt den normalen Befehl aus.

Syntax 2 dient zum Testen vorhandener Druckereinrichtungen. Die Option /ListDevices listet im Protokoll alle Gerätenamen der Drucker aus, mit denen der Rechner verbunden ist. Die Option /ListFonts listet im Protokoll alle installierten Schriften des Druckers aus, der entweder als Standarddrucker gesetzt ist oder über einen Druckbefehl der Syntax 1 gesetzt wurde.

Ist dateiname eine Datei, die mit Microsoft® Word®, Excel®, Powerpoint® oder Adobe® Reader® (PDF) verknüpft ist, so wird das entsprechende Programm zum Druck aufgerufen. In diesem Fall werden nur die Optionen /PaperSize und /PaperBin unterstützt. Falls der Aufruf des verknüpften Programms nicht durchgeführt wird, kann mit der Option /Application der Pfad der Anwendung explizit angegeben werden.

Ist dateiname eine Microsoft® Excel® Datei, kann man mit der Option /Element eine bestimmte Tabelle angeben. Um alle Tabellen zu drucken kann das Schlüsselwort /ALL als Tabellenname angegeben werden.

Mit der Option /ParmFile können alle folgenden Optionen in einer parameterdatei übergeben werden.

Option | Bedeutung | Wert
/Copies | Anzahl der zu druckenden Kopien | numerisch
/DeviceName | Gerätename des Druckers | alphanumerisch
/DriverName | Namen des Druckertreibers | alphanumerisch
/Duplex | Ein- und beid-seitiger Druck | 1 = Simplex, 2 = Duplex horizontal, 3 = Duplex vertikal
/FontBold | Fettschrift | 0 = ausgeschaltet, -1 = eingeschaltet
/FontItalic | Kursivschrift | 0 = ausgeschaltet, -1 = eingeschaltet
/FontName | Name einer Schrift auf dem Drucker | alphanumerisch (/ListFonts ermittelt vorhandene Schriften)
/FontSize | Größe einer Schrift auf dem Drucker | Anzahl Punkte (max. 2160)
/Orientation | Druck im Hoch- oder Querformat | 1 = Hochformat, 2 = Querformat
/PaperBin | Behälter für die Papierentnahme | 1 = Oberer, 2 = Unterer, 3 = Mittlerer, 4 = manuelle Einzelblätter, 5 = Umschlagspapiereinzug, 6 = Umschlagspapiereinzug manuell einlegen, 7 = aktuell voreingestellter Behälter (Standard), 8 = Traktor-Einzug, 9 = kleiner Behälter, 10 = großer Behälter, 11 = Einzug mit großem Papiervorrat, 14 = Kassetten-Cartrigde
/PaperSize | Papiergröße | Werte von 1 - 41, 256 = Benutzerdefiniert
/PrintQuality | Druckerauflösung | -1 = Entwurfsauflösung, -2 = Geringe Auflösung, -3 = Mittlere Auflösung, -4 = Hohe Auflösung


Programm
siehe auch '/Include' und 'START'

Aufruf eines beliebigen Programms.

Syntax1:
 [DOS | DOSBOX... ] programmname [parameter ]

Syntax2:
 dateiname [parameter ]

Bemerkungen:
 DOS-Batches müssen mit Extension .BAT angegeben werden.
DOS-Programme mit der Endung .COM müssen auch mit der Extension .COM angegeben werden.
Als Programm kann auch das Batchprogramm selbst aufgerufen werden.

Handelt es sich bei dem aufzurufenden Programm um ein DOS-Batch oder ein DOS-Programm so kann es notwendig sein, dass das Programm in einem DOS-Fenster laufen muss. Dies kann man mit dem Zusatz 'DOS ' erreichen.

Manche DOS-Programme benötigen eine besondere Speicherzuweisung um ausgeführt werden zu können. Das Job-System erlaubt folgende Einstellungen vorzugeben.

Zusatz | Anfängl. Speicher | EMS | XMS | DPMI
DOSBOX (Standard) | 4096 | Automatisch | 16384 | 16384
DOSBOXAUTO | Automatisch | Automatisch | Automatisch | Automatisch
DOSBOXBIG | Automatisch | 32000 | 32000 | 3200

Die Syntax2 kann benutzt werden, wenn der Dateityp (z.B. Endung .TXT) des angegebenen Dateinames mit einem Programm verknüpft ist und zusätzlich notwendige Parameter oder der Ort des Programms nicht bekannt sind (oder auf unterschiedlichen Rechnern anders installiert sind).

Hinweis:
 Enthält der Programmname Leerzeichen, muss er in Gänsefüßchen eingeschlossen sein.

Beispiele:
 notepad c:\autoexec.bat
DOS dispatch.bat
"c:\Programme\Easy CD Creator\creatr32.exe" G:\JobSys\Batch\cdlayout.cl3
readme.txt
 db_abnut.prm

Nach dem Programmaufruf wartet der Batch-Job auf die Beendigung des Programms und fährt erst danach mit dem Batchlauf fort. Die Prüfung der Programmbeendigung erfolgt alle 5 Sekunden.

siehe auch:
NOWAIT
 SENDKEYS
 START


; / ' / REM

Mit diesen Befehlen bzw. Zeichen können Kommentarzeilen gekennzeichnet werden.

Syntax:
; text
 REM text

Beispiel:
 ; Dies ist ein Kommentar
REM Dies ist auch ein Kommentar


REName

Umbenennen von Dateien.

Syntax:
REN AltName NeuName
REN AltTeilname NeuTeilname

Bemerkungen:
 Ist ein AltTeilname (Dateiname, der Jokerzeichen wie '* ' oder '? ' enthält) angegeben worden, so werden die Namenstücke, die durch die Jokerzeichen gefunden wurden, in dem NeuTeilnamen jeweils bei dessen Jokerzeichen eingesetzt.

Die Reihenfolge der Ersetzungen im NeuTeilnamen entspricht der Reihenfolge der Jokerzeichen im AltTeilnamen .

Das heißt, dass das gefundene Namensstück des 1. Jokerzeichens im AltTeilnamen an der Stelle des 1. Jokerzeichens im NeuTeilnamen eingesetzt wird. Das gefundene Namensstück des 2. Jokerzeichens im AltTeilnamen an der Stelle des 2. Jokerzeichens im NeuTeilnamen usw.

Beispiel:
 REN c:dbi*.* c:dbiv*.*

Mit dem Zeichen '? ' kann ein gefundenes Namensstück des AltTeilnamen mit der Länge, die der Anzahl der '? ' entspricht, in den NeuTeilnamen übernommen werden. Ist das gefundene Namensstück länger als die Anzahl der '?' ist, wird das Namensstück von links nach rechts bis zur angegebenen Länge übernommen.

Beispiel:
 REN c:\db\i*.* c:\db\iv???.*

Soll aber das gefundene Namensstück von rechts nach links übernommen werden, so kann im NeuTeilnamen das Jokerzeichen '< ' benutzt werden.

Beispiel:
 REN c:\dkb\KSBCDR*. G.*.* c:\dkb\cdr**.<<<

ergibt z.B. folgendes:

aus | wird
KSBCDR1.G.1.19974 | cdr11.974
KSBCDR1.G.D.19974 | cdr1d.974
KSBCDR1.G.D02.19974 | cdr1d02.974
KSBCDR1.G.E.19974 | cdr1e.974
KSBCDR1.G.E01.19974 | cdr1e01.974


RmDir

Löschen von Verzeichnissen.

Syntax:
RmDir Verzeichnisname
 RD Verzeichnisname

Bemerkungen:
 Es wird jeweils nur das letzte Teilverzeichnis gelöscht. Enthält dieses Teilverzeichnis noch Dateien, so wird ein Fehler erzeugt.

Beispiel:
rd c:\verz1\verz2\verz3


SENDKEYS

Mit diesem Befehl kann das Drücken von Tasten simuliert werden.

Dies kann dazu benutzt werden, um ein Programm, dass mit dem Job aufgerufen wurde, per Tasten (Menüaufrufe, Eingabe von Daten etc.) zu steuern.

Syntax:
SENDKEYS [{AFTER n sec} ] Tastenzeichen [{TOWINDOW ' fenstertitel '} ]

Für Sondertasten gibt es bestimmte Tastenzeichen :

Taste | Zeichen | Taste | Zeichen
Rückschritt | {BACKSPACE} oder {BS}oder {BKSP | Pause | {BREAK}
Caps Lock | {CAPSLOCK} | Clear | {CLEAR}
Entf | {DELETE} oder {DEL} | Pfeil unten | {DOWN}
Ende | {END} | Eingabe | {ENTER} oder ~
Esc | {ESCAPE} oder {ESC} | Hilfe | {HELP}
Pos1 | {HOME} | Einfg | {INSERT}
Pfeil links | {LEFT} | Num Lock | {NUMLOCK}
Seite runter | {PGDN} | Seite hoch | {PGUP}
Print Screen | {PRTSC} | Pfeil rechts | {RIGHT}
Scroll Lock | {SCROLLLOCK} | Tabulator | {TAB}
Pfeil oben | {UP} |  |
F1 | {F1} | F2 | {F2}
F3 | {F3} | F4 | {F4}
F5 | {F5} | F6 | {F6}
F7 | {F7} | F8 | {F8}
F9 | {F9} | F10 | {F10}
F11 | {F11} | F12 | {F12}
F13 | {F13} | F14 | {F14}
F15 | {F15} | F16 | {F16}

Um Tasten anzugeben, die zusammen mit einer der Tasten Umschalten, Strg und Alt gedrückt werden, können folgende Zeichen allein oder kombiniert davor gestellt werden.

Taste | Zeichen
Umschalten | +
Strg | ^
Alt | §

Um diese Zeichen, sowie %, runde und geschweifte Klammern, selbst als Taste angeben zu können, müssen diese in geschweifte Klammern eingeschlossen werden z.B. {+}, ([ ]), {{}.

Um anzugeben, dass Umschalten, Strg oder Alt zusammen mit mehreren anderen Tasten gleichzeitig gedrückt werden sollen, sollten diese in Klammer eingeschlossen werden. Wenn zum Beispiel die Umschalten Taste gedrückt werden soll und gleichzeitig E und C , so muss man "+(EC)" angeben.

Um sich wiederholende Tastendrucke anzugeben, benutzt man die Form {Taste Anzahl }; zwischen Taste und Anzahl muss ein Leerzeichen stehen. So bedeutet zum Beispiel {LEFT 42}, dass die Taste Pfeil links 42 mal gedrückt wird.

Mit dem Zusatz '{AFTER n sec} ' kann das Senden der Tastendrucke verzögert werden. Dabei ist der Wert in Sekunden anzugeben. Sollen Bruchteile einer Sekunde angegeben werden, muss als Kommazeichen der Punkt '. ' benutzt werden; z.B. '{AFTER 0.5}'.

Mit dem Zusatz '{TOWINDOW ' fenstertitel '} ' kann der fenstertitel des Fensters angegeben werden, zu dem die Tastendrucke geschickt werden sollen. Dies ist notwendig wenn das Fenster des Fremdprogramms im Hintergrund verschwinden könnte. Der Job holt dann dieses Fenster zuerst in den Vordergrund bevor es die Tastendrucke sendet. Zur Unterstützung dieser Option kann der Menüpunkt 'Fenstertitel kopieren' des Befehls-Editors benutzt werden. Zu beachten ist, dass der fenstertitel in Hochkommata eingeschlossen sein muss.

Hinweis :
Der SendKeys Befehl kann nur Tastendrucke an Programme senden, die für Microsoft Windows programmiert wurden (also keine DOS-Programme). Die Bildschirm-Druck Taste (Druck) kann nicht gesendet werden.

Beispiel:
 notepad
SENDKEYS §DFC:\AUTOEXEC.BAT{ENTER}

In diesem Beispiel wird zuerst das Programm 'notepad' aufgerufen.
Danach wird mit Alt + D das Dateimenü aufgerufen. Danach mit F das Untermenü 'Öffnen...'.
Dann wird der Text 'C:\AUTOEXEC.BAT' eingetragen und mit dem Zeichen ~ die Entertaste betätigt.

Zum Aufzeichnen von Tasteneingaben siehe auch Bearbeiten-Menü des Befehls-Editors.

Das nächste Beispiel zeigt, wie man ein Programm aufruft und dann das Fenster dieses Programms in den Vordergrund bringt um die Tastendrucke dorthin zu senden. Zum Ermitteln eines Fenstertitels siehe auch Bearbeiten-Menü des Befehls-Editors.

ZipSelfExtr.exe C:\Daten\adressen.zip
SENDKEYS {After 2 sec}{TAB 2}c:\kundenpfad{ENTER}{ToWindow 'Self-Extractor Programm'}


SETATTRIB

Setzen von Dateiattributen.

Syntax:
SETATTRIB DateiName READONLY | NORMAL
SETATTRIB DateiTeilname READONLY | NORMAL [/SubDirs] [/ShortLog]

Bemerkungen:
 Wird das Attribut 'ReadOnly' gesetzt, so ist eine Datei gegen Überschreiben geschützt. Das Attribut 'Normal' setzt wieder in den ungeschützten Zustand zurück. Alle anderen gesetzten Attribute einer Datei werden nicht geändert.

Wird die Syntax mit DateiTeilname benutzt, können mit der Option /SubDirs auch Dateien von Unterverzeichnissen berücksichtigt werden. Mit der Option '/ShortLog' kann die Ausgabe aller Dateinamen unterdrückt werden. Anstelle dessen wird die Anzahl der Dateien ausgegeben.

Hinweis:
 Wird die Syntax mit DateiTeilname benutzt, werden keine versteckten Dateien und keine Systemdateien berücksichtigt.

Beispiel:
 setattrib h:\eisims\NDB\DATA\I\ALFA.exe Readonly
setattrib h:\eisims\NDB\DATA\I\ALFA.* Normal


SORT

Sortiert eine Datei.

Syntax:
SORT dateiname [Ausgabedatei ] [Startposition [Sortierlänge ]] [/Ascending | /Descending ] [/CaseSensitiv | /NotCaseSensitiv ]

Bemerkungen:
 Wenn keine Startposition und keine Sortierlänge angegeben wurde, wird der vollständige Datensatz angenommen. Wenn keine Sortierlänge angegeben wird, wird der Datensatz ab Startposition bis zum letzten Zeichen angenommen. '/Ascending ' sortiert aufsteigend und ist die Standard -Einstellung. '/CaseSensitiv ' berücksichtigt Groß/Klein-Schreibung und ist die Standard -Einstellung.

Beispiel:
sort c:\daten\kunden.dat c:\daten\kundensort.dat 10 50


START
siehe auch 'Programm ' und 'INLINE'

Starten von Programmen.

Syntax:
 [scriptvariable = JSBatch.]START [/Min | /Max | /Hide ] [/NoWait ] programmname |dateiname [parameter ]

Bemerkungen:
 Mit diesem Befehl können Programme explizit aufgerufen werden. Er dient vor allem zur Benutzung innerhalb eines mit dem Befehl 'INLINE' definierten Script Programmcodes.

Bei Verwendung innerhalb einer Scriptsprache kann dieser Befehl einen so genannten Processhandle in scriptvariable zurückgeben. Ist dieser ungleich 0, so ist das als Parameter angegebene Programm erfolgreich gestartet worden.

Mit den Optionen '/Min ', '/Max ' und '/Hide ' kann die Ansicht des Fensters des aufgerufenen Programms vorgegeben bzw. unterdrückt werden.

Mit der Option '/NoWait ' wartet der Job nicht auf die Beendigung des gestarteten Programms und läuft sofort weiter.

Hinweis:
 Soll der Befehl 'SENDKEYS' für das aufgerufene Programm nachfolgend benutzt werden, so muss die Option '/NoWait ' angegeben werden.

Beispiele:
Start /max c:\daten\DatabaseInformation.xls
Start /max /nowait notepad.exe c:\daten\beschreibung.txt


UNPACK

Eine im Zip-Format gepackte Datei mit PKUnZip entpacken.

Syntax:
UNPACK ZipDateiname [Ausgabepfad ] [/LF-CRLF ] [/List ]

Bemerkungen:
 Als ZipDateiname kann auch eine selbst entpackende Programmdatei angegeben werden.

Wird kein Ausgabepfad angegeben, so entspricht das Verzeichnis der entpackten Ausgabedateien immer dem Verzeichnis der gepackten Zipdatei , unabhängig vom aktuellen Arbeitsverzeichnis.

Mit dem Zusatz '/LF-CRLF ' können Textdateien, die auf dem Unix-Betriebssystem gepackt wurden, korrekt wieder entpackt werden. Dabei werden eventuelle Satzendekennzeichen Linefeed in CarriageReturnLineFeed umgewandelt.

Mit dem Zusatz '/List ' wird nur eine Auflistung der in ZipDateiname enthaltenen Dateien in die Job-Protokolldatei ausgegeben. Es werden der Dateiname, die entpackte Größe und das Datum der letzten Änderung ausgegeben.

Hinweis:
 Ist als Befehl 'DOSUNPACK' angegeben worden, so müssen zur Funktion des Befehls das Programm 'PKUNZIP.EXE' im Verzeichnis des Job-System-Programms vorhanden sein.

Nach dem Start des DOS-PKUNZIP-Programms wartet der Job auf die Beendigung und fährt erst danach mit dem Joblauf fort. Bei Dateien, die größer als 10 MB sind, wird ein Hinweis mit der zu entpackenden Dateigröße ausgegeben.


WAIT

WAIT nn zeiteinheiten

Mit diesem Befehl kann ein Job angehalten werden, bis eine bestimmte Zeit verstrichen ist.

Syntax:
WAIT nn SECONDS | MINUTES | HOURS

Beispiel:
 WAIT 30 seconds


WAIT UNTIL EXISTS
siehe auch 'FTP wait until exists'

Mit diesem Befehl kann ein Job angehalten werden, bis eine bestimmte Datei existiert , sich in ihrer Größe nicht mehr verändert und zum Schreiben geöffnet werden kann.

Syntax:
WAIT UNTIL EXISTS Dateiname

Die Prüfung der Datei erfolgt dabei alle 30 Sekunden.


WAIT UNTIL HH:MM

Mit diesem Befehl kann ein Job angehalten werden, bis eine bestimmte Uhrzeit ereicht ist.

Syntax:
WAIT UNTIL stunde: minute

Beispiel:
 WAIT UNTIL 20:30

Die Prüfung der Zeit erfolgt dabei alle 30 Sekunden.


WRITETO
siehe auch 'INLINE'

Ausgabe von Textzeilen in eine Datei oder senden von Nachrichten an E-Mail Empfänger.

Syntax 1:
WRITETO dateiname | CLIPBOARD
 Textzeile
" "
ENDWRITETO

Syntax 2:
WRITETO MailUser [/Show ] [dateiname ]
[[Host]
SMTP=SMTPadresse]
[User]
From=Profilname
 [FromDisplay=Anzeigename]
[UserName=AnmeldeBenutzername]
 [Password=Profil/AnmeldePasswort]
 To=Haupt-Empfängername[;Haupt-Empfängername ]
[CC=Zusatz-Empfängername[;Zusatz-Empfängername ]]
[BCC=Blind-Empfängername[;Blind-Empfängername ]]

[Note]
Subject= Betriffttext

Nachrichtentextzeile
" " [{ anhangdateiname } ]
ENDWRITETO

Bemerkungen:
 Innerhalb der Befehle 'WriteTo ' und 'EndWriteTo ' werden angegebene Parameter und temporäre Dateinamen ersetzt sowie Steuerbefehle ausgeführt. Alle anderen Jobbefehle werden nicht berücksichtigt.

Bei der Syntax 1 werden die angegebenen Textzeilen entweder in die Datei dateiname geschrieben oder mit dem Schlüsselwort CLIPBOARD in die Windows Zwischenablage kopiert.

Bei der Syntax 2 bewirkt der Zusatz 'MailUser' eine Übergabe der nachfolgenden Angaben an das externe E-Mail-Programm 'JSMAIL', das E-Mails im Hintergrund absenden kann. In diesem Fall ist dateiname nicht zwingend notwendig, kann aber zur Abtrennung von Empfängerangaben benutzt werden (dann wird der Inhalt dieser Datei mit übergeben).

Soll das E-Mail nicht im Hintergrund, sondern manuell abgeschickt werden (z.B. um ad hoc Änderungen von Empfänger oder Nachricht vornehmen zu können), so muss der Zusatz '/Show ' angegeben werden.

Die Sektion [Host] kann benutzt werden, wenn das Email per SMTP gesendet werden soll. Dann muss mit SMTP= die SMTP-Adresse angegeben werden.

Die Sektion [User] bestimmt Sender- und Empfänger-Adressen.

Wenn noch keine Email-Session geöffnet ist (also kein Email-Programm wie z.B. Outlook), muss der Profilname mit From= und das Profilpasswort mit Password= angegeben werden. Wenn dies nicht geschieht, wird während der Ausführung ein Fenster erscheinen, in dem man die Werte nachträglich manuell eingeben kann.

Ist durch die SMTP Adressangabe die SMTP Sendeart bestimmt worden, muss mit From= der Absender angegeben werden. Ist eine Authentisierung beim SMTP Server notwendig, so müssen mit UserName= und Password= die entsprechenden Anmeldeinformationen definiert werden.

Die Angabe der Empfänger wird mit den Einträgen To= und CC= (Kopie) bzw. BCC= (versteckte Kopie) definiert.

Danach kann mit der Sektion [Options] mit dem Eintrag ReceiptRequested=No die Empfangsbestätigung (die Rücksendung eines Hinweises, wenn der Empfänger die Nachricht öffnet) unterdrückt werden.

Als letzte Sektion folgt [Note] mit dem Eintrag Subject= , mit dem die Betreff-Angabe definiert werden muss!. Der eigentliche Nachrichtentext muss in der nächsten Zeile beginnen.

Innerhalb des Nachrichtentextes können Dateien eingefügt werden (Anhang). Dazu muss der Dateiname mit geschweiften Klammern '{ } ' eingeschlossen sein.

Hinweis:
Ist in den Programm Optionen die Option 'SMTP für E-Mail benutzen' aktiviert und eine SMTP Adresse angegeben, wird automatisch die Sektion [Host] mit dieser SMTP Adresse eingefügt.

Beispiel:
WriteTo c:\daten\params.txt
Folgendes Datum muss verarbeitet werden:
%Tag%.%Monat%.%Jahr%
EndWriteTo

WriteTo MailUser
[User]
To =Monika Reisser

[Note]
Subject= L91-Lieferung per ISDN für %MM%/%JJ%

Hallo,

Die L91-Kontrolldatei für ISIS wurde im Verzeichnis ISIS01 und SCHWAR02 auf dem ISDN-Server bereitgestellt.

Gruß
Jürgen Markart
EndWriteTo


FTP-Befehlstypen

Die aufgeführten Befehle sind spezielle Befehle, die außer den üblichen FTP-Befehlen besondere Möglichkeiten bieten.

Anmeldung
FTPLogin
 FTPLogout
 FTP Server zu Server

Ausführung
submit
 wait until exists

Dateien
copy
 DCB-Befehle
 FileType-Befehle
mkdir
site

Informationen
addtologfile


addtolog
siehe auch 'PC ADDTOLOG'

Hinzufügen eines Dateinhaltes einer Datei vom Fernrechner in die Job-Protokolldatei.

Syntax:
AddToLog hostname:dateiname [/ErrorIfNotExists [( n) ] suchtext ] [/ErrorIfExists suchtext ]

Bemerkungen:
 Der Inhalt der mit Dateiname angegebenen Datei wird in das Job-Protokoll eingefügt, wenn zuvor mit dem Befehl 'submit' ein Host-Job gestartet wurde und dieser vom Job als beendet erkannt wurde.

Dies ist dann sinnvoll, wenn ein vorher aufgerufener Host-Job ein Programm gestartet hat, dessen Protokollausgaben dem Benutzer im aktuellen Job-Protokoll sichtbar gemacht werden sollen.

Mit den Angaben '/ErrorIfNotExists' und '/ErrorIfExists' kann man an Hand von Informationen aus der eingelesenen Datei, den Job abbrechen lassen. '/ErrorIfExists' kann mehrmals angegeben werden.

Bei '/ErrorIfNotExists' kann mit einem in Klammern eingeschlossenen Zahlenausdruck bestimmt werden, wie oft der nachfolgend angegebene suchtext mindestens vorkommen muss. Tritt suchtext pro Zeile mehrfach auf, dann wird er nur einmal gezählt.

Enthält der suchtext Leerzeichen, so muss er in Hochkomma eingeschlossen werden.

Beispiel:
 Es soll ein Job auf dem Host gestartet werden, der Dateien per Host-FTP auf einen anderen Fernrechner schicken soll. Dabei sollen dem Benutzer nach der Vollendung des Host-Jobs die Protokollausgaben des Host-FTP-Programms sichtbar gemacht werden um die übertragenen Dateien und die Dateigrößen zu kontrollieren.

Eine fehlerhafte Ausführung des Host-FTP's soll zum Abbruch des Jobs führen.

FTPLogin IBM 162.44.3.9 %Host-UserID% %Host-Passwort%
submit
//OYFTP JOB ('XNFL01 ',0035),'%Host-UserID%',
// MSGCLASS=T,CLASS=B,NOTIFY=%Host-UserID%
//*
//KILL EXEC=RPMKILL,PARM='%Host-UserID%.FTPSEND.PROT.M%MM%%JJ%.C%FirmNr%'
//*
//FTPSEND EXEC PGM=FTP
//SYSPRINT DD SYSOUT=*
//OUTPUT DD DSN=%Host-UserID%.FTPSEND.PROT.M%MM%%JJ%.C%FirmNr%
//INPUT DD *
162.44.130.3 (TRAN GERMAN
%Host-UserID%
%Host-UserID%
SENDSITE
CD /xtre_ger/server/data/input/%FirmPfad%
PUT '%arForm%.%arForm%.PFC.%FDForm%.M%MM%%JJ%.C%FirmNr%' %FirmDKZ%%MM%%JJ%.%Ext%
PUT '%arForm%.%arForm%.PFC.DESC.M%MM%%JJ%.C%FirmNr%' %FirmDesc%.dat
QUIT
/*
endsubmit
 ; Einlesen des Host-FTP-Protokolles
AddToLog IBM:%Host-UserID%.FTPSEND.PROT.M%MM%%JJ%.C%FirmNr% /ErrorIfNotExists(2) : 'Transfer complete'
FTPLogout


copy
siehe auch 'PC COPY'

Dient zum Übertragen einer Datei vom oder zum Fernrechner.

Syntax:
copy [hostname: ]QuellName [hostname: ]ZielName
copy [hostname: ]QuellTeilname [hostname: ]ZielTeilname

Bemerkungen:
 Die Anzahl übertragener Bytes und der prozentuale Übertragungsfortschritt wird während der Übertragung in der Statuszeile des Batchlauf-Moduls angezeigt (nur wenn kein DOS-FTP-Programm benutzt wird; siehe FTPLogin ).

Enthält der Dateiname Leerzeichen, so muss er inklusive dem hostnamen in Gänsefüßchen eingeschlossen sein.

Hinweis:
Vor dem Kopieren wird geprüft, ob der QuellName überhaupt existiert (siehe NoFileListCheck).

Die Anzahl übertragener Bytes wird zwischen Zieldatei und Quelldatei verglichen, um mögliche Transferfehler auszuschließen.

Beispiel:
 copy g:\daten\callrep\all\input.dat IBM:OYMP.INPUT.ABGL

copy "c:\input daten\input.dat" "FTPServer:Prod Daten/Input.dat"

Hinweis zum Mainframe-Betriebssystem MVS:
 Die notwendige Platzgröße wird beim Kopieren zum Mainframe in 'Cylinder' oder 'Tracks' automatisch vorgegeben, wenn sie nicht vorher explizit definiert wurde (siehe DCB-Befehle).

Beim Kopieren vom Mainframe bezieht sich die Prozentzahl der Fortschrittsanzeige nur auf den von der Datei benutzten Plattenplatz, der im Allgemeinen größer ist als die tatsächlich zu übertragenden Bytes. Befindet sich die zu übertragenden Datei nicht auf Platte sondern z.B. auf Kassette, wird keine Fortschrittsanzeige ausgegeben, da der Mainframe in diesem Fall keine Dateiinformtionen zur Verfügung stellt.

Die Anzahl übertragener Bytes kann aus obengenannten Gründen nicht zwischen Zieldatei und Quelldatei verglichen werden.

Ist ein QuellTeilname (Dateiname, der Jokerzeichen wie '* ' oder '? ' enthält) angegeben worden, so werden alle gefundenen Dateien unter dem angegebenen ZielTeilnamen plus den gefundenen QuellNamensresten kopiert.

Beispiel:
 copy IBM:OYMP.ALL01.GESAMT.* g:\daten\imsview\all\ivall.*

In diesem Beispiel würden alle gefundenen Dateien, die auf dem Mainframe mit 'OYMP.ALL01.GESAMT.' beginnen, mit ihren darauf folgenden Restteilnamen (z.B. HED, IDX, INF), zu folgenden Dateien kopiert:
g:\daten\imsview\all\ivall.hed
g:\daten\imsview\all\ivall.idx
g:\daten\imsview\all\ivall.inf

Zu beachten ist hierbei, dass der Dateiname des Mainframes mit einem Punkt endet. Ohne diesen Punkt, würde alles ab dem letzten Punkt als Restname mit in den Zielnamen genommen werden:

copy IBM:OYMP.ALL01.GESAMT* g:\daten\imsview\all\ivall.*

ergibt
g:\daten\imsview\all\ivall.gesamt.hed
g:\daten\imsview\all\ivall.gesamt.idx
g:\daten\imsview\all\ivall.gesamt.inf

Hinweis zu anderen Betriebssystemen:
 Ist ein QuellTeilname (Dateiname, der Jokerzeichen wie '* ' oder '? ' enthält) angegeben worden, und die gefundenen Namen nach dem Quellpfad sollen genauso übernommen werden, so muss als ZielTeilname nur der entsprechenden Zielpfad angegeben werden.

Ist ein QuellTeilname (Dateiname, der Jokerzeichen wie '* ' oder '? ' enthält) angegeben worden, und die gefundenen Namen nach dem Quellpfad sollen nur zum Teil übernommen werden, so wird der ZielTeilname gemäß den Regeln des PC-Befehls 'RENAME' umbenannt.

Beispiel:
 copy RS6000:KSBCDR*.G.*.* c:\daten\dkb\Input\cdr**.<<<

ergibt z.B.

aus | wird
KSBCDR1.G.1.19974 | cdr11.974
KSBCDR1.G.D.19974 | cdr1d.974
KSBCDR1.G.D02.19974 | cdr1d02.974
KSBCDR1.G.E.19974 | cdr1e.974
KSBCDR1.G.E01.19981 | cdr1e01.981
KSBCDR2.G.E02.19981 | cdr2e02.981


DCB-Befehle

Mit DCB Befehlen können Dateien auf dem Mainframe definiert werden.

Dies kann entweder mit den Befehlen 'quote' und 'site' gemacht werden oder einfacher, indem man den, bei dem Befehl 'FTPLogin' angegebenen hostnamen davor stellt.

Bei Satzlängenangabe wird automatisch die optimale Blockgröße ermittelt. Wird eine Platte angegeben, so wird vom Programm die korrekte 'Unit' Angabe ergänzt.

Beispiel:
IBM recfm=FB, lrecl=260, volume=IMGT05

Das Batch-Programm löst diese Zeile in folgende FTP-Befehle auf:
quote site recfm=FB lrecl=260 blksize=27820 volume=IMGT05 unit=SYSDA

quote site retpd=00

Das bedeutet, dass hier die Angaben 'blksize' (Blockgröße) und 'unit' (Speichermedium) automatisch erzeugt wird.
Als volume kann auch 'SYSWRK' oder 'WRK*' angegeben werden.
Für die Definition von Platzzuweisungen für eine Datei kann z.B. 'cy pri=n sec=m' angegeben werden (n primäre und m sekundäre Zylinder).

DCB Angaben müssen jeweils vor einem 'copy' - Befehl erfolgen.

Werden keine DCB Angaben gemacht, vergibt das Job-Programm automatisch Standardwerte (recfm=vb lrecl=255 blksize=27795 und cy pri=Dateigröße/56660/15 bzw. tr pri=Dateigröße/56660 und sec=10% von pri).


Filetype-Befehle

Filetype Befehle dienen zum Bestimmen des Übertragungstyps.

Syntax:
ascii oder ansi oder binary

'ascii' ist die Standard-Einstellung.
Diese Angabe muss jeweils vor einem 'get', 'put' oder 'copy' erfolgen.


FTP Server zu Server Datenübertragung
siehe auch FTPLogin

Einloggen in zwei Fernrechner per FTP und Übertragen von Dateien.

Syntax:
FTPLogin hostname1 [hostadresse1 userid1 passwort1 [accountcode] | /INLINE ]
FTPLogin hostname2 hostadresse2 userid2 passwort2
 copy hostname1 |hostname2:QuellName hostname2 |hostname1:ZielName
FTPLogout
FTPLogout

Bemerkungen:
 Diese Art der FTP-Datenübertragung kann benutzt werden, wenn Daten von einem Fernrechner nicht auf die lokale Festplatte sondern auf einen File-Server im Netzwerk oder auf einen anderen Fernrechner kopiert werden sollen.

Normalerweise wird auf dem PC ein FTP-Client benutzt, der die Daten mit dem lokalen Betriebssystem über das Netzwerk auf einen oder von einem Fernrechner kopiert. Wenn die Daten aber z.B. auf einen Netzwerk File-Server gestellt werden müssen, werden sie zuerst zum PC und dann vom PC wieder über das Netzwerk auf den File-Server kopiert. Dann machen sich deutliche Geschwindigkeitsverluste bemerkbar, wenn die Netzwerkbelastung durch viele Benutzer sehr hoch ist. Das trifft sowieso zu wenn beide Fernrechner sehr weit vom PC entfernt sind.

Umgehen lässt sich dieses Problem, indem man die Daten direkt an einen FTP-Server schickt, der auf dem entsprechenden File-Server installiert sein muss. Das ist meistens der Fall, da man ja auch von der Seite des anderen Fernrechners aus Daten auf den File-Server übertragen können soll.

Das FTP-Protokoll an sich macht es möglich, von einem FTP-Client aus, eine Verbindung zwischen zwei FTP-Servern aufzubauen und Daten von einem FTP-Server zum anderen FTP-Server übertragen zu lassen. Dabei spielt es keine Rolle, auf welchem Betriebssystem die FTP-Server laufen. So lassen sich vom PC aus initiiert auch Daten z.B. von einem Mainframe auf einen Unix-Rechner übertragen.

Das Job-System bietet diese Möglichkeit durch einfache geschachtelte 'FTPLogin' und 'FTPLogout' Befehle. Die Datenübertragung selbst wird mit dem Befehl 'copy' durchgeführt.

Hinweis:
 Nur der erste Befehl 'FTPLogin' erlaubt die Angabe von accountcode und /INLINE.

Alle Befehle, die einen gemeinsamen Einfluss auf die Art der Datenübertragung haben, gelten für beide FTP-Server. Dass heißt, man muss z.B. einen 'binary' Befehl nicht nochmals nach dem zweiten FTPLogin wiederholen.

Die Richtung der Datenübertragung ist allein von der Angabe des hostnamen beim Befehl 'copy' abhängig.

Bei dem 'copy' Befehl sind nur eindeutige Dateinamen erlaubt (keine Jokerzeichen wie '*' und '?' für Dateiteilnamen).

Bei der Übertragung wird nur die Gesamtanzahl der zu übertragenden Bytes angegeben. Es erscheint keine Fortschrittsanzeige, da der Übertragungsprozeß unabhängig vom FTP-Client abläuft.

Beispiel:
 Kopieren von Daten zwischen einem Mainframe mit MVS Betriebssystem und einem Unix-Rechner.

FTPLogin MVS 162.44.3.9 T49IMJM CORSAR
ascii
MVS recfm=FB, lrecl=80, blksize=27920

FTPLogin Unix 162.44.20.23 t49imjm corsar
copy Unix: /xtre_ger/data/test.dat IBM: OYMP.TEST.ABGL
copy IBM: OYMP.TEST.DATA Unix: /xtre_ger/data/test2.dat
FTPLogout

FTPLogout


FTPLogin
siehe auch FTP Server zu Server Übertragung

Einloggen in einen Fernrechner per FTP und Beginn einer FTP-Session zum Übertragen von Dateien.

Syntax:
FTPLogin hostname [hostadresse userid passwort [accountcode ] | /INLINE ]

Beispiel:
 FTPLogin IBM 162.44.3.9 T49IMJM CORSAR

Bemerkungen:
 Eine FTP-Session gilt bis zu dem Befehl 'FTPLogout' als ein geschlossener Programmaufruf. Das heißt, dass alle Befehle innerhalb dieser Session nacheinander ausgeführt werden und nicht mit PC -Befehlen wie 'NOWAIT' oder 'WAIT' beeinflusst werden können. Außer den FTP-Befehlen sind nur Kommentarzeilen und Parameterfunktionen erlaubt.

Das passwort wird während des Joblaufs und im Job-Protokoll verschlüsselt sichtbar gemacht.

Der hostname kann als Bezeichner für Befehle (z.B. DCB oder site -Befehle) und Dateien des Fernrechners verwendet werden (copy).

Bei Datenübertragung von einem Fernrechner zu einem anderen Fernrechner siehe FTP Server zu Server Übertragung.

Beispiel:
 FTPLogin IBM 162.44.3.9 T49IMJM CORSAR
IBM recfm=FB, lrecl=80, blksize=27920
copy g:\daten\test IBM:OYMP.TEST.ABGL

Mit dem Zusatz '/INLINE ' anstelle von hostadresse , userid und passwort kann man diese drei Parameter innerhalb der FTPSession einlesen. Dabei muss ab der ersten Zeile die Hostadresse folgen. In der nächsten Zeile muss die UserID und wahlweise, mit Leerzeichen getrennt, das Passwort folgen. Wenn das Passwort nicht mit der der UserID angegeben wurde, muss es in der nächsten Zeile stehen.

Beispiel:
 FTPLogin IBM /inline
162.44.3.9
T49IMJM
CORSAR

oder wenn die Angaben erst zur Laufzeit in der Datei 'c:ftpadrs.txt' stehen:

FTPLogin IBM /inline
/include c:\ftpadrs.txt /runtime

Hinweis:
 Ist als Befehl 'DOSFTPLogin' angegeben worden, so muss zur Funktion dieses Befehls und aller FTP-Befehle, das Programm 'FTP.EXE' in einem Systemverzeichnis oder im Verzeichnis des Job-System-Programms vorhanden sein.

Dieses DOS-FTP-Programm gehört zum Lieferumfang von Windows 95 und Windows NT. Wird dieses DOS-FTP-Programm benutzt, sind außer den in dieser Hilfe beschriebenen FTP-Befehlen alle FTP-Befehle möglich, die von 'FTP.EXE' unterstützt werden (siehe auch FTP copy ).

Nach dem Start einer DOS-FTP-Session wartet der Batch-Job auf die Beendigung der FTP-Session und fährt erst danach mit dem Joblauf fort. Die Prüfung der FTP-Session Beendigung erfolgt alle 30 Sekunden.


FTPLogout

Abbrechen der Verbindung zum Fernrechner und Verlassen der FTP-Session.

Syntax:
FTPLogout

Dieser Befehl muss angegeben werden, um das Ende einer FTP-Session zu kennzeichnen.

siehe auch
FTPLogin


FTP mkdir

del, mkdir, rmdir

Löschen von Dateien, Erstellen und Entfernen von FTP Verzeichnissen.

Syntax:
delete Dateiname
 del Dateiname

mkdir Verzeichnisname [/OnErrorIgnore]
md Verzeichnisname [/OnErrorIgnore]

rmdir Verzeichnisname
 rd Verzeichnisname

Bemerkungen:
Die Anweisung delete wird nur durchgeführt, wenn der angegebene Dateiname vorhanden ist.

Die Anweisung mkdir wird nur durchgeführt, wenn der angegebene Verzeichnisname noch nicht vorhanden ist. Es werden alle Teilverzeichnisse, die in dem Verzeichnisnamen enthalten sind mit angelegt. Mit der Option '/OnErrorIgnore' werden Fehler unterdrückt, die entstehen, wenn die Zugriffsberechtigung keine Prüfung auf alle Einzelverzeichnisse zulässt.

Die Anweisung rmdir wird nur durchgeführt, wenn der angegebene Verzeichnisname vorhanden ist.

Beispiel:
md verz1/verz2/ver3


NoFileListCheck
siehe auch 'Copy'

Mit diesem Befehl wird vor dem Kopieren die Prüfung auf die Existenz einer Datei unterdrückt.

Syntax:
NoFileListCheck

Bemerkungen:
Normalerweise wird vor dem Kopieren einer Datei vom Fremdrechner geprüft, ob sie überhaupt vorhanden ist. Dadurch kann in der aktuellen im Job-System gewählten Sprache eine Fehlermeldung ausgegeben werden, unabhängig von der Sprache, mit der der Fremdrechner Meldungen ausgibt. Die Prüfung wird anhand der Dateiliste, die mit dem FTP-Befehl 'DIR' vom Fremdrechner geliefert wird, durchgeführt.

Unter bestimmten Umständen, kann es passieren, dass der Fremdrechner keine oder nur eine unvollständige Dateiliste liefert. Dann würde die Prüfroutine den Kopiervorgang mit einer Fehlermeldung abbrechen, auch wenn die zu kopierende Datei tatsächlich vorhanden wäre.


site
siehe auch DCB-Befehle

Mit diesem Befehl können Befehle und Parameter für den Fernrechner angegeben werden, die dort besondere Funktionen bereitstellen.

Syntax:
site fernrechnerbefehl
 hostname fernrechnerbefehl

Beispiele von Befehlen für einen FTP-Server auf einem IBM-Mainframe:

Befehl | Funktion
AUTOMount | Für Kassetten und Bänder wird das Einlegen in die Kassetten- oder Band-Station angefordert.
AUTORecall | Dateien, die vom DMS-System archiviert wurden, werden wieder zurückgeladen.
RDW | Bei Dateiformaten mit variablen Satzlängen wird das Satzlängenfeld mit übertragen.
TRAILingblanks | Bei Dateiformaten mit festen Satzlängen werden auch Leerstellen bis zur Satzlänge mit übertragen.
WRAPrecord | Ist ein gesendeter Satz länger als die definierte Satzlänge, so wird er zum nächsten Satz umgebrochen.
SBD=tabellendatei | tabellendatei ist eine Mainframedatei, die eine Übersetzungstabelle enthält, mit der landesspezifische Zeichen umgesetzt werden können.


submit
siehe auch TelNetLogin

Ausführen eines Jobs auf dem IBM-Mainframe.

Syntax 1:
submit [hostname: ]dateiname [ /Replace zeichen ersatzzeichen... ]

Syntax 2:
submit
 HostJCLZeilen
 endsubmit [ /MaxRC returncode ]

Bemerkungen:
 Wenn nach der FTP-Session weitere Befehle folgen (ohne den Befehl 'NOWAIT'), wartet der Job nach der FTP-Session auf die Vollendung des Host-Jobs.

FTP-Befehle, die innerhalb der gleichen FTP-Session nach dem submit-Befehl angegeben sind, werden sofort ausgeführt.

Sollen diese Befehle aber erst nach der Vollendung des Mainframe-Jobs ausgeführt werden, so müssen diese in einer neuen FTP-Session definiert werden.

Mit der Option '/Replace' können Textteile einer eingelesenen Datei durch andere ersetzt werden, um temporäre Modifikationen des Host-Jobs zu erreichen.

Mit der Option '/MaxRC' kann ein Return-Code angegeben werden, der von allen Job-Steps nicht überschritten werden darf. Wird bei der Ausführung des Host-Jobs ein höherer Return-Code erreicht, so bricht der Job nach der Beendigung des Host-Jobs mit einer Fehlermeldung ab. Ohne Angabe dieser Option wird ein maximaler Return-Code von 0 angenommen.

Hinweis:
 Um die Ausführung des Host-Job kontrollieren zu können, werden diesem drei zusätzliche Job-Steps angefügt. Diese Steps speichern den Zustand bei der Beendigung durch Erzeugung von entsprechenden Dateien ab, die vom Job-System überprüft werden. Zusätzlich wird nach dem Abschicken des Host-Jobs ein zweiter Host-Job mit dem gleichen Jobnamen und der gleichen Jobklasse abgeschickt. Dieser wird für den Fall benötigt wird, wenn der eigentliche Host-Job entweder manuell oder vom Host-System abgebrochen wird (z.B. bei Zeitüberschreitung), sodass die hinzugefügten Job-Steps nicht mehr ausgeführt werden können.

Bei der Prüfung auf Vollendung des Host-Jobs wird immer der letzte Job berücksichtigt, falls mehrere Jobs gestartet werden sollen.

Das Zeitintervall der Prüfung der Job-Vollendigung wird nach jeder Prüfung um ca. 9 Sekunden erhöht, bis zu einem Maximum von 30 Minuten. Dies geschieht, um die Zahl der FTP-Logins nicht unnötig auszudehnen.

Beispiele:
submit g:\daten\cpms\etiketten.jcl
submit c:\prog16\vb3\jobsys\wop\dvrp92cd.jcl /replace CLASS=T, CLASS=I,
submit IBM:INF.JOB.ALLG(DXQUERY)

submit
 //OYPKZIP JOB ('XNFL01 ',35),'%Host-UserID%',REGION=0M,
// CLASS=B,MSGCLASS=T
//* TSO aufrufen
//IKJEFT01 EXEC PGM=IKJEFT01
//SYSPRINT DD SYSOUT=*
//SYSTSPRT DD SYSOUT=*
//* Aufruf einer CLIST-Prozedur, die die angegebene Datei auf dem Host packt
//SYSTSIN DD *
Alloc f(sysproc) da('isr.crp.ispclib') shr
MVSZIP SSW.RII.RX59.SUMUN.M04 MICG9804.TC SSW.RII.RX59.SUNUM.M04.ZIP
Free f(sysproc)
/*
//
endsubmit

Beispiel:
submit
 //%Study%DBIII JOB ('%Study%P01',32),'NDF-GROUP',CLASS=F,MSGCLASS=T,
// NOTIFY=T49DPRH
//JOBLIB DD DISP=SHR,DSN=SYS2.PKZIP.LOADLIB
//*
//ZIP EXEC PGM=PKZIP,REGION=7M
//SYSPRINT DD SYSOUT=*
//SYSOUT DD SYSOUT=A
//SYSIN DD *
-ARCHIVE(%Study%.DB3NDF.%PerType%%MM%COMP)
-ARCHUNIT(FPREXT) -NOPATH
%Study%.NDFDB3.%PerType%%MM%
-PCP(%PerType%%MM%,%Study%NDF%MM%.TXT)
/*
endsubmit /MaxRC 4

Beispiel:
 FTPLogin IBM 162.44.3.9 t49imjm passwort
submit IBM:T49IMJM.IMD.JOB(TEST)
; Job erstellt die Datei T49IMJM.TESTFILE
FTPLogout

FTPLogin IBM 162.44.3.9 t49imjm passwort
copy IBM:T49IMJM.TESTFILE g:\daten\test.txt
FTPLogout

Beispiel für das Starten eines CA7-Jobs auf dem Mainframe:

submit
 //CA7SUB JOB ('XNFL01 ',35),'%Host-UserID%',REGION=0M,
// CLASS=B,MSGCLASS=T
//* TSO aufrufen
//IKJEFT01 EXEC PGM=IKJEFT01
//SYSPRINT DD SYSOUT=*
//SYSTSPRT DD SYSOUT=*
//SYSTSIN DD *
CALL 'SYS2.CA#07P.LINKLIB(U7SVC) ' 'DEMANDH,JOB=jobname,SCHID=schid'
/*
endsubmit


FTP wait until exists

wait until exists
siehe auch 'TelNet wait until ended' und 'WAIT UNTIL EXISTS'

Mit diesem Befehl kann ein Job angehalten werden, bis eine bestimmte Datei auf dem Fernrechner existiert.

Syntax:
wait until exists hostname:dateiname

Bemerkungen:
 FTP-Befehle, die innerhalb der gleichen FTP-Session nach dem wait-Befehl angegeben sind, werden sofort ausgeführt.

Sollen diese Befehle aber erst nach dem Vorhandensein der angegebenen Datei ausgeführt werden, so müssen diese in einer neuen FTP-Session definiert werden.

Wenn nach der FTP-Session weitere Befehle folgen, wartet der Job nach der FTP-Session auf das Vorhandensein der angegebenen Datei.

Die Prüfung der Datei erfolgt dabei alle 30 Minuten.

Beispiel:
 FTPLogin IBM 162.44.3.9 %Host-UserID% %Host-Passwort%
wait until exists IBM:SSW.RII.F0498.C33480N
FTPLogout
msg exists!


Telnet-Befehle

Normalerweise wird das 'Telnet-Protokoll' zum Anmelden per Dialog an einem Fernrechner benutzt, um online Textbefehle des jeweiligen Betriebssystems (z.B. Unix oder MVS) einzugeben.

Mit einer FTP-Session können nur bestimmte Dateioperationen auf Fernrechnern ausgeführt werden. Mit einer TelNet-Session ist es möglich, alle Betriebssystembefehle eines Fernrechners auszuführen.

So ist es möglich zum Beispiel Jobs bzw. Prozeduren auf dem Fernrechner zu starten oder Zugriffsrechte für Dateien zu vergeben.

Die aufgeführten Befehle sind spezielle Befehle, die außer den üblichen Betriebssystembefehlen besondere Möglichkeiten bieten.

Anmeldung
TelnetLogin
 TelnetLogout

Ausführung
wait until ended

Informationen
checklogfile


checklog
siehe auch 'PC CHECKLOG'

Überprüfen von Ausgaben in die Job-Protokolldatei und steuern des Ablaufes.

Syntax:
CheckLog /IfExists | /IfNotExists [(n) ] suchtext Error | Skip Next n Lines | Continue With labelname

Bemerkungen:
 Überprüft werden können Ausgaben, die durch Befehle des Fernrechners in das Job-Protokoll gestellt wurden. Dabei beginnt die Prüfung immer ab der Protokollzeile des letzten Befehls.

Mit den Angaben '/IfNotExists' und '/IfExists' können die Protokollzeilen nach einem suchtext überprüft werden. '/ErrorIfExists' kann mehrmals angegeben werden.

Bei '/IfNotExists' kann mit einem in Klammern eingeschlossenen Zahlenausdruck bestimmt werden, wie oft der nachfolgend angegebene suchtext mindestens vorkommen muss. Tritt suchtext pro Zeile mehrfach auf, dann wird er nur einmal gezählt.

Enthält der suchtext Leerzeichen, so muss er in Hochkomma eingeschlossen werden.

Mit dem Befehl 'Error' kann man den Job in den Fehlerzustand versetzen. Der weitere Ablauf ist dann abhängig von den benutzten Befehlen zur Fehlerbehandlung.

Mit dem Befehl 'Skip Next n Lines' kann man die angegebene Anzahl Befehlszeilen des Jobs überspringen. Damit lassen sich bedingte Befehlszeilen einrichten um z.B. Aktionen für fehlerhafte Ausführungen zu starten.

Mit dem Befehl 'Continue With labelname' kann der Name eines Labels angegeben werden, bei dem der Job im Ablauf fortfahren soll.

Beispiel:
 Per Telnet wird ein Shellskript mit jeweils anzuwählenden Menüpunkten ausgeführt. Nach der Ausführung der Prozedur soll geprüft werden, ob der Ablauf erfolgreich gelaufen ist. Wenn er nur teilweise erfolgreich war, soll durch Aufruf eines weiteren Menüpunktes eine Korrekturroutine aufgerufen werden.

TelnetLogin Unix r49p311 %Host-UserID% %Host-Password%
3
1
B_%DDLName%_%Batchnr%
checklog /IfNotExists 'Successfully created' Error /IfExists 'Program Completed' Skip Next 3 Lines
2
B_%DDLName%_%Batchnr%
CheckLog /IfExists 'error' Error
11
TelnetLogout


TelnetLogin

Einloggen in einen Fernrechner per Telnet und Beginn einer Telnet-Session zum Ausführen von Betriebssystembefehlen.

Syntax:
TelnetLogin hostname hostadresse userid passwort [accountcode ] [procedure ] [/wait ]

Bemerkungen:
 Eine Telnet-Session gilt bis zu dem Befehl 'TelnetLogout' als ein geschlossener Programmaufruf. Das heißt, dass alle Befehle innerhalb dieser Session nacheinander ausgeführt werden und nicht mit PC -Befehlen wie 'NOWAIT' oder 'WAIT' beeinflusst werden können. Außer Betriebssystembefehlen des Fernrechners sind nur Kommentarzeilen erlaubt.

Mit dem Zusatz '/wait ' kann erreicht werden, dass das Einloggen solange durchgeführt wird, bis es erfolgreich ist. Das ist dann notwendig, wenn der Benutzer gleichzeitig auch an dem Fernrechner in dem Betriebssystem angemeldet ist oder wenn mehrere Jobs mit dem TelnetLogin und der gleichen UserID gestartet werden sollen.

Das passwort wird während des Joblaufs und im Job-Protokoll verschlüsselt sichtbar gemacht.

Hinweis:
 Um dem Programm eindeutig mit zuteilen, um welches Betriebssystem es sich handelt, sollte eine entsprechende Bezeichnung im hostnamen eingesetzt sein. Als Bezeichner für Betriebssysteme werden erkannt: MVS, Unix, DOS und Windows.

Beispiel:
 Bei der Datenübertragung per FTP auf einen Unix-Rechner kann es zu Problemen mit den voreingestellten Zugriffsrechten kommen. Dies führt dazu, dass andere diese Dateien nicht lesen oder löschen können.

Mit dem Unix-Befehl 'CHMOD' können Zugriffsrechte für Dateien vergeben werden.

TelnetLogin Unix-SP2 162.44.22.91 %Host-UserID% %Host-Password%
cd /xtre_ger/server/data/input/steiger
chmod a=rwx *
TelnetLogout


TelnetLogout

Abbrechen der Verbindung zum Fernrechner und Verlassen der Telnet-Session.

Syntax:
TelnetLogout

Dieser Befehl muss angegeben werden, um das Ende einer Telnet-Session zu kennzeichnen.

siehe auch
TelnetLogin


Telnet wait until ended

wait until ended
siehe auch 'FTP wait until exists'

Mit diesem Befehl kann ein Job des Job-Systems angehalten werden, bis ein bestimmter Job auf dem Fernrechner beendet ist.

Syntax:
wait until ended jobname [( jobnummer ) ] [/nowarning ]

Bemerkungen:
 Betriebssystem-Befehle, die innerhalb der gleichen Telnet-Session nach dem wait-Befehl angegeben sind, werden sofort ausgeführt.

Sollen diese Befehle aber erst nach der Beendigung des angegebenen Host-Jobs ausgeführt werden, so müssen diese in einer neuen Telnet-Session definiert werden.

Wenn nach der Telnet-Session weitere Befehle folgen, wartet der Job des Job-Systems nach der Telnet-Session auf die Beendigung des angegebenen Host-Jobs. Die Prüfung des Host-Jobs erfolgt sofort und danach alle 15 Minuten.

Die Benutzung dieses Befehls macht nur Sinn, wenn der Host-Job bereits auf dem Fernrechner gestartet wurde. Daher sollte immer auch die jobnummer mit angegeben werden. Der Host-Job wird als beendet betrachtet, wenn er entweder in der JES-Output-Queue steht, oder nicht mehr gefunden wird.

Wird zum Zeitpunkt der ersten Prüfung der Host-Job nicht gefunden oder ist er schon beendet, so wird eine Warnung an den Benutzer ausgegeben, die vor dem Fortfahren des Job des Job-Systems bestätigt werden muss. Soll diese Warnung unterdrückt werden, so muss der Zusatz '/nowarning ' benutzt werden. Dies ist dann erforderlich, wenn in dem Job des Job-Systems vor der Telnet-Session weitere Befehle abgearbeitet werden müssen und zum Zeitpunkt der Telnet-Session der Host-Job bereits beendet sein kann.

Beispiel:
 TelnetLogin IBM 162.44.3.9 %Host-UserID% %Host-Passwort% %Host-Account%
wait until ended OYPIMS2AB(4051)
TelnetLogout
msg Host-Job OYPIMS2AB(4051) beendet.


Parameter

Alle folgenden Punkte beziehen sich auf die Parametrisierung von Jobs.

Parameter
%Parameter%
 %Tabellen-Parameter%

Definitionsbefehle
/-
 /Include
 /Parameter
 /Set


%Parameter%

Parameter sind Platzhalter, die variabel sind und für die erst vor dem Job-Start die aktuellen Werte eingesetzt werden.

Syntax:
%Parametername%

Alle Parameternamen müssen in 2 Begrenzerzeichen eingeschlossen sein. Das Begrenzerzeichen ist standardmäßig ein Prozentzeichen % . Es kann mit dem Befehl für Parameterbegrenzerzeichen geändert werden.

Beispiel:
 del C:\Daten\%Firm%%Typ%%Bk%%JJ%%MM%.%Typ%M
/Set ParamDelimChar=°
 copy C:\Daten\°Firm°\°Typ°°Bk°°JJ°°MM°.EXE J:\RPM\Kunde\°Firm°\°Typ°°Bk°°JJ°°MM°.EXE

Die eingesetzten Werte ergeben sich entweder aus den Parametereingaben des Benutzers im Job-System oder durch spezielle Parameterbefehle bzw. Parameterfunktionen im Job selbst.

Sobald der Benutzer im Text des Jobs einen neuen Parameter einträgt, wird dieser vom Job-System nach dem Verlassen des Job-Editors automatisch in dem Bereich 'Job-Parameter' der Jobeigenschaften eingefügt.

Ist nur der Parameter angegeben worden, wird vom System ein Parameterbezeichnerfeld mit dem Parameternamen und ein Parametereingabefeld angelegt.

Hinweis:
 Enthält ein Parametername den Text 'passw' (unbabhängig ob groß oder klein), so nimmt das System an, dass es sich um einen Passwort-Parameter handelt. Dadurch werden in dem Parametereingabefeld alle eingegeben Zeichen mit Sterchen '*' ersetzt. Außerdem werden Passwort-Parameter chiffriert weitergegeben.

Dateinamen können per Ziehen und Fallenlassen aus dem Windows-Explorer oder anderen Anwendungen in das Eingabefeld übernommen werden.

Folgende Parameter sind vom System vordefiniert:

Parameter | Bedeutung
%SYSCOMPNAME% | der Name des Computers, auf dem das Batchlauf Modul läuft
%SYSPATH% | das Windowssystemverzeichnis
%SYSPROGPATH% | der Name des Standardverzeichnisses, in dem Programme installiert werden. Z.B.'C:\Programme'
%SYSAPPLPATH-progname% | das vollständige Installationsverzeichnis des Programms
%SYSAPPLPROGPATH-progname% | das Verzeichnis, in dem das Programm installiert wurde. Wenn es sich um das Standardverzeichnis handelt, ist es gleich dem %SYSPROGPATH%.
%SYSSJOBID% | die Job Nummer eines gestarteten Jobs (siehe Protokoll)
%SYSNETUSERID% | der Netzwerk Benutzername
%SYSUSERID% | der Job-System Benutzername (mit dem sich ein Benutzer angemeldet hat)
%SYSUSER% | der Vorname und Nachname des Job-System Benutzers
%SYSYY% | das aktuelle Jahr 2-stellig
%SYSYYYY% bzw. %SYSYEAR% | das aktuelle Jahr 4-stellig
%SYSMM% | der aktuelle Monat 2-stellig
%SYSMONTH% | der aktuelle Monat 1-2-stellig
%SYSWEEK% | die aktuelle Kalenderwoche 1-2-stellig (beginnt mit der ersten Woche im Jahr, die mindestens 4 Tage hat)
%SYSWEEKFULL% | die aktuelle Kalenderwoche 1-2-stellig (beginnt mit der ersten vollständigen Woche im Jahr)
%SYSWEEKSYS% | die aktuelle Kalenderwoche 1-2-stellig (nach Systemeinstellung)
%SYSWEEKUS% | die aktuelle Kalenderwoche 1-2-stellig (beginnt mit der Woche, in die der 1. Januar fällt)
%SYSDD% | der aktuelle Tag 2-stellig
%SYSDAY% | der aktuelle Tag 1-2-stellig
%SYSWEEKDAY% | der aktuelle Wochentag als Zahl 1-stellig (1 für Montag bis 7 für Sonntag)
%SYSWEEKDAYSYS% | der aktuelle Wochentag als Zahl 1-stellig (nach Systemeinstellung)
%SYSWEEKDAYUS% | der aktuelle Wochentag als Zahl 1-stellig (1 für Sonntag bis 7 für Samstag)
%SYSHH% | die aktuelle Stunde 2-stellig
%SYSHOUR% | die aktuelle Stunde 1-2-stellig
%SYSNN% | die aktuelle Minute 2-stellig
%SYSMINUTE% | die aktuelle Minute 1-2-stellig
%SYSSS% | die aktuelle Sekunde 2-stellig
%SYSSECOND% | die aktuelle Sekunde 1-2-stellig
%SYSTIME% | die aktuelle Zeit mit dem Zeittrennzeichen, das in der Systemeinstellung festgelegt ist

Der jeweils aktuelle Wert wird zum Zeitpunkt des Startens eines Jobs ermittelt.

Die beschriebenen Inhalte der Systemparameter werden vom System vorbelegt und erscheinen nicht in dem Job-Parameter-Bereich des Job-Systems.

Mit den Systemparametern, die sich auf das aktuelle Datum beziehen, ist es auch möglich, Datumsangaben relativ zum aktuellen Datum zu definieren. Dazu muss vor dem abschließenden Parameternamenbegrenzer ein negativer oder positiver Wert eingetragen werden.

Beispiel:

%SYSMM-1%
Es wird vom System der letzte Monat vorgegeben (aktueller Monat minus 1).

%SYSMM+1%
Es wird vom System der nächste Monat vorgegeben (aktueller Monat plus 1).

%SYSDD-2%
Es wird vom System der vorletzte Tag vorgegeben (aktueller Tag minus 2).

Um allerdings vollständige Datumsangaben von vergangenen oder zukünftigen Zeiten zu erhalten, muss die Parameterfunktion 'DATE' verwendet werden.


%Tabellen-Parameter%

Mit Tabellen-Parametern ist es möglich, bestehende Befehlszeilen in einem Job für den Benutzer auswählbar zu halten.

Syntax:
% Tabellenparametername
befehlszeile
befehlszeile
%

Der Tabellenparameter muss mit einem Parameterbegrenzerzeichen beginnen und darf nicht mit einem Begrenzerzeichen enden. Das Begrenzerzeichen muss in der ersten Spalte beginnen und nach dem Parameternamen darf kein weiterer Text in dieser Zeile folgen.

In den folgenden Zeilen, müssen die Batch-Befehle bzw. Programmaufrufe stehen, die der Benutzer auswählen soll.

Den Abschluss der Tabelle bildet eine Zeile, die nur aus einem Parameterbegrenzerzeichen besteht.

Werden mehrere Befehlzeilenblöcke mit dem gleichen Tabellenparameternamen eingeschlossen, so muss die Anzahl und die Reihenfolge der Befehlszeilen mit der des ersten Blockes übereinstimmen.

Es können bis zu 4 verschiedene Tabellen (mit unterschiedlichen Tabellenparameternamen) aufgebaut werden.

Die als Job-Parameter angezeigten Tabellenzeilen müssen nicht unbedingt vom Benutzer ausgewählt werden, um einen Job zu starten.

Bemerkungen:
Jobs können benutzt werden, um soviel wie möglich gleichartige Verarbeitungen in einem Durchlauf zu erledigen. Dabei werden alle gleichartigen Verarbeitungen bzw. Befehlszeilen untereinander in den Job geschrieben.

Da es aber in der Praxis oft nicht möglich ist, alle vorgesehenen Verarbeitungen zum gleichen Zeitpunkt durchzuführen, ist es vorteilhaft, wenn man nur bestimmte Verarbeitungen bzw. Befehlszeilen ausführbar machen kann.

Dies wird erreicht, wenn man Zeilen mit gleichen Batch-Befehlen, die sich meist nur durch die Dateinamen unterscheiden, mit Tabellen-Parametern beschreibt.

Alle von dem Tabellen-Parameter eingeschlossenen Befehlzeilen, werden vom Job-System auf unterschiedliche Wörter hin untersucht (mit Leerzeichen, Punkt, Doppelpunkt oder Backslash begrenzte Zeichenfolgen; keine Groß/Kleinschrift- Unterscheidung). Alle unterschiedlichen Wörter pro Befehlszeile werden dann in einer Liste dem Benutzer in dem Bereich 'Job-Parameter' der Jobeigenschaften angezeigt.

Der Benutzer sieht also in der erstellten Liste nur noch die, für die unterschiedlichen Verarbeitungen relevanten Begriffe.

Da in einem Job mehrere solcher 'Befehlstabellen' stehen können, die sich mit weitergehenden Verarbeitungsschritten der ersten Befehlstabelle befassen, können auch diese mit dem gleichen Tabellenparameternamen eingeschlossen werden. Dem Benutzer werden aber nur die Befehlszeilen, der ersten Tabelle aufgelistet.

Vor dem Job-Start wertet das Job-System, die vom Benutzer markierten Zeilen aus. Dabei geht das Job-System nach der Zeilennummer der ausgewählten Zeilen. In allen definierten Tabellen mit dem gleichen Tabellenparameter werden dann nur die Zeilen mit gleicher Nummer an den Job übergeben.

Das bedeutet, dass unbedingt alle Befehlszeilen mit gleichem Verarbeitungsbezug in allen Tabellen in der gleichen Reihenfolge angegeben sein müssen.

Beispiel:
 Für mehrere Kunden sollen Dateien vom Fernrechner auf den PC kopiert werden. Danach werden die kopierten Dateien gepackt. Der Benutzer soll bestimmen können, welcher Kunde mit welcher Berichtsart aus den vorgegebenen Möglichkeiten verarbeitet werden soll.

FTPLogin IBM 162.44.3.9 T49IMJM /passwort
%Berichte/Kunden
 copy IBM:SSW.RII.F%MM%%JJ%.C11500N c:\daten\Apharm\FMG%JJ%%MM%.FM
copy IBM:SSW.RII.F%MM%%JJ%.C12001N c:\daten\apogepha\FMG%JJ%%MM%.FM
copy IBM:SSW.ROI.F%MM%%JJ%.C12001N c:\daten\apogepha\FMG%JJ%%MM%.FM
copy IBM:SSW.ROi.S%MM%%JJ%.C18000N c:\daten\bykgul01\SMO%JJ%%MM%.FM
copy IBM:SSW.ROI.F%MM%%JJ%.C17510N c:\daten\bykgul01\FMO%JJ%%MM%.FM
%
 FTPLogout

; PKZip-Exe erstellen
%Berichte/Kunden
 pack zipexe c:\daten\Apharm\FMG%JJ%%MM%.FM
pack zipexe c:\daten\apogepha\FMG%JJ%%MM%.FM
pack zipexe c:\daten\apogepha\FMG%JJ%%MM%.FM
pack zipexe c:\daten\bykgul01\SMO%JJ%%MM%.FM
pack zipexe c:\daten\bykgul01\FMO%JJ%%MM%.FM
%

In dem Bereich 'Job-Parameter' wird nun erscheinen

Die Tabelle bekommt eine Überschrift, die sich aus dem Tabellenparameternamen zusammensetzt.
Nur die sich unterscheidenden Wörter der Befehlszeilen der ersten Tabelle wurden ausgegeben.


/-

Mit diesem Kennzeichen können Parameterdefinitionszeilen auf der nächsten Zeile fortgesetzt werden.

Syntax1:
/- parameterdefinitionsbefehle

Syntax2:
 parameterdefinitionsbefehle /-


/Include

Mit diesem Befehl können Jobbefehle aus einer anderen Datei eingelesen werden.

Syntax:
/Include dateiname [/RUNTIME]

Bemerkungen:
 Die Jobbefehle werden an der Stelle eingelesen, an der der '/Include'-Befehl angegeben wurde und je nach dem behandelt, ob der Zusatz '/RUNTIME' benutzt wurde oder nicht.

Ohne den Zusatz '/RUNTIME', erfolgt das Einlesen vor dem Start des Jobs. Das heißt, dass auch Parameter in der eingelesenen Datei durch die vom Benutzer angegebenen Inhalte ersetzt werden.

Wird der Zusatz '/RUNTIME' verwendet, so wird die angegebene Datei erst in dem Moment eingelesen, in dem das Batchlauf-Modul diese Befehlszeile verarbeitet. Dabei werden keine eventuell enthaltenen Parameter berücksichtigt. Dieser Modus ist dann notwendig, wenn die einzulesende Datei während des Joblaufs (also vor dem Aufruf) noch bearbeitet werden soll.

Hinweis :
In einer Zeile darf vor dieser Anweisung kein %Parameter% definiert sein. Wird dateiname als %Parameter% definiert, so kann der Job nur über den Job-System Batchstarter (siehe JSStart ) gestartet werden.

siehe auch:
JSBATCH


/Parameter

siehe auch Parameterfunktionen

Kennzeichnet eine Parameterdefinitionszeile im Job. Hier können die Parameter, die vom Benutzer eingegeben werden sollen, genauer beschrieben werden, sowie Hinweis- bzw. Beschreibungstexte definiert werden.

Syntax Parameter:
/Parameter [Bezeichner= ]%Parameter%[= Inhalt]

Syntax Texte:
/Parameter Beschreibungstext=%%

Mehrere Definitionen werden mit Komma abgetrennt.

Oft ist es störend, einen Parameternamen zu wählen, der dem Benutzer die vollständige Bedeutung des Parameters erklärt. Dadurch würde der Job durch überlange Parameternamen unübersichtlich werden und die Pflege des Jobs erschwert werden.

Um nun kurze Parameternamen zu nennen und trotzdem dem Benutzer sprechende Bezeichner zu bieten, können Parameterdefinitionszeilen benutzt werden.

Beispiel:
/Parameter Produktionsjahr=%JJ%, Produktionsmonat=%MM%

In dem Bereich 'Job-Parameter' wird nun erscheinen

Normalerweise wird vom Job-System immer der zuletzt vom Benutzer eingegebene Wert vorgegeben.
Soll der Inhalt des Parameterfeldes aber immer mit einem bestimmten Wert vorgegeben werden, so muss dieser folgendermaßen angegeben werden:

Bezeichner=%Parameter%=Inhalt oder
%Parameter%=Inhalt

Beispiel:
 In dem Parametereingabefeld für den Parameter %JJ% soll immer 97 und in dem von %MM% immer 12 erscheinen.

/Parameter Produktionsjahr=%JJ%=97, Produktionsmonat=%MM%=12

In dem Bereich 'Job-Parameter' wird nun erscheinen

Soll der Parameterinhalt bei jedem Aufruf der Job-Definitionen leer sein, so muss nur das Gleichheitszeichen angegeben werden.

/Parameter Produktionsjahr=%JJ%=, Produktionsmonat=%MM%=

Soll ein Parameter in dem Bereich 'Job-Parameter' in einer neuen Zeile plaziert werden, so muss der Parameter in einer neuen Parameterdefinitionszeile angegeben werden.

/Parameter Produktionsjahr=%JJ%
/Parameter Produktionsmonat=%MM%

In dem Bereich 'Job-Parameter' wird nun erscheinen

Der Paramterinhalt kann auch durch Parameterfunktionen ermittelt werden:
/Parameter Jahr=%JJ%=DATE(YY,%SYSYY%,%SYSMM%-1,1), Monat=%MM%=DATE(MM,%SYSYY%,%SYSMM%-1,1),


/Set

Kennzeichnet eine Parameterdefinitionszeile im Job mit der Parameter gesetzt werden können.

Syntax:
/Set %Parameter%=Inhalt

Mehrere Definitionen werden mit Komma abgetrennt.

Inhalt kann entweder eine direkte Zuweisung sein oder eine Funktion, die den Inhalt erzeugt.

Bei Direktzuweisung kann auch eine Operation angegeben werden. Dann muss der Operator ohne Leerstelle der Zahl folgen. Dabei lässt sich auch das Format von Zahlen bestimmen, indem führende Nullen vorangestellt werden.

Hinweis:
 Bei Direktzuweisung ohne Parameterfunktion, darf nur eine Anweisung pro Zeile angegeben werden!

Soll Inhalt Leerzeichen enthalten, muss das Ersatzzeichen für Leerzeichen angegeben werden, da sonst die Erkennung nicht korrekt erfolgen kann.

Das Format von Zahlen kann bestimmt werden. Durch die Angabe von Nullen vor einem numerischen Inhalt wird die Ausgabe von gleichlangen Zahlen (durch führenden Nullen) erreicht.

Beispiel:
 Vor dem Job-Start wurden vom Benutzer die Parameter %JJ% und %MM% eingegeben.

In dem Parameter %MM-1% soll immer der Monat eingesetzt werden, der vor dem, vom Benutzer eingegebenen Monat liegt.

In dem Parameter %JJM-1% soll immer das dazugehörige Jahr gesetzt werden.

/Set %JJM-1%=DATE(YY,%JJ%,%MM%-1,1), %MM-1%=DATE(MM,%JJ%,%MM%-1,1)

siehe auch Parameterfunktion DATE

Beispiel:
 Es soll ein laufender Zähler erzeugt werden, der Bestandteil eines Dateinamen ist. Deswegen muss der Zähler immer dreistellig mit führender Null sein.

/Set %LfndNr%=001

/For %DB%=(%DBs%)
/Set %NR%=%LfndNr%+1
copy c:\Daten\%DB%.dat k:\Daten\DBDATA.%NR%
/Next %DB%

Das Ergebnis dieses Beispiels hätte man auch mit der Option 'COUNT' des Befehls /For erreichen können. Es gibt aber Situationen bei geschachtelten Schleifen, bei denen damit kein laufender Zähler erzeugt werden kann.


Parameterfunktionen

Parameterfunktionen stellen Inhalte zur Verfügung, die in Parametern eingesetzt werden können.

Alle Zeilen im Job, in denen Funktionen definiert werden, müssen mit '/Parameter', '/-' oder '/Set' beginnen.

Folgende Funktionstypen stehen zur Verfügung:

Auflistungen
LIST
 TABLE
 TABLESELECT

Eingabevorbelegung
DATE
 DRIVE
 FILE
 FORMAT
PATH

Inhaltsumsetzung
CONV
 FILTER
 OFF
 ON
 REPLACE

Sonderfunktionen
CALL


CALL Funktion

Erzeugung eines Schalters, mit dem der Benutzer ein Programm oder eine Datei aufrufen kann.

Syntax:
 Beschreibung=%Parameter%=CALL(dateiname[,parameter])

Die einzelnen Funktionsparameter müssen mit Komma und ohne Leerzeichen getrennt eingetragen werden.

Bemerkungen:
 Mit dieser Funktion ist es möglich, dem Benutzer zusätzliche Informationen oder Programme zur Verfügung zustellen.

Dokumente oder Dateien , die im Betriebssystem mit Programmen verknüpft sind, können ohne Programmnamen angegeben werden. Zu Beachten ist, dass der Dateiname und zusätzliche Parameter keine Leerzeichen enthalten dürfen. Leerzeichen müssen mit dem Ersatzzeichen für Leerstellen ersetzt werden.

In %Parameter% wird der dateiname zur Verfügung gestellt.

Im Fenster der Jobeigenschaften wird für das angegebene oder mit der Datei verknüpfte Programm ein Schalter mit dem Symbol des Programms angezeigt.

Hinweis:
 Sollen dem Benutzer Hilfedateien angeboten werden, so kann als parameter der Indexname einer bestimmten Hilfeseite angegeben werden. Den Indexnamen einer Hilfeseite bekommt man, wenn man in der Hilfe den Schalter 'Suchen' anwählt. Dann erscheint ein Fenster mit einer Liste aller in der Hilfe abgelegten Indexnamen, die auf die dazugehörigen Hilfeseiten verweisen.

Beispiel:
 Während eines Jobs wird ein Programm aufgerufen, mit dem der Benutzer die vom Job erstellten Daten überprüfen muss. Zur Überprüfung müssen mehrere vorgegebene Schritte vom Benutzer befolgt werden. Da diese Schritte in einer Hilfedatei dokumentiert sind, soll diese dem Benutzer zur Verfügung gestellt werden. Die hierfür gültige Hilfeseite hat den Indexnamen 'Italien ASCII'.

/Set BlankChar=~°
/Parameter: Datenbank-Checks=%Hilfe%=CALL(h:\Pool~crp\JobSys\wopcheck.hlp,Italien°ASCII)
 /Set BlankChar=~
/Parameter: Jahr=%JJ%=98, Monat=%MM%=12, Laufwerk=c:

In dem Bereich 'Job-Parameter' wird nun erscheinen

Zu Beachten ist in diesem Beispiel, dass das Ersatzzeichen für Leerstellen von ~ auf ° umgesetzt werden muss, weil das Zeichen ~ tatsächlich in dem Pfadnamen vorkommt.


CONV Funktion

Umsetzen von Parameterinhalten in andere Parameterinhalte.

Syntax 1:
 %Parameter%=CONV( %eingabeparameter%, inhalt1: ersatz1, inhalt2: ersatz2... )

Links steht der Parameter, der mit dem konvertierten Ersatzinhalt gefüllt werden soll. Innerhalb des Befehls 'CONV' steht der Eingabeparameter, dessen Inhalt umgesetzt werden soll. Danach müssen alle Wertepaare mit Komma getrennt folgen. Ein Wertepaar besteht aus einem Inhalt und einem mit einem Trennzeichen (': ' oder '| ') getrennten Ersatzinhalt .

Syntax 2:
CONV( %eingabeparameter%: %Parameter1%: %Parameter2%..., inhalt1: ersatz11: ersatz12, inhalt2: ersatz21: ersatz22... )

Innerhalb des Befehls 'CONV' steht der Eingabeparameter, dessen Inhalt umgesetzt werden soll, gefolgt von dem oder den Parametern, die mit konvertierten Ersatzinhalten versorgt werden sollen. Danach müssen alle Wertepaare mit Komma getrennt folgen. Ein Wertepaar besteht aus einem Inhalt und einem oder mehreren, mit einem Trennzeichen (': ' oder '| ') getrennten Ersatzinhalten .

Dabei muss die Reihenfolge der Ersatzinhalte mit der Reihenfolge der Parameter übereinstimmen.

Bemerkungen:
 Bei der Ausführung der Funktion wird der Inhalt des Eingabeparameters mit den angegebenen Inhalten verglichen. Findet die Funktion einen übereinstimmenden Inhalt (Groß/Klein-Schreibung wird nicht berücksichtigt), so wird der hinter dem Doppelpunkt eingetragene Ersatzinhalt dem angegebenen Parameter zugewiesen.

Ist als letztes Wertepaar *: Ersatzinhalt angegeben worden, wird für alle Inhalte, die nicht in der Funktion definiert sind, dieser Ersatzinhalt zugewiesen.

Ist als letztes Wertepaar *:* angegeben worden und ist der gesuchte Inhalt nicht in der Funktion definiert, wird dem angegebenen Parameter der gesuchte Inhalt selbst zugewiesen.

Soll der Ersatzinhalt ein Leerzeichen enthalten, muss anstelle dessen das Ersatzzeichen für Leerzeichen angegeben werden, da sonst die Erkennung der Ersatzinhalte nicht korrekt erfolgen kann.

Hinweis:
 In einem Konvertierungsbefehl darf immer nur eins der beiden möglichen Trennzeichen benutzt werden. Vom Programm wird das jeweils erste gefundene Trennzeichen (entweder ': ' oder '| ') als Trennzeichen für den kompletten Befehl angenommen. Ein Komma Zeichen in Inhalt und Ersatz muss mit "," angegeben werden.

Die Prüfung von inhalt berücksichtigt keine Groß/Klein-Schreibung. Inhalt kann auch Jokerzeichen wie * und ? enthalten.

Beispiel:
 Dem Benutzer werden für den Parameter %Firm% verschiedene Firmennamen in einer Auswahlliste zur Verfügung gestellt.

In dem auszuführenden Job sollen Dateien für diese Firmen verarbeitet werden. Die Dateinamen sollen den Firmennamen beinhalten. Da die Firmennamen aber zu lang sind, um noch weitere Informationen (z.B. Monat und Jahr) in den Dateinamen stellen zu können, müssen diese in Kurzformen umgesetzt werden.

/Parameter Kunde=%Firm%=LIST(Zeneca,Wyeth,Thomae,Robugen,Opfermann)

;
/Set %FirmDKZ%=CONV(%Firm%,Zeneca:ZEN,Wyeth:WYE,Thomae:THO,Robugen:ROB,Opfermann:OPF)
 ; oder CONV(%Firm%:%FirmDKZ%,Zeneca:ZEN,Wyeth:WYE,Thomae:THO,Robugen:ROB,Opfermann:OPF)
copy c:\daten\xtrend\%FirmDKZ%\%MM%%JJ%.dat SP2:%FirmDKZ%%MM%%JJ%.dat

Beispiel:
 Dem Benutzer werden für den Parameter %RXX% in einer Auswahlliste verschiedene Berichtsformen in Form eines Kürzels angeboten, das firmenintern für diese Berichte vergeben worden ist.
Mit dem auszuführenden Job sollen Dateien für externe Kunden erstellt werden. Da die externen Kunden nicht die firmenintern vergebenen Kürzel kennen, müssen diese in eine Form umgesetzt werden, die kurz genug für Dateinamen und außerdem Kunden geläufiger sind (z.B. TW anstatt RAO).

/Parameter Bericht=%RXX%=LIST[RII,RIO,ROI,RAO,RAI]
;
/Set %Bk%=CONV(%RXX%,RII:MG,RIO:MW,ROI:MO,RAO:TW,RAI:TG)
 ; oder CONV(%RXX%:%Bk%,RII:MG,RIO:MW,ROI:MO,RAO:TW,RAI:TG)
 ;
copy C:\DATEN\%Firm%\%Bk%%JJ%%MM%.EXE J:\RPM\Kunde\%Firm%\%Bk%%JJ%%MM%.EXE


DATE Funktion

Zuweisen eines berechnetes Datum in verschiedenen Formaten an einen Parameter.

Syntax:
 %Parameter%=DATE( format, vorgabejahr, vorgabemonat, vorgabetag )

Die einzelnen Funktionsparameter müssen mit Komma getrennt eingetragen werden.

Folgende Formate sind möglich:

Format- | Bedeutung
d | Tag als Zahl ohne führende Null (1-31)
dd | Tag als Zahl mit führender Null (01-31)
ddd | Tag als Abkürzung (Sun-Sat)
dddd | voller Tagesname (Sunday-Saturday)
ddddd | Datum in Abhängigkeit von den Systemeinstellungen in Kurzform (z.B. dd.mm.yy)
dddddd | Datum in Abhängigkeit von den Systemeinstellungen in Langform (z.B. mmmm dd, yyyy)
w | Wochentag als Zahl (1 für Sontag bis 7 für Samstag.)
ww | Woche des Jahres als zweistellige Zahl (01-53)
m | Monat als Zahl ohne führende Null (1-12)
mm | Monat als Zahl mit führender Null (01-12)
mmm | Monat als Abkürzung (Jan-Dez)
mmmm | voller Monatsname (Januar-Dezember)
q | Quartal des Jahres als Zahl (1-4)
y | Jahrestag als Zahl (1-366)
yy | Jahr als zweistellige Zahl (00-99)
yyy | Jahrestag als Zahl mit führenden Nullen (001-366)
yyyy | Jahr als vierstellige Zahl (0100-9999)

Bemerkungen:
 Vorgabe-jahr , -monat und -tag können Parameter oder Literale sein. Zu Parametern können Werte addiert oder subtrahiert werden.

Bei allen Formatzeichen für format , die eine fest definierbare maximale Anzahl Zeichen erzeugen, wie z.B. 'm' (erzeugt die Zahlen 1-12, also max. 2 Zeichen), wird die mögliche Eingabelänge des erzeugten Eingabefeldes auf diese Anzahl Zeichen begrenzt.

Auch Definitionen mit kombinierten Formaten wie z.B. 'D.M.YY' sind möglich.

Hinweis:
 Wird als vorgabejahr ein 2-stelliger Wert angegeben, so wird dieser intern in eine 4-stellige Jahreszahl umgewandelt. Dabei wird bei Werten, die kleiner 30 sind, 2000 addiert. Das heißt, dass damit das Zeitfenster 1930 - 2029 festgelegt wird.

Beispiel:
 Oft ist es notwendig, in einer Verarbeitung die Datumsangaben von zurückliegenden Zeiten zu benutzen, um diese in Produktionsdateinamen einzusetzen. Dem Benutzer soll immer das normale Produktionsdatum zur Verfügung gestellt werden, um ihm die Parametereingabe zu erleichtern.

In diesem Fall sollen Dateien bearbeitet werden, die immer das Datum des Vormonats im Namen enthalten. Dabei geht man vom aktuellen Datum aus, welches durch die Systemparameter %SYSYY%, %SYSMM% und %SYSDD% zu bekommen ist. Dann muss vom Monatswert 1 abgezogen werden.

Damit das Ergebnis an jedem Tag des aktuellen Monats gleich ist, wird hier immer der Tag 1 eingesetzt (denn würde der Job am 31. des Monats gestartet werden und der Vormonat hat nur 30 Tage, dann würde der aktuelle Monat mit dem 1. Tag ausgegeben werden, da das Endergebnis immer ein vollständiges, korrektes Datum ergeben muss).

/Parameter Jahr=%JJ%=DATE( YY, %SYSYY%, %SYSMM%-1, 1) , Monat=%MM%=DATE( MM, %SYSYY%, %SYSMM%-1, 1)

Beispiel:
 Vor dem Job-Start wurden vom Benutzer die Parameter %Jahr% und %Monat% eingegeben.

In dem Parameter %Vormonat% soll immer der Monat eingesetzt werden, der vor dem, vom Benutzer eingegebenen Monat liegt.

In dem Parameter %Vormonatjahr% soll immer das dazugehörige Jahr gesetzt werden.

/Set %Vormonatjahr%=DATE( YY, %Jahr%, %Monat%-1, 1) , %Vormonat%=DATE( MM, %Jahr%, %Monat%-1, 1)

Hat der Benutzer z.B. in %Jahr% 98 und in %Monat% 01 eingegeben, so wird der Parameter %Vormonatjahr% auf 97 und der Parameter %Vormonat% auf 12 gesetzt.


DRIVE Funktion

Zuweisen eines Laufwerkbuchstabens eines Laufwerkes mit einer Mindestgröße an freiem Speicherplatz.

Syntax:
 %Parameter%=DRIVE( mindestgröße [,SMALL | LARGE ][, laufwerksbuchstabe1, laufwerksbuchstabe2... ])

Alle Funktionsparameter müssen mit Komma getrennt ohne Leerzeichen eingetragen werden.

Bemerkungen:
 Die Angabe der Mindestgröße an freiem Speicherplatz kann in Kilobyte 'KB ', Megabyte 'MB ' (Standard) oder Gigabyte 'GB ' erfolgen.

Sind keine gewünschten Laufwerksbuchstaben angegeben worden, so werden bei der Suche nach einem geeigneten Laufwerk zuerst die Netzwerklaufwerke und dann die Festplattenlaufwerke überprüft (und zwar in absteigender Buchstabenfolge).

Wird kein Laufwerk gefunden, das mindestens die angegebene Größe an freiem Speicherplatz enthält, so wird der Joblauf mit einem Fehler abgebrochen.

Ist die Option 'SMALL ' angegeben worden, so wird von mehreren Laufwerken mit der erforderlichen Speicherplatzgröße, das Laufwerk mit dem wenigsten Speicherplatz zugewiesen.

Ist die Option 'LARGE ' angegeben worden, so wird von mehreren Laufwerken mit der erforderlichen Speicherplatzgröße, das Laufwerk mit dem meisten Speicherplatz zugewiesen.

Ist keine Option angegeben worden, so wird das erste Laufwerk mit der erforderlichen Speicherplatzgröße zugewiesen.

Hinweis:
 Da diese Funktion erst während des Joblaufes bearbeitet wird, sollte sie möglichst direkt vor dem Befehl definiert werden, der das freie Laufwerk benötigt (z.B. COPY oder ZIPEXE ).

Beispiel:
 Für die Übertragung von Dateien vom Fernrechner muss ein Laufwerk mit mindestens 150 Megabyte vorhanden sein.

Zuerst soll das Laufwerk 'G' geprüft werden. Wenn dort nicht genug Platz ist, die Festplatte 'C'. Ist auch dort nicht genug Platz, soll auf dem Netzwerklaufwerk 'J' gespeichert werden.

/Set % Lw% =DRIVE(150MB, g, c, j)
 ;
md % Lw% :\DATEN\%Firm%
;
FTPLogin IBM 162.44.3.9 %Host-UserID% %Host-Passwort%
IBM trailingblanks
copy IBM:SSW.RII.F0298.C%FirmNr%N % Lw% :\DATEN\%Firm%\FMG9802.FM
FTPLogout


FILE Funktion
siehe auch 'PATH'

Erzeugen eines Dateiauswahlfensters, in dem der Benutzer einen Dateinamen auswählen und in das Parametereingabefeld übernehmen kann.

Syntax:
 %Parameter%=FILE( [vorgabedateipfad [,UNC][,QUOTES | NOQUOTES | MULTISEL ]])

Bemerkungen:
 In dem erzeugten Dateiauswahlfenster wird der Vorgabedateipfad als Ausgangsverzeichnis angegeben.
Ist zusätzlich auch ein Dateiname bzw. Dateifilter (z.B. *.txt) angegeben worden, so wird dieser in dem Dateiauswahlfenster mit berücksichtigt.
Enthält der vom Benutzer gewählte Dateiname Leerstellen, wird er automatisch in Hochkommata eingeschlossen.

Dateinamen können per Ziehen und Fallenlassen aus dem Windows-Explorer oder anderen Anwendungen in das Eingabefeld übernommen werden.

Mit der Option 'UNC ' wird der gewählte Dateiname in das UNC (Universal Naming Convention) Format umgewandelt und weitergegeben. Das heißt, dass eventuell angegebene Laufwerk Mappings aufgelöst werden und der vollständige Pfadname übergeben wird.

Mit der Option 'QUOTES ' wird der gewählte Dateiname immer in Hochkommata eingeschlossen. Mit der Option 'NOQUOTES ' wird der gewählte Dateiname nie in Hochkommata eingeschlossen. Diese beiden Optionen sind notwendig, wenn der Parameter innerhalb einer Scriptsprache an Variablen übergeben werden soll.

Mit der Option 'MULTISEL ' können vom Benutzer mehrere Dateien innerhalb des Vorgabeverzeichnisses von vorgabedateipfad ausgewählt werden. Diese werden dann mit Komma getrennt in %Parameter% übergeben und könnten evtl. mit dem Steuerbefehl '/FOR ...' ausgewertet werden. Das Vorgabeverzeichnis von vorgabedateipfad wird nicht mit übergeben, sodass es für weitere Benutzung innerhalb des Jobs zusätzlich definiert werden muss.

Hinweis:
 Ist der Pfadteil vom vorgabedateipfad , in der zuletzt eingegebenen Datei enthalten, wird diese beim nächsten Aufruf des Eigenschaftenfensters wieder zur Verfügung gestellt. Ist dies nicht der Fall, so wird der vorgabedateipfad zur Verfügung gestellt.

Beispiel:
 Es werden für einen Job Dateien immer aus einem bestimmten Verzeichnis benötigt und die Endung der Dateien ist meistens .txt.

/Parameter Direktdaten-Datei=%DirDatei%=FILE( g:\daten\imsview\*.txt)

In dem Bereich 'Job-Parameter' wird nun erscheinen

der Schalter mit den 3 Punkten ruft das Dateiauswahlfenster auf.


FILTER Funktion

Herausfiltern von Begriffen aus einer Datei und Zuweisen an einen Parameter.

Syntax:
 %Parameter%=FILTER(dateiname, begrenzertext1[, begrenzertext2])

Die einzelnen Funktionsparameter müssen mit Komma getrennt eingetragen werden.

Bemerkungen:
 Die Funktion sucht innerhalb der angegebenen Datei nach dem begrenzertext1 . Wird ein solcher gefunden, so wird der Text, der diesem begrenzertext1 folgt, als Begriff genommen und dem Parameter zugewiesen. Ist ein begrenzertext2 angegeben worden, so wird der Text zwischen begrenzertext1 und begrenzertext2 als Begriff übernommen.

Werden in einer Datei mehrere Begriffe gefunden, so werden diese mit Komma getrennt dem Parameter zugewiesen. Wird ein Begriff mehrmals aufgefunden, so wird er nur einmal übernommen.

Beispiel:
 Ein Job soll mehrere Zipdateien in selbstextrahierende Zipdateien umwandeln. Um welche Zipdateien es sich handelt, kann man nur in einer DOS-Batchdatei erkennen. Dort wird mit dem DOS-Befehl 'set' dem DOS-Parameter 'pd' jeweils der entsprechende Zipname zugewiesen.

; definieren der Filterbedingung 'set pd' (Achtung ! das Leerzeichen muss mit dem Ersatzzeichen für Leerzeichen beschrieben werden)

;
/Set %RepSets%=FILTER(c:\daten\iv\norway\ferring.bat, set_pd=)
 ;
; eine for/next-Schleife kann jetzt alle in %RepSets% enthaltenen Begriffe abarbeiten
;
/For %RepSet%=(%RepSets%)
wzipsepe C:daten%RepSet%.zip
Sendkeys {TAB 2}%ClPath%~
Sendkeys §N§S
/Next %RepSet%


FORMAT Funktion

Bestimmen des Verhaltens von Texteingabeparametern.

Syntax:
 Beschreibung=%parameter%=FORMAT([UCASE] | [LCASE] | [0] [,INIT:inhalt | EMPTY] [,LINES:zeilenanzahl ] [,LENGTH:zeichenanzahl ])

Die einzelnen Funktionsparameter müssen mit Komma und ohne Leerzeichen getrennt eingetragen werden.

Bemerkung:
 Mit dem Zusatz 'UCASE' wird erreicht, dass während der Dateneingabe vom Benutzer alle Zeichen in Großschrift umgewandelt werden.

Mit dem Zusatz 'LCASE' wird erreicht, dass während der Dateneingabe vom Benutzer alle Zeichen in Kleinschrift umgewandelt werden.

Mit dem Zusatz '0' wird erreicht, dass beim Verlassen des Eingabefeldes die Eingabe mit führenden Nullen aufgefüllt wird. Die Gesamtlänge, die zum Auffüllen benutzt wird, richtet sich nach der Anzahl definierter Nullen (00 würde die Eingabe auf einen 2-stelligen Inhalt auffüllen).

Mit dem Zusatz 'INIT:' kann der Inhalt festgelegt werden, der als Initialwert erscheinen soll. Mit 'EMPTY' wird der Parameter leer gelassen.

Mit dem Zusatz 'LINES:' kann die Zeilenhöhe eines Eingabefeldes angegeben werden. Dabei wird die Eingabefeldlänge immer bis zum rechten Fensterrand erweitert, dass heißt die Feldlänge ändert sich nicht dynamisch nach dem Feldinhalt dieses Eingabefeldes.

Mit dem Zusatz 'LENGTH:' kann die maximale Anzahl Zeichen eines Eingabefeldes angegeben werden.

Beispiel:
 /Parameter SiteID=%SiteID%=FORMAT(UCASE)
 /Parameter Abfrage(n)=%Enquiries%=FORMAT(LINES:5,UCASE)
 /Parameter Datenbankname=%DBName%=FORMAT(LENGTH:8)
 /Parameter Monat=%MM%=FORMAT(INIT:EMPTY,LENGTH:2)
 /Parameter Monat=%MM%=FORMAT(00)


LIST Funktion

Erzeugen einer Auswahlliste als Parametereingabe für den Benutzer.

Syntax:
 %Parameter%=LIST( eintrag1, eintrag2... )
%Parameter%=LIST[ eintrag1, eintrag2... ]
%Parameter%=LIST[^ eintrag1, eintrag2... ]
%Parameter%=LIST{ eintrag1, eintrag2... }
Alle Einträge , die in der Auswahlliste angezeigt werden sollen, müssen mit Komma getrennt eingetragen werden.

Listentyp:
 Runde Klammern ( ) erzeugen eine sortierte Auswahlliste, die durch Anklicken ausgeklappt wird.
Eckige Klammern [ ] erzeugen eine unsortierte Auswahlliste, die durch Anklicken ausgeklappt wird.
Eckige Klammern mit einem Dach [^ ] erzeugen eine unsortierte Auswahlliste, die durch Anklicken ausgeklappt wird ohne den zuletzt benutzten Wert als Vorgabe zu nehmen.
Geschweifte Klammern { } erzeugen eine sortierte Auswahlliste, die direkt angezeigt wird und aus der mehrere Einträge gleichzeitig ausgewählt werden können. Werden mehrere Einträge ausgewählt, so werden diese mit Komma getrennt aneinander gehängt.

Bemerkungen:
 Ist als erster Eintrag ein Sternchen * angegeben worden, so hat der Benutzer die Möglichkeit, zusätzlich zu den Einträgen in der Auswahlliste, einen wahlfreien Eintrag anzugeben. Dies ist allerdings normalerweise nur sinnvoll wenn innerhalb des Jobs keine Inhaltsumsetzungen anhand dieser Einträge gemacht werden (siehe Parameterfunktion CONV).

Beispiel:
 Dem Benutzer sollen verschiedene Berichtsformen zur Auswahl angeboten werden.

/Parameter Bericht=%RXX%=LIST[ RII,RIO,ROI,RAO,RAI]

In dem Bereich 'Job-Parameter' wird nun erscheinen

Die Elemente erscheinen in gleicher Reihenfolge, wie in der Funktionsangabe.

Beispiel:
 Dem Benutzer sollen verschiedene Kunden zur Auswahl angeboten werden, deren Namen als Verzeichnisnamen benutzt werden. Da der Benutzer eigenständig neue Verzeichnisnamen anlegt, soll er diese auch für den Job angeben dürfen.

/Parameter: Kundenname=%Firm%=LIST(*,Gruen01,Lilly,Apharm,Hofla01,Bykgul01)

In dem Bereich 'Job-Parameter' wird nun erscheinen

Die Elemente erscheinen in sortierter Reihenfolge und das Eingabefeld mit der Textmarke ist jetzt editierbar.

Beispiel:
 Der Benutzer soll eine Datenverarbeitung starten, bei der die Daten von mehreren Kunden zusammen in einem Job verarbeitet werden können.

/Parameter: Kunden=%Firm%=LIST{Asche1KV,Asche2KV,Asche1,Asche2,Aliud,Abbott1,Abbott4}

In dem Bereich 'Job-Parameter' wird nun erscheinen

Bei der gezeigten Auswahl enthält der Parameter %Firm% den Inhalt 'Abbott4, Aliud, Asche2'.


OFF Funktion
siehe auch 'ON'

Setzen von Inhalten von Parametern, die zur Auswahl von Befehlszeilen dienen.

Syntax:
 %Parameter%=OFF(%eingabeparameter%:inhalt1[:inhaltN ][,%OnOffParameter%])

Links steht der Parameter, der mit 'REM' gefüllt wird wenn %eingabeparameter% den Inhalt inhalt1 enthält. Ist dies nicht der Fall, dann wird der Parameter mit einem Leerzeichen gefüllt. Der Parameter %OnOffParameter% bekommt jeweils den entgegen gesetzten Wert zugewiesen.

Bemerkungen:
 Diese Funktion kann benutzt werden, wenn man Befehlszeilen in Abhängigkeit von Bedingungen ein- oder ausschalten will. Dies erreicht man, indem man vor die Befehlszeilen einen Parameter schreibt, der entweder den Wert Leerzeichen (eingeschaltet) oder der Wert 'REM' (ausgeschaltet) bekommen muss. Das heißt also, dass die Befehlzeilen entweder ausführbar (Leerzeichen) oder auskommentiert (REM) werden.
Inhalt kann auch mit Jokerzeichen definiert werden.

Hinweis:
 Die Prüfung von inhalt berücksichtigt keine Groß/Klein-Schreibung.

Beispiel:
 Der Benutzer muss entscheiden, ob Daten in gepacktem oder ungepacktem Format auf den Mainframe kopiert werden sollen. Mit der Eingabe des Benutzers müssen dann die entsprechend auszuführenden Befehlszeilen aktiviert werden.

/Parameter Daten gepackt übertragen=%Zipped%=LIST[Ja,Nein]
;
/Set %ZIP%=OFF(%Zipped%:Nein,%TXT%)
 ;
FTPLogin Mf 162.44.3.9 T49imjm %Passwort%
%ZIP% binary
%ZIP% Mf lrecl=27998, blksize=27998, recfm=U
%ZIP% copy u:\proj\dataview\medmidas\source\B_6505.zip Mf:QBV.IDS.MEM.B_6505.ZIP
%TXT% Mf lrecl=27992, blksize=27996, recfm=VB
%TXT% copy u:\proj\dataview\medmidas\source\B_6505.txt Mf:QBV.IDS.MEM.B_6505.TXT
FTPLogout


ON Funktion
siehe auch 'OFF'

Setzen von Inhalten von Parametern, die zur Auswahl von Befehlszeilen dienen.

Syntax:
 %Parameter%=ON(%eingabeparameter%:inhalt1[:inhaltN ][,%OnOffParameter%])

Links steht der Parameter, der mit einem Leerzeichen gefüllt wird wenn %eingabeparameter% den Inhalt inhalt1 enthält. Ist dies nicht der Fall, dann wird der Parameter mit 'REM' gefüllt. Der Parameter %OnOffParameter% bekommt jeweils den entgegen gesetzten Wert zugewiesen.

Bemerkungen:
 Diese Funktion kann benutzt werden, wenn man Befehlszeilen in Abhängigkeit von Bedingungen ein- oder ausschalten will. Dies erreicht man, indem man vor die Befehlszeilen einen Parameter schreibt, der entweder den Wert Leerzeichen (eingeschaltet) oder der Wert 'REM' (ausgeschaltet) bekommen muss. Das heißt also, dass die Befehlzeilen entweder ausführbar (Leerzeichen) oder auskommentiert (REM) werden.
Inhalt kann auch mit Jokerzeichen definiert werden.

Hinweis:
 Die Prüfung von inhalt berücksichtigt keine Groß/Klein-Schreibung.

Beispiel:
 Der Benutzer muss entscheiden, ob Daten in gepacktem oder ungepacktem Format auf den Mainframe kopiert werden sollen. Mit der Eingabe des Benutzers müssen dann die entsprechend auszuführenden Befehlszeilen aktiviert werden.

/Parameter Daten gepackt übertragen=%Zipped%=LIST[Ja,Nein]
;
/Set %ZIP%=ON(%Zipped%:Ja,%TXT%)
 ;
FTPLogin Mf 162.44.3.9 T49imjm %Passwort%
%ZIP% binary
%ZIP% Mf lrecl=27998, blksize=27998, recfm=U
%ZIP% copy u:\proj\dataview\medmidas\source\B_6505.zip Mf:QBV.IDS.MEM.B_6505.ZIP
%TXT% Mf lrecl=27992, blksize=27996, recfm=VB
%TXT% copy u:\proj\dataview\medmidas\source\B_6505.txt Mf:QBV.IDS.MEM.B_6505.TXT
FTPLogout


PATH Funktion
siehe auch 'FILE'

Erzeugen eines Verzeichnisauswahlfensters, in dem der Benutzer eine Verzeichnis auswählen und in das Parametereingabefeld übernehmen kann.

Syntax:
 %Parameter%=PATH([vorgabeverzeichnis[,UNC][,FIX][,NOQUOTES]])

Bemerkungen:
 In dem erzeugten Verzeichnisauswahlfenster wird das Vorgabeverzeichnis als Ausgangsverzeichnis angegeben.

Pfadnamen können per Ziehen und Fallenlassen aus dem Windows-Explorer oder anderen Anwendungen in das Eingabefeld übernommen werden.

Enthält der vom Benutzer gewählte Pfadname Leerstellen, wird er automatisch in Hochkommata eingeschlossen.

Mit der Option 'UNC' wird der gewählte Pfadname in das UNC (Universal Naming Convention) Format umgewandelt und weitergegeben. Das heißt, dass eventuell angegebene Laufwerk Mappings aufgelöst werden und der vollständige Pfadname übergeben wird.

Mit der Option 'FIX' können vom Benutzer nur Unterverzeichnisse von vorgabeverzeichnis ausgewählt werden. In dem Parametereingabefeld wird das vorgabeverzeichnis nicht angezeigt. Nur das vom Benutzer ausgewählte Unterverzeichnis wird übernommen. Bei dieser Option wird der gewählte Pfadname nie in Hochkommata eingeschlossen, damit er mit einem übergeordneten Pfad zusammmengesetzt werden kann.

Mit der Option 'NOQUOTES' wird der gewählte Pfadname nie in Hochkommata eingeschlossen. Diese Option ist notwendig, wenn der Parameter innerhalb einer Scriptsprache an Variablen übergeben werden soll.

Hinweis:
 Ist der Pfad vom Vorgabeverzeichnis in dem zuletzt eingegeben Pfad enthalten, wird dieser beim nächsten Aufruf des Jobfensters wieder zur Verfügung gestellt. Ist dies nicht der Fall, so wird das vorgabeverzeichnis zur Verfügung gestellt.

Beispiel:
 Es sollen für einen Job Unterverzeichnisse eines bestimmten Verzeichnisses ausgewählt werden können.

/Parameter Kunden CD-Pfad=%CDPath%=PATH(c:\Produkt\Kundendaten,FIX)

In dem Bereich 'Job-Parameter' wird nun erscheinen

der Schalter mit den 3 Punkten ruft das Verzeichnisauswahlfenster auf:


REPLACE Funktion

Ersetzen von Zeichenfolgen und Zuweisen an einen Parameter.

Syntax:
 %Parameter%=REPLACE(ausdruck,option)

Die einzelnen Funktionsparameter müssen mit Komma getrennt eingetragen werden.

Bemerkungen:
Die Funktion gibt den ersetzen Inhalt des Ausdrucks in %Parameter% aus.

Wenn Ausdruck ein Passwort-Parameter des Jobs ist (siehe %Parameter%), kann mit der Option 'CODING' der decodierte Inhalt ausgegeben werden.

Mit der Option 'PARAMS' wird in Ausdruck nach %Parametern% gesucht und durch deren Inhalte ersetzt. Dadurch ist es möglich, Parameter zu ersetzen, die innerhalb von Parametern enthalten sind. Somit können vom Benutzer eingegebene oder aus Parametertabellen ausgewählte Ausdrücke variabel definiert werden.

Beispiel:
 Ein Job soll eine Datei mit einem Namen packen, der das Systemdatum enthält. Der Name muss vom Benutzer aus einer Parametertabelle ausgewählt werden können.

; %VariablerDateiname% ist ein Feld einer Parametertabelle. Der Benutzer wählte eine Zeile der Tabelle, die in diesem Feld den Wert 'Database_%SYSYY%%%SYSMM%%SYSDD%' enthält.

/Set %NameMitDatum%=REPLACE(%VariablerDateiname%,PARAMS)
; %NameMitDatum% enthält nun den Wert mit dem festen Teil 'Database_' und dem zum Jobstart gültigen Systemdatum

pack c:\test\database.dat c:\test\%NameMitDatum%.zip


TABLE Funktion
siehe auch 'DATASOURCE' und 'Tabellen-Editor'

Erzeugen einer Auswahltabelle als Parametereingabe für den Benutzer.

Syntax:
 %Indexparameter%=TABLE{ [Spaltenüberschriften, ] Spaltenparameter, Spaltenanzeige, Zeilenauswahl, Tabellenzeilen,... | DATASOURCE(...)}

Alle Spalten- und Zeilendefinitionen müssen mit Komma getrennt eingetragen werden (Ausnahme siehe Hinweis).

Tabellentyp:
 Runde Klammern ( ) erzeugen eine sortierte Auswahlliste, die durch Anklicken ausgeklappt wird.
Eckige Klammern [ ] erzeugen eine unsortierte Auswahlliste, die durch Anklicken ausgeklappt wird.
Geschweifte Klammern { } erzeugen eine sortierte Auswahltabelle, die direkt angezeigt wird und aus der mehrere Einträge gleichzeitig ausgewählt werden können. Dabei können auch Spaltenüberschriften erscheinen.
Geschweifte Klammer und runde Klammer {( am Anfang erzeugt eine sortierte Auswahltabelle, die direkt angezeigt wird und aus der nur ein Eintrag ausgewählt werden kann. Dabei können auch Spaltenüberschriften erscheinen.

Syntax der Spalten- und Zeilendefinitionen:
 Spaltenangabe1: Spaltenangabe2: Spaltenangabe3:...,

Jede Angabe bezieht sich auf eine Spalte der Tabelle und muss mit einem Trennzeichen (': ' oder '| ') von der Angabe für die nächste Spalte getrennt sein. Dabei darf in einem Tabellenbefehl immer nur eins der beiden möglichen Trennzeichen benutzt werden. Vom Programm wird das jeweils erste gefundene Trennzeichen (entweder ': ' oder '| ') als Trennzeichen für die komplette Funktion angenommen.

Die Spalten- und Zeilendefinitionen bieten folgende Möglichkeiten:

Spaltenüberschriften:
 Sie sind optional anzugeben. Wenn sie nicht angegeben werden, werden die Spaltenparameter als Überschriften benutzt.

Wird 'NoHeader ' angegeben, wird keine Spaltenüberschrift erzeugt.
Bei der Auswahlliste, die durch Anklicken ausgeklappt wird erscheint keine Spaltenüberschrift.

Spaltenparameter:
 Sie definieren die Parameter, die innerhalb des Jobs mit den Spaltenwerten der Zeile(n), die der Benutzer markiert hat, gefüllt werden. Sind keine Spaltenüberschriften angegeben worden, werden die Spaltenparameter als Überschrift benutzt.

Spaltenanzeige:
 Sie definiert, welche der in der Tabelle vorhandenen Spalten dem Benutzer angezeigt werden sollen. Dies hat den Vorteil, dass die einmal in einer Tabelle angelegten Tabellenzeilen, für mehrere Jobs genutzt werden können, die unterschiedliche Bedeutungen und Aufgaben für den Benutzer haben können.

Es gibt die Möglichkeit mit der Angabe 'Yes ' oder 'No ' eine Spalte anzuzeigen oder zu unterdrücken.

Als zweite Möglichkeit kann die Reihenfolge der auszugebenden Spalten verändert werden. Dazu gibt man einfach die entsprechenden Reihenfolgezahlen an, wie z.B. 2:1:0:3 . Eine '0 ' unterdrückt die entsprechende Spalte.

Zeilenauswahl:
 Sie definiert, welche der in der Tabelle vorhandenen Zeilen dem Benutzer angezeigt werden sollen.

Dabei wird der Inhalt jeder Spalte einer Zeile mit der Selektionsangabe der Zeilenauswahl überprüft. Stimmt der Spalteninhalt einer Zeile nicht mit dem entsprechenden Selektionskriterium dieser Spalte überein, so wird die Tabellenzeile nicht ausgegeben.

Als Selektionskriterien können die Operatoren '<', '=', '<> ', '>' und '>=' angegeben werden. Auf den Operator muss direkt der abzufragende Wert folgen. Sollen alle Tabellenzeilen angezeigt werden, braucht nur der Operator '>' angegeben werden (bzw. '>=', wenn in den Spalten einer Zeile gar kein Wert steht). Wird kein Operator angegeben, sondern nur ein Vergleichswert, dann wird auf Gleichheit geprüft. Bei dieser Vergleichsart sind auch Jokerzeichen erlaubt.

Um eine Liste von Werten zu definieren, muss die Syntax '<Wert1+Wert2+WertN>' benutzt werden.

Tabellenzeilen:
 Als letzte Angabe folgen die eigentlichen Tabellenzeilen mit den Spaltenwerten. Soll der Spaltenwert ein Leerzeichen enthalten, muss anstelle dessen das Ersatzzeichen für Leerzeichen angegeben werden, da sonst die Erkennung der Spaltenwerte nicht korrekt erfolgen kann.

Wenn als Tabellenzeilen die Datensätze einer Datenbank oder anderer tabellarischer Quellen entnommen werden sollen, dann kann anstelle der Tabellenzeilen die Option 'DATASOURCE' benutzt werden.

Bemerkungen:
 Die Tabellenfunktion ist eine Erweiterung der Listenfunktion 'LIST'. Mit der Tabellenfunktion können grundlegende Wertezugehörigkeiten direkt definiert werden ohne die Funktion 'CONV' zu benötigen. Die Parameter für alle Spalten werden direkt mit den in den Tabellenzeilen angegebenen Werten gefüllt.

Wie bei der Listfunktion werden bei der Auswahl mehrerer Zeilen alle Spaltenwerte in den dazugehörenden Parameter mit Komma getrennt eingetragen.

Der entscheidende Unterschied ist der, dass dieses Vorgehen verändert wird, sobald der Indexparameter (der vor der Tabellenfunktion angegeben ist) mit dem Steuerbefehl '/FOR ...' benutzt wird.

In diesem Parameter werden nämlich alle vom Benutzer markierte Zeilen mit ihrer Zeilennummer abgelegt. Bei jedem Vervielfältigungsdurchlauf wird die nächste Zeilennummer benutzt, um die für diese Zeile gültigen Spaltenwerte bereitzustellen.

Somit ist es nur mit dem Befehl '/FOR...' und dem Indexparameter möglich, für mehrere vom Benutzer ausgewählte Zeilen die Inhalte der jeweiligen zusammengehörenden Spaltenparameter zu nutzen.

Außerdem werden von dem Befehl '/FOR...' bei mehreren aufeinander folgenden gleichen Werten, alle Werte berücksichtigt.

Die Definition einer Tabelle kann mit dem Tabellen-Editor für Definitionen bearbeitet werden.

Hinweis:
 Alle Spalten- und Zeilendefinitionen können in einer Reihe hintereinender angegeben werden. Sollen diese Angaben jeweils in einer neuen Befehlszeile stehen, gibt zwei verschiedene Möglichkeiten.

1. vor jeder Zeile muss das Verbindungszeichen /- stehen; es werden dann die oben genannten Trennzeichen angenommen.

2. die Zeile vor den Tabellenzeilen und die Zeile nach den Tabellenzeilen muss aus den Zeichen /^ bestehen. Die Spalten der nachfolgenden Zeilen werden durch Tabulator getrennt und die Zeilen brauchen nicht mit Komma abgeschlossen werden. Der Vorteil dieser Methode ist, dass innerhalb der Spalten alle sichtbaren Zeichen angegeben werden können (also auch , : ; ) und | ).

Diese Methoden werden üblicherweise nur mit den eigentlichen Tabellenzeilen gemacht. Werden viele Tabellenzeilen definiert, so können diese in eine eigene Datei geschrieben und mit dem Befehl '/Include' eingelesen werden. Der Vorteil dieser Methode ist, dass die Tabellendatei dann komfortabel mit dem Tabellen-Editor bearbeitet werden kann. Dieser kann dann direkt über das Kontextmenü der ausgegebenen Tabelle aufgerufen werden, ohne in den Befehlseditor gehen zu müssen. Im Befehlseditor kann der Tabelleneditor über das Kontextmenü des markierten Wortes 'TABLE' aufgerufen werden.

Beispiel:
 Es soll für mehrere Firmen eine Datenübertragung von RPM-Datenbanken gestartet werden. Dabei soll dem Benutzer nur der Firmenname und die Firmennummer gezeigt werden.

/Param: %Kunden%=TABLE{%FirmName%:%Studie%:%FirmNrPref%:%FirmNr%:%PCFir%, Yes:No:No:Yes:No, >:>:>:>:>,
/- Azupharma-Tiger:RII:M:99080:azutiger,
/- Asche2KV:RAI:M:99171:ascheasch2kv,
/- Asche1KV:RAI:M:99161:ascheasch1kv,
/- Asche2:RAI:M:99170:ascheasch2,
/- Asche1:RAI:M:99160:ascheasch1,
/- Aliud:RAI:C:99050:aliudaliud,
/- Abbott1:RII:C:99010:abbottabbott1,
/- Abbott4:RII:M:99040:abbottabbott4}

In dem Bereich 'Job-Parameter' wird nun erscheinen

Wie im obigen Bild hat der Benutzer nun zwei Zeilen markiert. Um diese zwei Zeilen bearbeiten zu können, muss der Job nun folgendermaßen aufgebaut sein:

/FOR %Firma%=(%Kunden%)
 binary
copy IBM:%Studie%.%FirmNrPref%%FirmNr%.CHR %PC-Pfad%\%PCFir%.chr
copy IBM:%Studie%.%FirmNrPref%%FirmNr%.HED %PC-Pfad%\%PCFir%.hed
copy IBM:%Studie%.%FirmNrPref%%FirmNr%.IDX %PC-Pfad%\%PCFir%.idx
copy IBM:%Studie%.%FirmNrPref%%FirmNr%.INF %PC-Pfad%\%PCFir%.inf
copy IBM:%Studie%.%FirmNrPref%%FirmNr%.TAD %PC-Pfad%\%PCFir%.tad
/NEXT %Firma%

Für die, in dem Indexparameter %Kunden% enthaltenen Zeilennummern (also in dem Fall 4 und 6), werden bei jedem Durchlauf die fünf Spaltenparameter mit den Inhalten der jeweiligen Zeile gefüllt.

Beachtet werden muss, dass der Indexparameter '%Kunden%' in dem Klammerausdruck benutzt werden muss und dass der Parameter '%Firma%' innerhalb der FOR/NEXT-Schleife nicht verwendet wird.

Beispiel:
 Dem Benutzer sollen verschiedene Berichtsformen zur Auswahl angeboten werden.
/Parameter %Bericht%=TABLE[%RXX%,Yes,>,RII,RIO,ROI,RAO,RAI]

In dem Bereich 'Job-Parameter' wird nun erscheinen

Die Elemente erscheinen in gleicher Reihenfolge, wie in der Funktionsangabe.

Beispiel:
 Dem Benutzer sollen verschiedene Kunden zur Auswahl angeboten werden. Die Anzeige soll sortiert und zum Aufklappen sein. Die Tabelle enthält mehrere Spalten und soll vom Benutzer selbst verwaltet werden.

/Parameter: %Kunde%=TABLE(noheader,%Firm%:%FirmNr%:%Typ%,Yes:No:No,>:>:>,

/Include RPMFIRM2.JST

In dem Bereich 'Job-Parameter' wird nun erscheinen

Durch die Verwendung einer eigenen Tabellendatei, die mit /Include eingebunden wird, kann der Benutzer die Tabelle über das Kontextmenü aufrufen.

Besonderheit bei der Liste zum Aufklappen ist, dass das Kontextmenü nur über dem zusätzlichen Zeichen '>' erscheint.


TABLESELECT Funktion
siehe auch 'DATASOURCE'

Selektieren von Feldinhalten einer Tabellendatei und Setzen von Jobparametern.

Syntax:
 %Anzahlparameter%=TABLESELECT([Tabellenspalten,]Spaltenparameter,Zeilenauswahl,DATASOURCE(...))

Alle Spalten- und Zeilendefinitionen müssen mit Komma ohne Leerzeichen getrennt eingetragen werden.

Syntax der Spalten- und Zeilendefinitionen:
 Spaltenangabe1:Spaltenangabe2:Spaltenangabe3...,

Jede Angabe bezieht sich auf eine Spalte der Tabelle und muss mit einem Trennzeichen (': ' oder '| ') von der Angabe für die nächste Spalte getrennt sein. Dabei darf in einem Tabellenbefehl immer nur eins der beiden möglichen Trennzeichen benutzt werden. Vom Programm wird das jeweils erste gefundene Trennzeichen (entweder ': ' oder '| ') als Trennzeichen für die komplette Funktion angenommen.

Die Spalten- und Zeilendefinitionen bieten folgende Möglichkeiten:

Tabellenspalten:
 Die Spaltennamen der Tabellendatei können optional angegeben werden. Wenn sie hier nicht angegeben werden, müssen sie bei 'DATASOURCE' angegeben werden.

Spaltenparameter:
 Sie definieren die Parameter, die innerhalb des Jobs mit den Spaltenwerten der Zeile(n), die durch die Zeilenauswahl gelesen wurde, gefüllt werden.

Zeilenauswahl:
 Sie definiert, welche der in der Tabelle vorhandene Zeile selektiert werden sollen.

Dabei wird der Inhalt jeder Spalte einer Zeile mit der Selektionsangabe der Zeilenauswahl überprüft. Stimmt der Spalteninhalt einer Zeile mit dem entsprechenden Selektionskriterium dieser Spalte überein, wird die Tabellenzeile selektiert.

Als Selektionskriterien können die Operatoren '<', '=', '<>', '>' und '>=' angegeben werden. Auf den Operator muss direkt der abzufragende Wert folgen. Der Wert kann auch durch einen Parameter bezeichnet werden. Soll kein Auswahlkriterium für eine Tabellenspalte angegeben werden, braucht nur der Operator '>' angegeben zu werden (bzw. '>=', wenn in den Spalten einer Zeile gar kein Wert steht). Wird kein Operator angegeben, sondern nur ein Vergleichswert, dann wird auf Gleichheit geprüft. Bei dieser Vergleichsart sind auch Jokerzeichen erlaubt.

DATASOURCE:
 Die Option 'DATASOURCE' beschreibt den Typ der Tabellendatei und falls nicht in dieser Funktion angegeben auch die Tabellenspalten.

Bemerkungen:
 Übliche Anwendung ist das Lesen einer bestimmten Zeile einer Tabelle anhand eines Schlüsselfeldes. Das oder die Schlüsselfelder werden hier als normaler Spaltenname angegeben. Das Selektieren einer Zeile ergibt sich aus dem oder den Werten, die in der Zeilenauswahl für die entsprechenden Spalten angegeben wurden. Dieser Wert wird normalerweise mit einer Gleichheitsoperation definiert.

Beispiel:
 Mit dem Inhalt des Parameters %DBName% soll die dazugehörende Tabellenzeile einer Tabelle aus einer Access Datenbank gelesen werden und die Inhalte der Spalten in die restlichen Parameter gestellt werden. Nur wenn die Zeile auch einen Servernamen enthält, soll sie selektiert werden. Die Parameter sollen nicht wie die Spaltennamen der Tabelle heißen.

/Set %TB%=TABLESELECT(%DBName%:%Server%:%User%,%DBName%:>:>=,DataSource(c:\daten\proddb.mdb,,,Transfer~Information,Database:Servername:UserID))


Steuerbefehle

Mit Steuerbefehlen ist es möglich, den Ablauf der Jobbefehle zu steuern oder Jobbefehlszeilen variabel zu vervielfältigen.

/FOR ...=...

siehe auch
'PC CHECKLOGFILE' und 'TelNet checklogfile'


/FOR ...=...

Dieser Befehl dient zum Vervielfältigen von Befehlszeilen.

Syntax 1:
/FOR %parameter%= anfangswert TO endwert [STEP schrittweite ] [COUNT %zähler% ] Befehlszeile...

Syntax 2:
/FOR %parameter%= anfangswert TO endwert [STEP schrittweite ] [COUNT %zähler% ]
Befehlszeile
" "
/NEXT %parameter%

Syntax 3:
/FOR %parameter%=( wert1, wert2, ...) [COUNT %zähler% ] [INITCOUNT zahl ]
Befehlszeile
" "
/NEXT %parameter%

Bemerkungen:
 Bei der Syntax 1 und der Syntax 2 wird die Vervielfältigung erreicht, indem für jeden Wert vom angegebenen Anfangswert bis zum Endwert die nachfolgende(n) Befehlszeile(n) erstellt werden. Dabei wird der Inhalt des angegebenen Parameters jeweils um eine Einheit erhöht, wenn mit dem Zusatz 'STEP ' keine bestimmte Schrittweite angegeben wurde. Für Anfangswert und Endwert können Zahlen oder Buchstaben angegeben werden.

Bei der Syntax 1 vervielfältigt der Befehl nur die, in der gleichen Zeile nachfolgend, angegebenen Befehle.

Bei der Syntax 3 wird die Vervielfältigung erreicht, indem für jeden, der in Klammern angegebenen Werte, die nachfolgende(n) Befehlszeile(n) erstellt werden. Die Werte können Zahlen und Texte sein. Folgen mehrere gleiche Werte aufeinander, so wird nur der erste Wert berücksichtigt. Besondere Bedeutung hat diese Syntax im Zusammenhang mit der Tabellenfunktion 'TABLE'.

Der %parameter% , in den die jeweiligen Werte eingesetzt werden, kann in der/den folgenden Befehlszeilen benutzt werden, um diese variabel zu halten.

Mit dem Zusatz 'COUNT' kann %zähler% als Parameter definiert werden, der bei jedem Vervielfältigungsdurchlauf um 1 erhöht wird. Dadurch enthält dieser Zählparameter immer die aktuelle Anzahl der Durchläufe.

Mit der Option 'INITCOUNT' kann %zähler% mit zahl vorbelegt werden. Dadurch enthält der Zählparameter die aktuelle Anzahl der Durchläufe plus dem Wert von zahl . Dies kann benutzt werden, um bei mehreren '/For' Befehlen einen Gesamtzähler zu bekommen, indem man zahl mit %zähler% des vorherigen '/For' Befehls belegt.

Es können mehrere 'For ...' Befehle geschachtelt angegebene werden.

Hinweis:
 Bei Syntax 1 und Syntax 2 kann das Format von Zahlen bestimmt werden. Durch die Angabe von Nullen vor dem Anfangswert wird die Ausgabe von gleichlangen Zahlen (durch führenden Nullen) erreicht.

Beispiel:
 Ein Programm gibt bestimmte Tabellen als Dateien aus. Die jeweilige Tabellennummer ist im Namen der Ausgabedateien enthalten. Die Ausgabedateien sollen in ein anderes Verzeichnis kopiert werden.

/FOR %TabNr%= 1 TO 6: copy SP2:KSBCDR%TabNr%.G.T.19981 c:\daten\dkb\C%TabNr% T981.TXT

Folgende Befehlzeilen werden generiert:
copy SP2:KSBCDR1.G.T.19981 c:\daten\dkb\C1T981.TXT
copy SP2:KSBCDR2.G.T.19981 c:\daten\dkb\C2T981.TXT
copy SP2:KSBCDR3.G.T.19981 c:\daten\dkb\C3T981.TXT
copy SP2:KSBCDR4.G.T.19981 c:\daten\dkb\C4T981.TXT
copy SP2:KSBCDR5.G.T.19981 c:\daten\dkb\C5T981.TXT
copy SP2:KSBCDR6.G.T.19981 c:\daten\dkb\C6T981.TXT

Beispiel:
 Die Dateien aus dem oben genannten Beispiel sollen zusätzlich jeweils für das 1. und das 2. Quartal kopiert werden.

/FOR %Q%= 1 TO 2

/FOR %TabNr%= 1 TO 6: copy SP2:KSBCDR%TabNr%.G.T.1998%Q% c:\daten\dkb\C%TabNr% T98%Q%.TXT

/NEXT %Q%

Folgende Befehlzeilen werden generiert:
copy SP2:KSBCDR1.G.T.19981 c:\daten\dkb\C1T981.TXT
copy SP2:KSBCDR2.G.T.19981 c:\daten\dkb\C2T981.TXT
copy SP2:KSBCDR3.G.T.19981 c:d\aten\dkb\C3T981.TXT
copy SP2:KSBCDR4.G.T.19981 c:\daten\dkb\C4T981.TXT
copy SP2:KSBCDR5.G.T.19981 c:\daten\dkb\C5T981.TXT
copy SP2:KSBCDR6.G.T.19981 c:\daten\dkb\C6T981.TXT

copy SP2:KSBCDR1.G.T.19982 c:\daten\dkb\C1T982.TXT
copy SP2:KSBCDR2.G.T.19982 c:\daten\dkb\C2T982.TXT
copy SP2:KSBCDR3.G.T.19982 c:\daten\dkb\C3T982.TXT
copy SP2:KSBCDR4.G.T.19982 c:\daten\dkb\C4T982.TXT
copy SP2:KSBCDR5.G.T.19982 c:\daten\dkb\C5T982.TXT
copy SP2:KSBCDR6.G.T.19982 c:\daten\dkb\C6T982.TXT

Beispiel:
 Es soll für mehrere Dateien mit durchnummerierten Dateinamen eine Datenübertragung erfolgen. Die Nummerierung beginnt mit 01 und endet mit 26, wobei alle einstelligen Zahlen mit führender Null vorhanden sind.

/FOR %Reportnr%= 0 1 TO 26
copy IBM:OYMP.PAGEVIEW.REPORT%Reportnr% c:\daten\dpm\REPORT%Reportnr%
/NEXT %Reportnr%

Beispiel:
 Es soll für mehrere Firmen eine Datenübertragung von Dateien gestartet werden.

/FOR %Firma%=(Abbott4,Aliud,Asche2)
 binary
copy IBM:DATA.%Firma%.TXT c:\data\%Firma%.txt
/NEXT %Firma%
Um die Werte innerhalb der Klammern vom Benutzer aus einer Liste wählen zu lassen, kann die Parameterfunktion 'LIST' mit geschweiften Klammern benutzt werden.


Sonstiges

Weitere Angaben zur Benutzung des Job-Systems.


Fehlerbehandlung

Tritt während der Verarbeitung ein Fehler auf, so wird normalerweise der Job abgebrochen und eine entsprechende Meldung ausgegeben.

Soll aber für eine bestimmte Aktion ein Abbruch des Jobs verhindert werden, obwohl ein Fehler aufgetreten ist, so kann dies mit dem Befehl 'OnErrorWarning ' erreicht werden. Tritt während des Jobs eine Fehler auf, wird erst nach Ablauf des kompletten Jobs eine Warnung an den Benutzer ausgegeben.

Soll ein aufgetretener Fehler ignoriert werden, so muss der Befehl 'OnErrorIgnore ' benutzt werden.

Soll nach der Aktion die normale Fehlerbehandlung wieder eingeschaltet werden, so muss der Befehl 'OnErrorBreak ' benutzt werden.

Soll nach einem aufgetretenem Fehler, der zum Abbruch führt, eine besondere Meldung an den Benutzer ausgegeben werden, so kann der Befehl 'OnErrorMsg meldung ' benutzt werden.

Mit dem Befehl 'OnErrorRepeat sekunden' wird innerhalb einer FTP Session ein abgebrochener Kopierbefehl bis zu 3 mal nach der angegebenen Anzahl Sekunden wiederholt.

Beispiel:
 Bei der Umwandlung von Ausgabeformaten werden bestimmte Eingabedaten nicht bei jeder Produktion erstellt. Tritt dieser Fall auf, so soll dem Benutzer nach Ablauf des Jobs ein Hinweis gegeben werden, dass ein Ereignis aufgetreten ist, das überprüft werden muss.

OnErrorWarning
fileconv &&fileconvlog h:pool_crpJobsysbatchIVENG.ini
addtologfile &&fileconvlog /IfExists 'abnormal beendet' Error
OnErrorBreak

Bei der der Verarbeitung von Parameterdateien gibt es unterschiedliche Namenskonventionen. Bei einigen Verarbeitungen ist erst eine Umbenennung erforderlich, bei anderen existiert der Name schon.

OnErrorIgnore
 ren %DBName%.prm %PRMName%.prm
OnErrorBreak

Nach einem Abbruch des Jobs soll der Benutzer darauf hingewiesen werden, dass bei manueller Weiterbearbeitung eine bestimmte Aktion durchgeführt werden muss.

OnErrorMsg Achtung! Die Datei 'Standard.dat' muss unbedingt in das Datenbankverzeichnis kopiert werden.


Kommandozeilenparameter

Mit Kommandozeilenparametern kann der Aufruf des Job-Systems mit bestimmten Werten vorbelegt werden.

Folgende Parameter sind möglich:

/DB datenbankname | der Pfadname oder direkt der Name der Job-System Datenbank
Benutzername [Kennwort ] | der Name und das Kennwort des Benutzers, mit dem das Job-System aufgerufen werden soll

Beispiel:
 C:\Programme\Eigene\JobSys2.exe t49imjm


Programm-Module von Drittherstellern

Das Job-System wurde unter Verwendung von Programm-Modulen von Drittherstellern programmiert.
Diese Programm-Module sind nicht lizenzpflichtig und werden daher aus rechtlichen Gründen mit ihren Lizenzvereinbarungen zu dem Job-System mit installiert.

  1. SocketWrench von Catalyst Development Corporation
     dieses Software Modul wird für die Ausführung der integrierten FTP- und Telnet-Befehle benutzt. Hierfür gelten die SocketWrench-Lizenzvereinbarungen.
  2. Zip und Unzip von der Info-Zip Group
     diese Software-Module werden für die integrierten Befehle zum Packen und Entpacken benutzt. Hierfür gelten die Info-Zip-Lizenzvereinbarungen.


Systemschalter

Mit Systemschalter lassen sich Systemeinstellungen verändern, die bei der Job Erstellung benutzt werden.

/Set Jobname=jobbezeichner

Gibt dem Job einen Namen, der in dem Protokoll-Archiv zur Identifikation benutzt werden kann. Die Zeichen / : * ? " < > | % . sind nicht zugelassen und werden automatisch in einen Unterstrich _ umgewandelt.

Beispiel:
 /Set Jobname=%Kunde%M%Monat%

/Set NoArchive
/Set NoHistory

Unterdrückt die standardmäßige Sicherung des Jobprotokolls.

/Set Notification=EMAIL( [OnStart] [,OnBreak | OnConfirmedError | OnError | OnEnd | OnWarning ] :emailadresse )

Beschreibt zu welchem Zeitpunkt des Joblaufs die emailadresse per E-Mail benachrichtigt werden sollen.

Option | das E-Mail wird geschickt
OnStart | nach dem Start des Jobs und enthält die Startangaben, die auch im Protokoll ausgegeben werden
OnConfirmedError | wenn ein Fehler aufgetreten ist und der Benutzer eine Benachrichtigung senden will (ein Bestätigungsfenster lässt den Benutzer entscheiden)
OnBreak | wenn ein Fehler aufgetreten ist, der zum Abbruch des Jobs führte
OnError | wenn ein Fehler aufgetreten ist, der nicht unterdrückt wurde (siehe Fehlerbehandlung)
OnWarning | wenn ein Fehler aufgetreten ist, der zu einer Warnung führte
OnEnd | wenn der Job beendet ist

Bei 'OnConfirmedError', 'OnError', 'OnWarning' und 'OnEnd' wird das Protokoll des Joblaufs im E-Mail mit angehängt.
Fehler, die mit dem Schalter 'OnErrorIgnore' unterdrückt wurden, werden nicht als Fehler behandelt.

Die emailadressen können wie in der Adressangabe eines Mailprogramms angegeben werden. Zu Beachten ist, dass Leerzeichen mit dem Ersatzzeichen für Leerstellen ersetzt werden müssen (siehe unten).

Es können mehrere Zeilen mit verschiedenen Benachrichtigungsdefinitionen eingesetzt werden.

Ist in den allgemeinen Programmoptionen die Option 'SMTP für Email benutzen' aktiviert, so wird auch für die Benachrichtigung die angegebene SMTP Adresse benutzt.

Beispiel:
 /Set Notification=EMAIL(OnEnd:Müller,~Hans;Maier~Walter)
/Set Notification=EMAIL(OnError:JMarkart@online.de)

/Set BlankChar=zeichen

Setzt das Ersatzzeichen für Leerstellen auf das angegebene zeichen . Ersatzzeichen für Leerzeichen müssen innerhalb von Parameterfunktionen benutzt werden. Standardzeichen ist das Zeichen '~' (Tilde).
Eine Änderung ist notwendig, wenn innerhalb einer Parameterfunktion das Standardzeichen selbst benutzt werden muss.

Beispiel:
 /Set BlankChar=°
/Parameter: Kunden=%Firm%=TABLE{(Clientnr|DBName|HostDBName|LANClient....
/Include ivnwfir2.txt <--- Hier Kundendaten ändern (enthält Pfadnamen mit Tilde)
/Set BlankChar=~

/Set ParamAllign

Schaltet die Ausrichtung der Parametereingabefelder ein (siehe auch Job Optionen). Muss als erste Angabe vor den "/Parameter" Definitionen erfolgen.

/Set ParamDelimChar=zeichen

Setzt das Begrenzerzeichen für Parameternamen auf das angegebene zeichen. Standardzeichen ist das Zeichen '%'.
Eine Änderung ist notwendig, wenn das Standardzeichen selbst an andere Programme übergeben werden muss.

Beispiel:
 /Set ParamDelimChar=^
 //* SAS Program Inline Code
//SASCODE *
%Macro performtest
month=^MM^
 //*
/Set ParamDelimChar=%


Temporäre Dateien
siehe auch INLINE

Definieren von Dateien, die nur zur Laufzeit des Batch-Moduls benötigt werden.

Syntax:
&& bezeichnername

Bemerkungen:
 Temporäre Dateien werden oft benutzt, wenn Informationen von einem Programm an nachfolgende Programme weitergegeben werden sollen. Da die übergebenen Informationen lediglich während des Joblaufs benötigt werden, wäre eine Speicherung über den Joblauf hinaus nicht sinnvoll und außerdem bestände bei Vergabe von festen Dateinamen die Gefahr, dass parallele Verarbeitungen sich gegenseitig blockieren oder manipulieren.

Der && bezeichnername kann anstelle eines normalen Dateinamens angegeben werden.

Die Benutzung von Bezeichnernamen für temporären Dateien wird auch innerhalb eines mit dem Befehl 'INLINE' definierten Script Programmcodes unterstützt.

Beispiel:
 Es soll ein Programm zur Konvertierung von Dateiformaten aufgerufen werden. Das Programm schreibt Ablaufmeldungen in eine Protokolldatei, deren Name dem Programm mitgegeben werden kann.

Nach dem Programmlauf soll diese Protokolldatei in das Jobprotokoll des Batchlauf-Moduls eingefügt werden und auf Fehlermeldungen geprüft werden, um eventuell den Joblauf unterbrechen zu können.

fileconv.exe && fileconvlog c:\daten\work\cnvsozio.ini
addtologfile && fileconvlog /ErrorIfNotExists: 'normal beendet'


Job Startplan Zeit
siehe auch Startplan Ereignis

Der Startplan beschreibt zeitlichen Termine und/oder Ereignissen, bei denen ein Job gestartet werden soll.

Über das Dateimenü 'Job Plan ändern...' oder über den Schalter 'Plan ändern...' des Eigenschaftenfensters wird das Startplanfenster aufgerufen.

Das Startplanfenster hat drei Register zum Definieren eines Zeitplans, Ereignissen und zusätzlichen Einstellungen.

Als Zeitplan können folgende Terminarten definiert werden.

Einmal | wenn ein einmaliger Aufruf eines Jobs erfolgen soll.
Stündlich | wenn ein Job innerhalb jeder Stunde einmal aufgerufen werden soll.
Täglich | wenn ein Job an bestimmten Tagen innerhalb eines Zeitbereiches aufgerufen werden soll.
Wöchentlich | wenn ein Job jede Woche an einem bestimmten Tag zu einer bestimmten Uhrzeit aufgerufen werden soll.
Monatlich | wenn ein Job jeden Monat an einem bestimmten Tag zu einer bestimmten Uhrzeit aufgerufen werden soll.
Beim Start | wenn ein Job beim Start des Betriebssystems ausgeführt werden soll. Hierzu muss die Option 'Dauerhaft aktivieren' des Menüs 'Extras' aktiv sein.
Beim Beenden | wenn ein Job beim Beenden des Betriebssystems aufgerufen werden soll.


Job Startplan Ereignis
siehe auch Startplan Zeit und Einstellungen

Der Startplan Ereignis beschreiben Ereignissen, bei denen ein Job gestartet werden soll.

Als Ereignis können folgende Arten definiert werden.

Sobald Dateien existieren | wenn ein Job in Abhängigkeit von existierenden Dateien aufgerufen werden soll.
Sobald eine Nachricht eintrifft | wenn ein Job in Abhängigkeit von E-Mails aufgerufen werden soll.
Sobald ein Programm läuft | wenn ein Job in Abhängigkeit von laufenden Programmen aufgerufen werden soll.

Wenn ein Dateiereignis gewählt ist, kann in dem Bereich 'Startereignis' angegeben werden, für welche Dateien das Ereignis definiert werden soll.

In dem Eingabefeld 'Dateien' können eine oder mehrere Dateien definiert werden. Dabei können auch Jokerzeichen ('*', '?') benutzt werden. Eine neu angegebene oder geänderte Datei, muss immer mit dem Schalter 'Hinzufügen' aufgenommen werden. Wurde ein Eintrag geändert, muss der noch vorhandene alte danach gelöscht werden.

Nach dem Start eines Programms, hängt es von seiner Funktion ab, was danach geschehen soll. Auf jeden Fall muss dafür gesorgt werden, dass es nicht immer wieder durch den Scheduler aufgerufen wird. Dafür gibt es die Optionen 'Nach dem Start'. Falls das aufgerufene Programm die Datei(en) selbst löscht, verschiebt oder umbenennt, kann die Option 'Periodische Aktivierung' gewählt werden. Dann kann über die Seite 'Einstellungen' die Frequenz der Ereignisprüfung eingestellt werden.


Job Startplan Einstellungen
Zurück

Über die Startplan Einstellungen können zusätzliche Optionen für den definierten Plan gesetzt werden.

Folgende Arten von Einstellungen können definiert werden.

Ausführung | beschreibt, wie auf bestimmte Situationen, die beim Jobstart oder während der Ausführung eintreten, reagiert werden soll. Option 'Nicht starten wenn letzter Job noch läuft': Wenn ein Job des Job-Systems ausgeführt werden soll, muss das dafür notwendige Startprogramm 'JSStart' mit dem Kommandozeilenparameter '/W' angegeben werden. Dies ist notwendig, damit der Scheduler das von ihm gestartete Programm überprüfen kann.
Periodische Aktivierung | muss bei bestimmten Ereignissen definiert werden, um zu verhindern, dass die Ausführung ununterbrochen stattfindet.
Meldungen | können angegeben werden, um auf dem Rechner Start und Ende eines Jobs anzuzeigen.


Gruppen und Abteilungen
Zurück

Über dieses Register der Benutzerverwaltung werden Abteilungen und Gruppen definiert, für die Benutzer des Job-System angelegt weden sollen.

Die Benutzerverwaltung wird über das Menü 'Extras' aufgerufen.

Es gibt keine hierarchische Pflege von Abteilungen und Gruppen, sondern nur eine einfache Zuordnung.

Neuanlage einer Gruppe

Falls die Gruppe zu einer Abteilung gehört, für die schon eine Gruppe definirt ist, sollte man diese zuvor in der Liste auswählen, damit der Name der Abteilung übernommen werden kann. Sobald Gruppen- und Abteilungsname eingetragen sind, wird der Schalter 'Aufnehmen' aktiv, mit dem die neue Gruppen angelegt werden kann.

Neuanlage einer Abteilung

Da es keine hierarchische Pflege von Gruppen zu Abteilungen gibt, muss für die Neuanlage einer Abteilung auch eine dazugehörende Gruppe angelegt werden. Somit gilt hier das gleiche, wie bei der Neuanlage einer Gruppe.

Ändern oder Löschen einer oder Gruppe

Sobald eine Gruppe aus der Liste selektiert wurden, werden die Schalter 'Ändern' und 'Löschen' aktiv, mit denen eine Gruppe geändert oder gelöscht werden kann.

Ändern einer Abteilung

Sobald eine Gruppe/Abteilung aus der Liste selektiert wurden, werden die Schalter 'Ändern' und 'Löschen' aktiv, mit denen eine Abteilung geändert oder gelöscht werden kann.

Obwohl es keine hierarchische Pflege von Gruppen zu Abteilungen gibt, muss ein geänderter Name einer Abteilung nur für einen Gruppen/Abteilungs-Eintrag geändert werden. Die Änderung des Abteilungsname wird in allen Einträgen, in denen der alte Name vorhandene war, übernommen.


Listen Optionen
Zurück Weiter

Über dieses Register der Optionen können Einstellungen gemacht werden, die das Verhalten von Listen steuern.

Folgende Optionen sind möglich:

Schriftart | Die Schriftart des Textes von Zeilen aller Listen kann gesetzt werden.
Gitternetzlinien anzeigen | Zeilen und Spalten aller Listen werden durch Linien abgetrennt.
Hintergrundbild anzeigen | Ein Bildmuster wird als Hintergrund in allen Listen angezeigt.
Hoverselektion benutzen | Zeilen aller Listen werden automatisch durch Überstreichen mit dem Mauszeiger markiert.
Letzte Auswahl wiederherstellen | Die zuletzt ausgewählte Zeile einer Liste wird beim Erneuten Aufrufen des Job-System wieder angezeigt und markiert.
Gleichen Job mehrfach öffnen möglich als Standard | Wenn diese Option gesetzt ist, wird mit dem Menü 'Job öffnen' nicht geprüft, ob der gleiche Job schon in einem Fenster geöffnet ist. Das heißt, es wird dann immer das Menü 'Job öffnen in neuem Fenster' benutzt.
Beendete Jobs aus der Statusliste entfernen | Beendete Jobs werden nur bis zu der eingestellten Anzahl Tagen in der Statusliste der gestarteten Jobs angezeigt. Sie bleiben jedoch innerhalb der Job-System Datenbank bestehen, sodass durch Erhöhung der Tage auch frühere Jobs angezeigt werden können.
Protokoll-Archiv erst bei Gebrauch laden | Da das Laden der Protokolle aller bisher gelaufenen Jobs für die Ordneransicht des Protokoll-Archives je nach Anzahl sehr lange dauert, kann das Laden unterdrückt werden. Dann wird die Ordneransicht erst aufgebaut, wenn der Benutzer das Element 'Protokoll-Archiv' anklickt.


Job Optionen
Zurück Weiter

Über dieses Register der Optionen können Einstellungen gemacht werden, die das Verhalten von Jobs steuern.

Folgende Optionen sind möglich:

bei Aufruf eines Jobs folgende Seite sofort anzeigen | Anstatt der Startseite können auch die anderen Seiten automatisch angezeigt werden.
letzten Seitentyp anzeigen | Es wird jeweils der Seitentyp angezeigt, der beim letzten Job gewählt wurde.
Seitenschalter | Bestimmt das Aussehen des Schalters zum Aufrufen der Seiten.
mit Symbol | Die Symbole auf den Schaltern für die Seite können unterdrückt werden, um dadurch mehr Platz für die Anzeige der Schalter zu bekommen.
oben/unten | Bestimmt die Position des Seitenschalters.
Eingabe im Überschreibmodus | Setzt den Schreibmodus der Job-Parameter so, dass eingegebene Zeichen nicht in einen vorhandenen Text eingefügt werden, sondern diesen überschreiben.
Inhalt vorselektiert | Stellt ein, ob der Inhalt der Parameterfelder bei der Anwahl vorselektiert bzw. markiert wird.
Parameter in Fettschrift | Bei den Parameterfeldern und -listen kann zwischen Fettschrift und Normalschrift gewählt werden. Fettschrift abzuschalten ist dann vorteilhaft, wenn oft mit sehr langen Textinhalten (z.B. Dateinamen) gearbeitet wird, da sich die Länge der Parameterfelder nach deren Inhalt richtet. Dann kann der für die Parameterfelder zur Verfügung stehende Platz mit der Normalschrift besser genutzt werden.
Parameternamen in Fettschrift | Zeigt die Feldnamen in Fettschrift oder Normalschrift.
Passwortfelder speichern | Ist diese Option ausgeschaltet, werden Inhalte von Passwortfeldern bei der Neuanzeige eines Jobs nicht mit dem vorherigen Inhalt gezeigt.
Eingabefelder ausrichten | Bestimmt, ob Eingabefelder linksbündig ausgerichtet werden. Bei linksbündiger Ausrichtung wird pro Zeile nur ein Parameter angezeigt. Kann auch pro Job gesetzt werden (siehe ParamAllign).
Nur letzte Vorschau anzeigen | Wenn diese Option deaktiviert ist, werden alle Vorschauzeilen, die seit dem letzten Aufruf des Jobs erzeugt wurden, angezeigt.
n Sekunden nach Ende eines Jobs auf das Protokoll warten | Dies bezieht sich auf Jobs, die fehlerhaft beendet wurden. In diesem Fall wird automatisch das Protokoll angezeigt. Dauert das Anzeigen länger als standardmäßig vorgegeben, nimmt das Programm an, dass kein Protokoll existiert. In diesem Fall kann hier die Wartezeit erhöht werden.


Editor Optionen
Zurück

Über dieses Register der Optionen können Einstellungen gemacht werden, die das Verhalten des Job Befehls-Editors steuern.

Folgende Optionen sind möglich:

Schriftart | Die Schriftart des Befehlstextes kann gesetzt werden.
Code-Färbung | Alle bekannten Befehle des Job-Systems können in bestimmten Farben anzeigt werden. Dabei werden auch Befehle von Microsoft VBScript berücksichtigt.
Automatisch Einzug vergrößern | Beim Erzeugen einer neuen Zeile durch Drücken der Enter-Taste, wird der Einzug der vorherigen Zeile übernommen und der Cursur steht an der durch die Tab-Schrittweite eingestellten Position.
Hilfefenster integriert | Wird mit der Taste F1 die Hilfe für ein Wort aufgerufen, so kann diese in einem Fenster innerhalb des Job-Systems erscheinen.
Hilfedatei für Scriptsprache | Es kann eine Hilfedatei angegeben werden, die über das Untermenü 'Hilfe für Scriptsprache' des Hilfemenüs '?' aufgerufen werden kann. Dies ist sinnvoll, wenn in Jobs mit einer Scriptsprache gearbeitet wird.


Speicherung der Protokolle

Das Job-System legt für die Protokolldatei ein Verzeichnis an, das sich unterhalb des Verzeichnisses des entsprechenden Jobs befindet. Soll ein Job nicht protokolliert werden, so kann dies mit einem Systemschalter erreicht werden.

Der Name der Protokollverzeichnisse enthält normalerweise die UserID, mit dem der Benutzer an einem Netzwerk angemeldet ist (kann das Job-System keine UserID finden, so wird der Verzeichnisname 'JobSys' benutzt).

Wird die UserID jedoch mehrmals an verschiedenen Rechnern benutzt, so sollte zur Unterscheidung ein anderer Name für das Protokollverzeichnis benutzt werden.

Für diesen Fall kann in der Datei 'JobSys.ini', die sich im Windowsverzeichnis befindet, unter dem Abschnitt '[Datei]' eine Einstellung vorgenommen werden.

Mit dem Eintrag 'LogPfad =JobList' wird als Protokollverzeichnis der Dateiname der Job-Liste genommen (ohne Extension). Mit dem Eintrag 'LogPfad =UserIDJobList' wird die UserID und der vollständige Dateiname der Job-Liste genommen.

Welcher Verzeichnisname für eine Protokolldatei vom Job-System benutzt wurde kann man ersehen, wenn man mit der rechten Maustaste auf den Schalter 'Protokoll ' klickt.

Während des Joblaufs befindet sich das Protokoll in einem temporären Verzeichnis, aus dem heraus die Protokolldatei in das Archiv übernommen wird.


 Job Starten

Mit diesem Schalter wird der Job gestartet. Wenn noch nicht alle Parameter eingegeben wurden erscheint eine Fehlermeldung und der Job kann noch nicht gestartet werden.


Informationen

Allgemeines

Wie arbeitet das Job-System

Notation der Syntax


DATASOURCE Option
siehe auch 'TABLE' und 'TABLESELECT'

Diese Befehlsoption dient zum Abrufen von Tabellendaten aus Datenbanken und anderen tabellarischen Dateien.

Syntax:
DATASOURCE(Datenbankname,Datenbanktyp,Ansichtmodus[,Tabellenname[, Tabellenspalten]])

Alle Parameter müssen mit Komma ohne Leerzeichen getrennt eingetragen werden.

Bemerkung:
 Diese Option kann mit den Funktionen 'TABLE' und 'TABLESELECT' benutzt werden.

Der Datenbankname ist der Dateiname unter dem die Datenquelle abgespeichert ist. Wird kein Pfadname angegeben, so nimmt das Programm den Pfad an, unter dem der Job gespeichert ist.

Der Datenbanktyp beschreibt den Typ der Datenquelle. Die zu verwendende Bezeichnung muss einem installierbaren Datenbank-Treiber entsprechen. Zu beachten ist, dass in der Bezeichnung anstelle von Leerstellen das Ersatzzeichen für Leerzeichen angegeben werden muss.

Der Ansichtmodus beschreibt bei der Funktion 'TABLE', wie die Datenquelle im Tabellen-Editor angezeigt werden soll. Für mit der Option 'DATASOURCE' beschriebene Tabellen kann der Benutzer in der Ausgabetabelle über deren Kontextmenü die beschriebene Datenquelle aufrufen. Mit Ansichtmodus 'VIEW' kann die Tabelle nur angesehen werden. Mit Ansichtmodus 'EDIT' können Inhalte bearbeitet werden. Bei der Funktion 'TABLESELECT' kann hier mit der Konstanten 'OPTIONAL' erreicht werden, dass keine Fehlermeldung ausgegeben wird, wenn keine Sätze für den Zugriffsschlüssel gefunden wurden.

Tabellenname bezeichnet den Namen der Tabelle, die in der Datenbank Datenbankname gespeichert ist. Bei Access Datenbanken kann dies auch ein Abfragename sein. Bei Tabellennamen in Excel wird vom Programm automatisch ein '$'-Zeichen an den Namen angehängt, da dies zur Identifikation notwendig ist. Bei allen anderen Formaten muss Tabellenname nicht angegeben werden.

Die Tabellenspalten müssen nur angegeben werden, wenn die in den Funktionen 'TABLE' und 'TABLESELECT' angegebenen Spaltennamen nicht mit denen der Tabelle der Datenquelle identisch sind. Alle Spaltennamen müssen mit dem in den Funktionen 'TABLE' oder 'TABLESELECT' benutzten Trennzeichen (': ' oder '| ') voneinander getrennt sein. Bei Spalten aus einer Excel Tabelle werden bestimmte Sonderzeichen automatisch umgesetzt. Falls Spalten nicht in der Ausgabetabelle erscheinen, sollte man im Tabellen-Editor prüfen, wie die Namen der Spalten geschrieben werden müssen.

Hinweis:
 Tabellendaten im Access Format können schneller gelesen werden als im Excel Format. Dies macht sich bei Tabellen mit vielen Sätzen bemerkbar. Sollen die Daten mehrerer Tabellen verknüpft werden, kann man dies in einer Access Datenbank über eine Abfrage erreichen. Dies ist auch mit Tabellen aus verschiedenen Excel Dateien möglich, die in einer Access Datenbank als Tabelle verknüpft werden können.

Wird diese Option mit der Funktion 'TABLE' benutzt, so kann die zugrunde liegende Tabelle direkt über das Kontextmenü der ausgegebenen Tabelle mit dem Tabellen-Editor aufgerufen werden, ohne den Befehlseditor öffnen zu müssen. Im Befehlseditor kann der Tabellen-Editor über das Kontextmenü des markierten Wortes 'TABLE' aufgerufen werden. Ist als Tabellenausgabe eine PopUp Liste definiert worden, so wird neben dem Listenfeld ein Größerzeichen > ausgegeben; z.B. . Durch Anklicken dieses Zeichens, wird das Kontextmenü angezeigt.

Beispiel:
 Einlesen einer Tabelle aus einer Access Datenbank. Die Spaltennamen der Tabelle entsprechen den Namen, die in der Ausgabetabelle angezeigt werden sollen. Access ist das Standard Format und muss nicht als Datenbanktyp angegeben werden. Die Tabelle darf vom Benutzer mit dem Tabellen-Editor bearbeitet werden.

/Parameter: DBs=%DB%=TABLE{(Country~Code|Client|ClientPath,%CC%|%Client%|%ClPath%,1|2|3,>|>|>, DataSource(proddb.mdb,,EDIT,Database~Information))

Beispiel:
 Einlesen einer Tabelle aus einer Access Datenbank. Die Spaltennamen der Tabelle entsprechen nicht den Namen, die in der Ausgabetabelle angezeigt werden sollen.

/Parameter: DBs=%DB%=TABLE{(%CC%|%Client%|%ClPath%,1|2|3,>|>|>, DataSource(proddb.mdb,,EDIT,Database~Information,Country~Code|Client|ClientPath))

Beispiel:
 Einlesen einer Tabelle aus einer Excel Datei. Die Spaltenüberschrift 'Hersteller-kürzel' besitzt einen Zeilenwechsel zwischen den Texten 'Hersteller-' und 'kürzel'. Es muss das Zeichen '_' in den Spaltennamen eingefügt werden.

/Parameter: DBs=%DB%=TABLE{(%Fir%|%Anrede%|%E-Mail%,Y|Y|Y,BYG|>|>=, DataSource(SAdress.xls,Excel~8.0,VIEW, Tabelle1,Hersteller-_kürzel|pers.Anrede|E-Mail))

Beispiel:
 Einlesen einer Tabelle aus einer Text Datei. Ein Tabellenname muss nicht angegeben werden.

/Parameter: DBs=%DB%=TABLE{(%Fir%|%Anrede%|%E-Mail%,Y|Y|Y,BYG|>|>=,DataSource( MAdress.txt,Text,VIEW))


 Datenbank-Treiber können folgende Bezeichnung haben:

Access
dBASE III
dBASE IV
dBASE 5.0
Excel 3.0
Excel 4.0
Excel 5.0
Excel 8.0
Foxpro 2.0
Foxpro 2.5
Foxpro 2.6
Foxpro 3.0
Lotus WK1
Lotus WK3
Lotus WK4
Paradox 3.x
Paradox 4.x
Paradox 5.x
Text


Lizenzvereinbarung für Info-Zip

This is version 1999-Oct-05 of the Info-ZIP copyright and license.
The definitive version of this document should be available at
ftp://ftp.cdrom.com/pub/infozip/license.html indefinitely.

Copyright (c) 1990-1999 Info-ZIP. All rights reserved.

For the purposes of this copyright and license, "Info-ZIP" is defined as
the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois,
Jean-loup Gailly, Hunter Goatley, Ian Gorman, Chris Herborth, Dirk Haase,
Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum,
Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller,
Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel,
Steve Salisbury, Dave Smith, Christian Spieler, Antoine Verheijen,
Paul von Behren, Rich Wales, Mike White

This software is provided "as is," without warranty of any kind, express
or implied. In no event shall Info-ZIP or its contributors be held liable
for any direct, indirect, incidental, special or consequential damages
arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose,
including commercial applications, and to alter it and redistribute it
freely, subject to the following restrictions:

1. Redistributions of source code must retain the above copyright notice,
definition, disclaimer, and this list of conditions.

2. Redistributions in binary form must reproduce the above copyright
notice, definition, disclaimer, and this list of conditions in
documentation and/or other materials provided with the distribution.

3. Altered versions--including, but not limited to, ports to new operating
systems, existing ports with new graphical interfaces, and dynamic,
shared, or static library versions--must be plainly marked as such
and must not be misrepresented as being the original source. Such
altered versions also must not be misrepresented as being Info-ZIP
releases--including, but not limited to, labeling of the altered
versions with the names "Info-ZIP" (or any variation thereof, including,
but not limited to, different capitalizations), "Pocket UnZip," "WiZ"
or "MacZip" without the explicit permission of Info-ZIP. Such altered
versions are further prohibited from misrepresentative use of the
Zip-Bugs or Info-ZIP e-mail addresses or of the Info-ZIP URL(s).

4. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip,"
"WiZ," "Pocket UnZip," "Pocket Zip," and "MacZip" for its own source and
binary releases.


Lizenzvereinbarung für SocketWrench

1. GRANT OF LICENSE

In this license agreement ("License"), Catalyst Development Corporation("Catalyst") grants you, the developer, the right to use one copy of the software developers kit entitled "Catalyst SocketWrench" ("Software"). You may distribute it to others, provided that the Software is redistributed in it's original unmodified form, complete with all files, and no fee is charged for such distribution except for reasonable media and shipping charges.

2. DISTRIBUTION

The developer does retain the right to sell or distribute an unlimited number of end-user programs that contain or otherwise access the Software, so long as the primary purpose of the included routines is to augment the programs being sold or distributed. The developer may not distribute any source modules, header files or import libraries that comprise the Software. THE DEVELOPER MAY NOT DISTRIBUTE PROGRAMS THAT UTILIZE CATALYST ROUTINES IF THOSE PROGRAMS ARE PART OF A PROGRAMMING TOOLKIT OR OTHER APPLICATION WHICH WILL BE REDISTRIBUTED OR RESOLD BY THE DEVELOPER'S CUSTOMERS. The developer agrees to include a valid copyright notice on all programs distributed with Catalyst component routines, and agrees to indemnify, hold harmless and defend the copyright holder against any claims or lawsuits, including attorney's fees, that arise from the distribution of the end-user programs. The Software is free of royalty and/or subsequent licensing fees in accordance with the above stated conditions.

3. COPYRIGHT

The Software is owned by Catalyst or its suppliers or licensors and is protected by copyright laws and international treaty provisions. Therefore, you must treat the Software like any other copyrighted material, except that you may copy and redistribute the Software in accordance with this License.

4. OTHER RESTRICTIONS

You may not rent, lease or loan the Software, but you may redistribute the Software and accompanying written materials in accordance with the terms of this Agreement. You may not reverse engineer, decompile or disassemble the Software, except to the extent the foregoing restriction is expressly prohibited by applicable law.

5. NO WARRANTY

The Software is provided "as is", without warranty of any kind, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Should the Software prove defective, you assume the cost of all necessary servicing, repair or correction. Some states do not allow limitations on implied warranties, so the above limitations may not apply to you.

6. LIMITATION OF LIABILITY

In no event shall Catalyst or its suppliers be liable for any damages whatsoever (including, with limitation, damages for loss of business profits, business interruption, or other pecuniary loss) arising out of the use or inability of this Catalyst product, even if Catalyst has been advised of such damages.

7. GOVERNMENT-RESTRICTED RIGHTS

The Software and accompanying documentation are deemed to be "commercial computer software" and "commercial computer software documentation", respectively, pursuant to DFAR Section 227.7202 and FAR Section 12.212, as applicable. Any use, modification, reproduction release, performance, display or disclosure of the software and accompanying documentation by the U.S. Government shall be governed solely by the terms of this Agreement and shall be prohibited except to the extent expressly permitted by the terms of this Agreement.

8. GOVERNING LAW

This License is governed by the laws of the State of California, without reference to conflict of laws principles. This Agreement is the entire agreement between you and Catalyst and supersedes any other communications or advertising with respect to the Software and documentation. If any provision of this License is held invalid, the remainder of this License shall continue in full force and effect.


 Konstanten für die Funktion JSBatch.GetLocalInfo

(entsprechen den Konstanten, die mit der System Funktion 'GetLocalInfo' benutzt werden).

Value | Constant | Name Description
&H1 | LOCALE_ILANGUAGE | Language identifier indicating the language. The maximum number of characters allowed for this string is 5
&H2 | LOCALE_SLANGUAGE | Full localized name of the language
&H1001 | LOCALE_SENGLANGUAGE | Full English name of the language from the International Organization for Standardization (ISO) Standard 639. This is always restricted to characters mappable into the ASCII 127-character subset
&H3 | LOCALE_SABBREVLANGNAME | Abbreviated name of the language, created by taking the 2-letter language abbreviation from the ISO Standard 639 and adding a third letter, as appropriate, to indicate the sublanguage
&H4 | LOCALE_SNATIVELANGNAME | Native name of the language
 | LOCALE_SSORTNAME | The full localized name of the sort for the given locale ID
&H5 | LOCALE_ICOUNTRY | Country code, based on international phone codes, also referred to as IBM country codes. The maximum number of characters allowed for this string is 6
&H6 | LOCALE_SCOUNTRY | Full localized name of the country
&H1002 | LOCALE_SENGCOUNTRY | Full English name of the country. This is always restricted to characters mappable into the ASCII 127-character subset
&H7 | LOCALE_SABBREVCTRYNAME | Abbreviated name of the country from the ISO Standard 3166
&H8 | LOCALE_SNATIVECTRYNAME | Native name of the country
&H9 | LOCALE_IDEFAULTLANGUAGE | Language identifier for the principal language spoken in this locale. This is provided so that partially specified locales can be completed with default values. The maximum number of characters allowed for this string is 5
&HA | LOCALE_IDEFAULTCOUNTRY | Country code for the principal country in this locale. This is provided so that partially specified locales can be completed with default values. The maximum number of characters allowed for this string is 6
 | LOCALE_IDEFAULTANSICODEPAGE | American National Standards Institute (ANSI) code page associated with this locale. The maximum number of characters allowed for this string is 6
 | LOCALE_IDEFAULTOEMCODEPAGE | Original equipment manufacturer (OEM) code page associated with the locale. The maximum number of characters allowed for this string is 6
&HB | LOCALE_IDEFAULTCODEPAGE | Original equipment manufacturer (OEM) code page associated with the country. The maximum number of characters allowed for this string is 6
 | LOCALE_IDEFAULTEBCDICCODEPAGE | Default EBCDIC code page associated with the locale. The maximum number of characters allowed for this string is 6
&HC | LOCALE_SLIST | Character(s) used to separate list items. For example, a comma is used in many locales
&HD | LOCALE_IMEASURE | System of measurement. This value is 0 if the metric system (Systéme International d'Unités, or S.I.) is used and 1 if the U.S. system is used. The maximum number of characters allowed for this string is 2
&HE | LOCALE_SDECIMAL | Character(s) used as the decimal separator
&HF | LOCALE_STHOUSAND | Character(s) used to separate groups of digits to the left of the decimal
&H10 | LOCALE_SGROUPING | Sizes for each group of digits to the left of the decimal. An explicit size is needed for each group; sizes are separated by semicolons. If the last value is zero, the preceding value is repeated. To group thousands, specify 3;0, for example
&H11 | LOCALE_IDIGITS | Number of fractional digits. The maximum number of characters allowed for this string is 3
&H12 | LOCALE_ILZERO | Specifier for leading zeros in decimal fields. The maximum number of characters allowed for this string is 2. The specifier can be one of the following values:
 | Return Value | Meaning
 | 0 | No leading zeros
 | 1 | Leading zeros
 | LOCALE_INEGNUMBER | Negative number mode. The mode can be one of these values:
 | Return Value | Meaning
 | 0 | (1.1)
 | 1 | –1.1
 | 2 | – 1.1
 | 3 | 1.1–
 | 4 | 1.1 –
&H13 | LOCALE_SNATIVEDIGITS | Native equivalents to ASCII 0 through 9
 | LOCALE_SENGCURRNAME | The full English name of the currency associated with the locale
 | LOCALE_SNATIVECURRNAME | The native name of the currency associated with the locale
&H14 | LOCALE_SCURRENCY | String used as the local monetary symbol
&H15 | LOCALE_SINTLSYMBOL | Three characters of the international monetary symbol specified in ISO 4217, "Codes for the Representation of Currencies and Funds," followed by the character separating this string from the amount
&H16 | LOCALE_SMONDECIMALSEP | Character(s) used as the monetary decimal separator
&H17 | LOCALE_SMONTHOUSANDSEP | Character(s) used as the monetary separator between groups of digits to the left of the decimal
&H18 | LOCALE_SMONGROUPING | Sizes for each group of monetary digits to the left of the decimal. An explicit size is needed for each group; sizes are separated by semicolons. If the last value is zero, the preceding value is repeated. To group thousands, specify 3;0, for example
&H19 | LOCALE_ICURRDIGITS | Number of fractional digits for the local monetary format. The maximum number of characters allowed for this string is 3
&H1A | LOCALE_IINTLCURRDIGITS | Number of fractional digits for the international monetary format. The maximum number of characters allowed for this string is 3
&H1B | LOCALE_ICURRENCY | Positive currency mode. The maximum number of characters allowed for this string is 2. The mode can be one of the following values:
 | Return Value | Meaning
 | 0 | Prefix, no separation
 | 1 | Suffix, no separation
 | 2 | Prefix, 1-char. separation
 | 3 | Suffix, 1-char. separation
&H1C | LOCALE_INEGCURR | Negative currency mode. The maximum number of characters allowed for this string is 3. The mode can be one of the following values:
 | Return Value | Example
 | 0 | ($1.1)
 | 1 | –$1.1
 | 2 | $–1.1
 | 3 | $1.1–
 | 4 | (1.1$)
 | 5 | –1.1$
 | 6 | 1.1–$
 | 7 | 1.1$–
 | 8 | –1.1 $ (space before $)
 | 9 | –$ 1.1 (space after $)
 | 10 | 1.1 $– (space before $)
 | 11 | $ 1.1– (space after $)
 | 12 | $ –1.1 (space after $)
 | 13 | 1.1– $ (space before $)
 | 14 | ($ 1.1) (space after $)
 | 15 | (1.1 $) (space before $)
&H1D | LOCALE_SDATE | Character(s) for the date separator
&H1E | LOCALE_STIME | Character(s) for the time separator
&H1003 | LOCALE_STIMEFORMAT | Time formatting strings for this locale. The string can consist of a combination of the hour, minute, and second format pictures defined in the table in National Language Support Constants
 | LOCALE_SYEARMONTH | The Year/Month formatting string for the locale. This string shows the proper format for a date string that contains only the year and the month
&H1F | LOCALE_SSHORTDATE | Short date formatting string for this locale. The string can consist of a combination of day, month, and year format pictures defined in table in National Language Support Constants
&H20 | LOCALE_SLONGDATE | Long date formatting string for this locale. The string can consist of a combination of day, month, and year format pictures defined in the table in National Language Support Constants and any string of characters enclosed in single quotes. Characters in single quotes remain as given
&H21 | LOCALE_IDATE | Short date format-ordering specifier. The maximum number of characters allowed for this string is 2. The specifier can be one of the following values:
 | Return Value | Meaning
 | 0 | Month-Day-Year
 | 1 | Day-Month-Year
 | 2 | Year-Month-Day
&H22 | LOCALE_ILDATE | Long date format-ordering specifier. The maximum number of characters allowed for this string is 2. The specifier can be one of the following values:
 | Return Value | Meaning
 | 0 | Month-Day-Year
 | 1 | Day-Month-Year
 | 2 | Year-Month-Day
&H23 | LOCALE_ITIME | Time format specifier. The maximum number of characters allowed for this string is 2. The specifier can be one of the following values:
 | Return Value | Meaning
 | 0 | AM / PM 12-hour format
 | 1 | 24-hour format
&H24 | LOCALE_ICENTURY | Specifier for full 4-digit century. The maximum number of characters allowed for this string is 2. The specifier can be one of the following values:
 | Return Value | Meaning
 | 0 | Abbreviated 2-digit century
 | 1 | Full 4-digit century
&H25 | LOCALE_ITLZERO | Specifier for leading zeros in time fields. The maximum number of characters allowed for this string is 2. The specifier can be one of the following values:
 | Return Value | Meaning
 | 0 | No leading zeros for hours
 | 1 | Leading zeros for hours
&H26 | LOCALE_IDAYLZERO | Specifier for leading zeros in day fields. The maximum number of characters allowed for this string is 2. The specifier can be one of the following values:
 | Return Value | Meaning
 | 0 | No leading zeros for days
 | 1 | Leading zeros for days
&H27 | LOCALE_IMONLZERO | Specifier for leading zeros in month fields. The maximum number of characters allowed for this string is 2. The specifier can be one of the following values:
 | Return Value | Meaning
 | 0 | No leading zeros for months
 | 1 | Leading zeros for months
&H28 | LOCALE_S1159 | String for the AM designator
&H29 | LOCALE_S2359 | String for the PM designator
 | LOCALE_ICALENDARTYPE | Current calendar type. This type can be one of these values:
 | Return Value | Meaning
 | 1 | Gregorian (as in United States)
 | 2 | Gregorian (English strings always)
 | 3 | Era: Year of the Emperor (Japan)
 | 4 | Era: Year of Taiwan Region
 | 5 | Tangun Era (Korea)
LOCALE_IOPTIONALCALENDAR | Additional calendar types. This can be a zero-separated list of one or more of these calendars type values:
Return Value | Meaning
0 | No additional types valid
1 | Gregorian (as in United States)
2 | Gregorian (English strings always)
3 | Era: Year of the Emperor (Japan)
4 | Era: Year of Taiwan Region
5 | Tangun Era (Korea)
LOCALE_IFIRSTDAYOFWEEK | Specifier for the first day in a week. The specifier can be one of these values:
Return Value | Meaning
0 | LOCALE_SDAYNAME1
1 | LOCALE_SDAYNAME2
2 | LOCALE_SDAYNAME3
3 | LOCALE_SDAYNAME4
4 | LOCALE_SDAYNAME5
5 | LOCALE_SDAYNAME6
6 | LOCALE_SDAYNAME7
LOCALE_IFIRSTWEEKOFYEAR | Specifier for the first week of the year. The specifier can be one of these values:
Return Value | Meaning
0 | Week containing 1/1 is the first week of that year
1 | First full week following 1/1 is the first week of that year
2 | First week containing at least 4 days is the first week of that year
&H2A | LOCALE_SDAYNAME1 | Native long name for Monday
&H2B | LOCALE_SDAYNAME2 | Native long name for Tuesday
&H2C | LOCALE_SDAYNAME3 | Native long name for Wednesday
&H2D | LOCALE_SDAYNAME4 | Native long name for Thursday
&H2E | LOCALE_SDAYNAME5 | Native long name for Friday
&H2F | LOCALE_SDAYNAME6 | long name for Saturday
&H30 | LOCALE_SDAYNAME7 | Native long name for Sunday
&H31 | LOCALE_SABBREVDAYNAME1 | Native abbreviated name for Monday
&H32 | LOCALE_SABBREVDAYNAME2 | Native abbreviated name for Tuesday
&H33 | LOCALE_SABBREVDAYNAME3 | Native abbreviated name for Wednesday
&H34 | LOCALE_SABBREVDAYNAME4 | Native abbreviated name for Thursday
&H35 | LOCALE_SABBREVDAYNAME5 | Native abbreviated name for Friday
&H36 | LOCALE_SABBREVDAYNAME6 | Native abbreviated name for Saturday
&H37 | LOCALE_SABBREVDAYNAME7 | Native abbreviated name for Sunday
&H38 | LOCALE_SMONTHNAME1 | Native long name for January
&H39 | LOCALE_SMONTHNAME2 | Native long name for February
&H3A | LOCALE_SMONTHNAME3 | Native long name for March
&H3B | LOCALE_SMONTHNAME4 | Native long name for April
&H3C | LOCALE_SMONTHNAME5 | Native long name for May
&H3D | LOCALE_SMONTHNAME6 | Native long name for June
&H3E | LOCALE_SMONTHNAME7 | Native long name for July
&H3F | LOCALE_SMONTHNAME8 | Native long name for August
&H40 | LOCALE_SMONTHNAME9 | Native long name for September
&H41 | LOCALE_SMONTHNAME10 | Native long name for October
&H42 | LOCALE_SMONTHNAME11 | Native long name for November
&H43 | LOCALE_SMONTHNAME12 | Native long name for December
 | LOCALE_SMONTHNAME13 | Native name for 13th month, if exists
&H44 | LOCALE_SABBREVMONTHNAME1 | Native abbreviated name for January
&H45 | LOCALE_SABBREVMONTHNAME2 | Native abbreviated name for February
&H46 | LOCALE_SABBREVMONTHNAME3 | Native abbreviated name for March
&H47 | LOCALE_SABBREVMONTHNAME4 | Native abbreviated name for April
&H48 | LOCALE_SABBREVMONTHNAME5 | Native abbreviated name for May
&H49 | LOCALE_SABBREVMONTHNAME6 | Native abbreviated name for June
&H4A | LOCALE_SABBREVMONTHNAME7 | Native abbreviated name for July
&H4B | LOCALE_SABBREVMONTHNAME8 | Native abbreviated name for August
&H4C | LOCALE_SABBREVMONTHNAME9 | Native abbreviated name for September
&H4D | LOCALE_SABBREVMONTHNAME10 | Native abbreviated name for October
&H4E | LOCALE_SABBREVMONTHNAME11 | Native abbreviated name for November
&H4F | LOCALE_SABBREVMONTHNAME12 | Native abbreviated name for December
&H100F | LOCALE_SABBREVMONTHNAME13 | Native abbreviated name for 13th month, if exists
&H50 | LOCALE_SPOSITIVESIGN | String value for the positive sign
&H51 | LOCALE_SNEGATIVESIGN | String value for the negative sign
&H52 | LOCALE_IPOSSIGNPOSN | Formatting index for positive values. The maximum number of characters allowed for this string is 2. The index can be one of the following values:
 | Return Value | Meaning
 | 0 | Parentheses surround the amount and the monetary symbol
 | 1 | The sign string precedes the amount and the monetary symbol
 | 2 | The sign string succeeds the amount and the monetary symbol
 | 3 | The sign string immediately precedes the monetary symbol
 | 4 | The sign string immediately succeeds the monetary symbol
&H53 | LOCALE_INEGSIGNPOSN | Formatting index for negative values. This index uses the same values as LOCALE_IPOSSIGNPOSN. The maximum number of characters allowed for this string is 2
&H54 | LOCALE_IPOSSYMPRECEDES | Position of monetary symbol in a positive monetary value. This value is 1 if the monetary symbol precedes the positive amount, 0 if it follows it. The maximum number of characters allowed for this string is 2
&H55 | LOCALE_IPOSSEPBYSPACE | Separation of monetary symbol in a positive monetary value. This value is 1 if the monetary symbol is separated by a space from a positive amount, 0 if it is not. The maximum number of characters allowed for this string is 2
 | LOCALE_INEGSYMPRECEDES | Position of monetary symbol in a negative monetary value. This value is 1 if the monetary symbol precedes the negative amount, 0 if it follows it. The maximum number of characters allowed for this string is 2
&H57 | LOCALE_INEGSEPBYSPACE | Separation of monetary symbol in a negative monetary value. This value is 1 if the monetary symbol is separated by a space from the negative amount, 0 if it is not. The maximum number of characters allowed for this string is 2
 | LOCALE_IPAPERSIZE | Default paper size associated with the locale
&H80000000 LOCALE_NOUSEROVERRIDE This constant may be OR'ed with any other constant type in a call to the function. This always causes the function to bypass any user overrides, and return the system default value for the other constant type specified in the function call, based on the default user local


Datensatz-Editor

Tabellen-Editor - Ansicht Datensatz
Zurück

Mit der Datensatzansicht kann ein einzelner Datensatz einer Tabelle angesehen und bearbeitet werden.

Auf die Datensatzansicht kann mit dem Schalter [image] in der Toolbar umgeschaltet werden. Dabei wird der in der Tabelle aktuell markierte Datensatz angezeigt. Zurück zur Tabellenansicht kommt man mit dem Schalter [image].

Das Datensatz-Fenster

In der linken Spalte sind die Feldnamen aufgelistet. In der rechten Spalte, die dazu gehörenden Feldinhalte.

Felder mit dem Datenformat 'Memo' werden mit der Höhe von 4 Zeilen angezeigt. Falls ein Feld einen Dateinamen enthält, kann über das Kontextmenü des Feldes ein Editor aufgerufen werden.

Wenn das Fenster zu klein ist, können die nicht sichtbaren Felder mit dem erscheinenden rechten Rollbalken erreicht werden.

Mit dem Rollbalken am unteren Rand kann der letzte oder nächste Datensatz der Tabelle angezeigt werden. Wird auf die Tabellenansicht umgeschaltet, ist dort der aktuelle Datensatz markiert. Mit dem Schalter [image] kann ein ein neuer Datensatz angelegt werden.

Die Tabellen-Editor-Menüs